quodlibet can't read embedded cover art in ogg files

Bug #930808 reported by David López on 2012-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
quodlibet (Ubuntu)
Undecided
Unassigned

Bug Description

1) I use ubuntu 11.10 64 bits

2) I've installed quodlibet 2.3.2.99-0~rev5017~63ad0924efc9~ppa1~oneiric

3) I expected that quodlibet can read the embedded covers in my ogg files (according to http://code.google.com/p/quodlibet/wiki/FAQ embedded cover art is pupported in some formats, and according to http://code.google.com/p/quodlibet/wiki/Development_TagMapping it can load embedded pictures in Ogg Vorbis / Ogg FLAC / Ogg Speex).

4) quodlibet doesn't read the embedded cover art from my ogg files (please note that some other applications as banshee and nautilus can read them).

For your information, I've tested quodlibet 2.3.2-1 in precise alpha2 32bits in virtualbox with the same results. I used easytag to insert the covers in the ogg files.

Is this a bug or actually quod libet doesn't support this feature for ogg files? Thanks.

----------------------

1) Uso ubuntu 11.10 64 bits

2) He instalado quodlibet 2.3.2.99-0~rev5017~63ad0924efc9~ppa1~oneiric

3) Esperaría que quodlibet leyera las portadas insertadas enpara insertar las portadas en los archivos ogg mis archivos oggc (según http://code.google.com/p/quodlibet/wiki/FAQ quodlibet puede leer portadas incluidas en algunos formatos, y según http://code.google.com/p/quodlibet/wiki/Development_TagMapping se pueden cargar imágenes insertadas en Ogg Vorbis / Ogg FLAC / Ogg Speex).

4) quodlibet no lee las imágenes de mis archivos ogg (otras aplicaciones como banshee y nautilus sí las leen).

Para vuestra información, he probado quodlibet 2.3.2-1 en precise alpha2 32bits en virtualbox con los mismos resultados. Para insertar las portadas en los archivos ogg usé easytag.

¿Es un fallo o quodlibet no tiene implementada la opción de leer las imágenes de los archivos ogg? Gracias.

Christoph Reiter (lazka) wrote :

Please use the new version in the ppa.

If that doesn't work, send me one affected file per mail.

thanks

David López (david-lopez-upct) wrote :

Hi Christoph. I've updated to 2.3.2.99-0~rev5025~865a560ecc38~ppa1~oneiric, but the problem has not solved. I sent you an e-mail.

Christoph Reiter (lazka) wrote :

Thanks David,

this really got fixed just yesterday and is in the version you updated to.

One thing I forgot to mention: You need to reload the library (Music > Reload Library) for it to work.

The problem is that embedding album art isn't standardized in ogg files and some programs do their own thing.

Changed in quodlibet (Ubuntu):
status: New → Fix Committed
David López (david-lopez-upct) wrote :

Thanks for your quick answer, Christoph. I've reloaded the library and now quodlibet read the art when I listen to a song (that is, I can see the cover in the right upper corner of quodlibet and in the transparent window with huge fonts that appears a few seconds in the upper center of my desktop).

However there's still a problem, most of the covers don't appear in the album list view, I attach you an image. All my albums have an embedded cover in the first song of the album, but in the picture yo can see that only a few are shown in the album list. 'Reload album cover' doesn't seem to do anything. And something more weird, if I close and reopen quodlibet then the album list view show the covers of different albums. That is, there are covers that sometimes are shown in the album list view and sometimes there are not shown. And some others, as the song I sent you by e-mail, are never shown in the album list.

By the way, I've noticed that 'coverart' and 'coverartmime' tags have dissapeared in quod libet and ex falso, I don't know if it is normal.

Christoph Reiter (lazka) wrote :

At the moment a random song gets used for finding album art.

This needs to be improved.

David López (david-lopez-upct) wrote :

Thanks Christoph. Any idea when this will be done? I can be a good tester, I have lots of albums with embedded art ogg files.

Christoph Reiter (lazka) wrote :

No idea.

I'll write here when I have something working..

Jackson Doak (noskcaj) on 2015-07-06
Changed in quodlibet (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.