Quod Libet display disappeared after update

Bug #1155431 reported by BertN45 on 2013-03-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
quodlibet (Ubuntu)
Undecided
Unassigned

Bug Description

The display of quod libet disappeared foe a large part after the last update of Ubuntu 13.04. What disppeared are the list of albums and the list of songs of an album.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: xorg 1:7.7+1ubuntu4
ProcVersionSignature: Ubuntu 3.8.0-12.21-generic 3.8.2
Uname: Linux 3.8.0-12-generic i686
.tmp.unity.support.test.0:

ApportVersion: 2.9.1-0ubuntu1
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDmesg:

Date: Thu Mar 14 23:37:20 2013
DistUpgraded: Fresh install
DistroCodename: raring
DistroVariant: ubuntu
ExtraDebuggingInterest: Yes
GraphicsCard:
 Intel Corporation 82915G/GV/910GL Integrated Graphics Controller [8086:2582] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3005]
   Subsystem: Hewlett-Packard Company Device [103c:3005]
InstallationDate: Installed on 2012-11-08 (126 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20121107.2)
MachineType: Hewlett-Packard HP Compaq dc7100 CMT(PP480US)
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-12-generic root=UUID=6b5e059b-288d-4540-950f-c6cecdaeb48c ro quiet splash
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/16/2004
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 786C1 v01.05
dmi.board.name: 0968h
dmi.board.vendor: Hewlett-Packard
dmi.chassis.asset.tag: 2UA5310HC5
dmi.chassis.type: 6
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr786C1v01.05:bd06/16/2004:svnHewlett-Packard:pnHPCompaqdc7100CMT(PP480US):pvr:rvnHewlett-Packard:rn0968h:rvr:cvnHewlett-Packard:ct6:cvr:
dmi.product.name: HP Compaq dc7100 CMT(PP480US)
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.9~daily13.03.08-0ubuntu1
version.libdrm2: libdrm2 2.4.42-0ubuntu2
version.libgl1-mesa-dri: libgl1-mesa-dri 9.0.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 9.0.2-0ubuntu1
version.xserver-xorg-core: xserver-xorg-core 2:1.13.2-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.3-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.1.0-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.21.4-0ubuntu1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.6-0ubuntu3
xserver.bootTime: Thu Mar 14 22:09:20 2013
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input SEJIN SEJIN USB joint Keyboard KEYBOARD, id 8
 input saa7134 IR (Encore ENLTV) KEYBOARD, id 9
 input ImPS/2 Logitech Wheel Mouse MOUSE, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.version: 2:1.13.2-0ubuntu3
xserver.video_driver: intel

BertN45 (lammert-nijhof) wrote :
Timo Aaltonen (tjaalton) wrote :

Define 'last update'?

quodlibet hasn't changed since last May, so it's caused by something else.

affects: xorg (Ubuntu) → xserver-xorg-video-intel (Ubuntu)
Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Incomplete
Chris Wilson (ickle) wrote :

Worksforme on pnv with raring.

Bryce Harrington (bryce) on 2013-04-01
Changed in xserver-xorg-video-intel (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Christoph Reiter (lazka) wrote :

This is a python-gobject-2 bug introduced by the fix in https://bugs.launchpad.net/ubuntu/+source/pygobject-2/+bug/1129309

It's only in combination with QL 2.5 which isn't in Ubuntu. 2.5.1 has a workaround and will be released soon.
Possible workarround: use the QL unstable PPA.

affects: xserver-xorg-video-intel (Ubuntu) → quodlibet (Ubuntu)
Changed in quodlibet (Ubuntu):
status: Incomplete → In Progress
Christoph Reiter (lazka) wrote :

2.5.1 is out

Changed in quodlibet (Ubuntu):
status: In Progress → Fix Committed
Christoph Reiter (lazka) wrote :

3.0.2 now in trusty

Changed in quodlibet (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.