Quickly project fails to run

Bug #840408 reported by Tan Kah Ping on 2011-09-03
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Quickly
High
Didier Roche
quickly (Ubuntu)
High
Unassigned

Bug Description

Software made with Quickly fail to run. Create a new ubuntu-application and you get:

Creating project directory foobar
Creating bzr repository and committing
Launching your newly created project!

(foobar:26741): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(foobar:26741): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(foobar:26741): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(foobar:26741): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
Traceback (most recent call last):
  File "./foobar", line 32, in <module>
    import foobar
  File "/home/kahping/foobar/foobar/__init__.py", line 14, in <module>
    from foobar import FoobarWindow
  File "/home/kahping/foobar/foobar/FoobarWindow.py", line 14, in <module>
    from foobar_lib import Window
  File "/home/kahping/foobar/foobar_lib/__init__.py", line 9, in <module>
    from . helpers import set_up_logging
  File "/home/kahping/foobar/foobar_lib/helpers.py", line 13, in <module>
    from . Builder import Builder
  File "/home/kahping/foobar/foobar_lib/Builder.py", line 8, in <module>
    from gi.repository import GObject # pylint: disable=E0611
  File "/usr/lib/python2.7/dist-packages/gi/__init__.py", line 23, in <module>
    from ._gi import _API, Repository
ImportError: could not import gobject (error was: ImportError('When using gi.repository you must not import static modules like "gobject". Please change all occurrences of "import gobject" to "from gi.repository import GObject".',))
Congrats, your new project is setup! cd /home/kahping/foobar/ to start hacking.

Looks like it's something to do with gi.repository

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: quickly 11.06-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
Architecture: amd64
CheckboxSubmission: 8861f1385669c9b7871898f4d29776e4
CheckboxSystem: 2a6f54df59af338184485e85cbcf0d32
Date: Sat Sep 3 23:33:11 2011
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
QuicklyDataPath: /usr/share/quickly
QuicklyTemplates:
 /usr/share/quickly/templates/ubuntu-flash-game
 /usr/share/quickly/templates/ubuntu-pygame
 /usr/share/quickly/templates/ubuntu-application
 /usr/share/quickly/templates/ubuntu-cli
QuicklyTemplatesDirectories: /usr/share/quickly/templates/
SourcePackage: quickly
UpgradeStatus: No upgrade log present (probably fresh install)

Tan Kah Ping (kahping) wrote :
Changed in quickly (Ubuntu):
status: New → Confirmed
Didier Roche (didrocks) wrote :

Thanks a lot for this bug report and help to make Quickly better! It's now fixed in oneiric and you will be able to recreate your project with the new version once it's uploaded :)

Changed in quickly:
status: New → Fix Committed
Changed in quickly (Ubuntu):
status: Confirmed → Fix Committed
Changed in quickly:
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → High
Changed in quickly (Ubuntu):
importance: Undecided → High
Michael Terry (mterry) on 2011-09-12
Changed in quickly:
milestone: none → 11.09
Michael Terry (mterry) on 2011-09-12
Changed in quickly:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quickly - 11.09-0ubuntu1

---------------
quickly (11.09-0ubuntu1) oneiric; urgency=low

  * New upstream release
    + ubuntu-application:
      - add: Make indicator code set its icon to the project icon (Tony
        Byrne)
      - design: Call new 'glade' executable, not 'glade-3' (Paolo
        Sammicheli)
      - upgrade: Better detection for whether to use new /opt code (Tony
        Byrne)
      - Fix some mistakes in the tutorial (LP: #822972)
      - Don't mix PyGI and PyGObject calls in project code (LP: #840408)
    + common:
      - A lot of string cleanup and translation fixes (Paolo Sammicheli)
      - Updated translations
  * Update packaging to dh8, source format 3.0, and dh_python2
 -- Michael Terry <email address hidden> Mon, 12 Sep 2011 15:54:47 -0400

Changed in quickly (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers