Ubuntu

Latest python-distutils-extra broke quickly submitubuntu

Reported by Didier Roche on 2012-07-09
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Quickly
Undecided
Didier Roche
quickly (Ubuntu)
Undecided
Didier Roche
Precise
Undecided
Unassigned

Bug Description

[ Test Case ]
1. install latest quickly and latest python-distutils-extra from -proposed
2. run quickly submitubuntu

-> you shouldn't get any error

[ Regression potential ]
Still work in a fallback mode with older python-distutils-extra

People get:
Traceback (most recent call last):
  File "/usr/share/quickly/templates/ubuntu-application/package.py", line 83, in <module>
    if packaging.updatepackaging(no_changelog=True, installopt=for_extras) != 0:
  File "/usr/share/quickly/templates/ubuntu-application/internal/packaging.py", line 322, in updatepackaging
    update_rules()
  File "/usr/share/quickly/templates/ubuntu-application/internal/packaging.py", line 260, in update_rules
    " debhelper (>= 6), libglib2.0-bin,")
  File "/usr/lib/python2.7/dist-packages/quickly/templatetools.py", line 137, in update_file_content
    raise CantUpdateFile(_("%s was not found in the file %s.") % (start_marker, ftarget_file_name.name))

Didier Roche (didrocks) on 2012-07-09
Changed in quickly (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) on 2012-07-09
Changed in quickly:
assignee: nobody → Didier Roche (didrocks)
status: New → Fix Released
Changed in quickly (Ubuntu):
status: New → Fix Committed
David Planella (dpm) on 2012-07-09
tags: added: arb

Hello Didier, or anyone else affected,

Accepted quickly into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/quickly/12.04-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in quickly (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

seems to work fine here

tags: added: verification-done
removed: verification-needed
Scott Kitterman (kitterman) wrote :

Needs fixing in Quantal (apparently) before it can be copied over.

Scott Kitterman (kitterman) wrote :

Switching back to verification needed since it needs verification it's fixed in quantal. The actual fix doesn't need reverification.

tags: added: verification-needed
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quickly - 12.08-0ubuntu1

---------------
quickly (12.08-0ubuntu1) quantal; urgency=low

  * New upstream release
    - Build-Depend on libglib2.0-bin when building for extras (LP: #1022514,
      LP: #1018038)
    - Support Exec desktop keys with arguments to the executable for extras
      (LP: #1021675)
    - Support © symbol in license command
    - Fix appindicator support (LP: #1023618)
    - Add get_current_name() to quickly API
 -- Michael Terry <email address hidden> Thu, 02 Aug 2012 10:10:09 -0400

Changed in quickly (Ubuntu):
status: Fix Committed → Fix Released
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quickly - 12.04-0ubuntu4

---------------
quickly (12.04-0ubuntu4) precise-proposed; urgency=low

  * debian/patches/fix-extras.patch:
    - fix a regression with latest python-distutils-extra from -proposed.
      Now support both (LP: #1022514)
    - fix Exec= key matching when it has args. (LP: #1021675)

quickly (12.04-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/fix-extras.patch:
    - Add libglib2.0-bin to the Build-Depends line when using submitubuntu
      or package --extras. This is needed for glib-compile-schemas.
      LP: #1018038
 -- Didier Roche <email address hidden> Mon, 09 Jul 2012 11:57:20 +0200

Changed in quickly (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers