Quickly package replaces all Exec strings in .desktop file, removing Quicklist entries

Bug #1021675 reported by Serhiy Zahoriya on 2012-07-06
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Quickly
Undecided
Unassigned
quickly (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

[ Test case ]
1. install the version from -proposde (-0ubuntu4)
2. have a file with an exec key containing an option (--foo)
3. use Quickly package
-> the file should get completed with the right path and no arg should be skipped

[ Regression potential ]
Covered by test suite

Upon packaging quickly replaces debian/rules file and it contains

sed -i 's|Exec=.*|Exec=/opt/extras.ubuntu.com/wakeonplan/bin/wakeonplan|' debian/wakeonplan/usr/share/applications/extras-wakeonplan.desktop;

which replaces the whole Exec line including command-line arguments.
AFAIU it should've been

s|Exec=[^ ]*|

The main issue with this is that it removes the command-line arguments used in Unity Quicklist entries.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: quickly 12.04-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-26.41-generic-pae 3.2.19
Uname: Linux 3.2.0-26-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu8
Architecture: i386
Date: Fri Jul 6 13:44:33 2012
PackageArchitecture: all
QuicklyDataPath: /usr/share/quickly
QuicklyTemplates:
 /usr/share/quickly/templates/ubuntu-application
 /usr/share/quickly/templates/ubuntu-flash-game
 /usr/share/quickly/templates/ubuntu-cli
QuicklyTemplatesDirectories: /usr/share/quickly/templates/
SourcePackage: quickly
UpgradeStatus: No upgrade log present (probably fresh install)

Serhiy Zahoriya (xintx-ua) wrote :
David Planella (dpm) on 2012-07-06
tags: added: arb
Changed in quickly (Ubuntu):
status: New → Confirmed
Changed in quickly:
status: New → Confirmed
summary: - Quickly package replaces all Exec strings in .desktop file
+ Quickly package replaces all Exec strings in .desktop file, removing
+ Quicklist entries
description: updated
Didier Roche (didrocks) on 2012-07-09
Changed in quickly:
status: Confirmed → Fix Released
Changed in quickly (Ubuntu):
status: Confirmed → Fix Committed
description: updated

Hello Сергій, or anyone else affected,

Accepted quickly into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/quickly/12.04-0ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in quickly (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Serhiy Zahoriya (xintx-ua) wrote :

I'm getting a bunch of warnings like this:

WARNING: syntax errors in wakeonplan_lib/Builder.py: encoding declaration in Unicode string (Builder.py, line 0)

But I'm not sure it's related to this particular bug.
Please contact me on IRC at #ubuntu-app-devel if you know how to fix it.

tags: added: verification-done
removed: verification-needed
Scott Kitterman (kitterman) wrote :

Like the other Quickly bugs, this one still seems to be open in Quantal. That needs to be fixed before this goes to -updates.

Scott Kitterman (kitterman) wrote :

Switching back to verification needed since it needs verification it's fixed in quantal. The actual fix doesn't need reverification.

tags: added: verification-needed
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quickly - 12.08-0ubuntu1

---------------
quickly (12.08-0ubuntu1) quantal; urgency=low

  * New upstream release
    - Build-Depend on libglib2.0-bin when building for extras (LP: #1022514,
      LP: #1018038)
    - Support Exec desktop keys with arguments to the executable for extras
      (LP: #1021675)
    - Support © symbol in license command
    - Fix appindicator support (LP: #1023618)
    - Add get_current_name() to quickly API
 -- Michael Terry <email address hidden> Thu, 02 Aug 2012 10:10:09 -0400

Changed in quickly (Ubuntu):
status: Fix Committed → Fix Released
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quickly - 12.04-0ubuntu4

---------------
quickly (12.04-0ubuntu4) precise-proposed; urgency=low

  * debian/patches/fix-extras.patch:
    - fix a regression with latest python-distutils-extra from -proposed.
      Now support both (LP: #1022514)
    - fix Exec= key matching when it has args. (LP: #1021675)

quickly (12.04-0ubuntu3) precise-proposed; urgency=low

  * debian/patches/fix-extras.patch:
    - Add libglib2.0-bin to the Build-Depends line when using submitubuntu
      or package --extras. This is needed for glib-compile-schemas.
      LP: #1018038
 -- Didier Roche <email address hidden> Mon, 09 Jul 2012 11:57:20 +0200

Changed in quickly (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers