[Needs Update] Quassel (Ignorelist adding ctcp ignore)

Bug #509287 reported by ghostcube on 2010-01-18
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
quassel (Ubuntu)
High
Scott Kitterman
Karmic
High
Scott Kitterman
Lucid
High
Scott Kitterman

Bug Description

Binary package hint: quassel

Hi, as you all know he freenode network gets spammed by a botnet with several attacks,
one is dcc spamming second one is ctcp flood and request through the channels,
in Quassel here has been no possibility do ignore ctcp since today.
there is a patch for this commited into git.
Can you pls update the package to get this into the Packages for Ubuntu?

TEST CASE:

Ask someone on IRC to send a CTCP version request. Notice that you get it.
Enable CTCP Ignore (Settings -> Configure Quassel -> Ignore List)
Ask someone to ping you again. Notice that you don't get it.

For people using the split quassel-client and quassel-core, both need to be updated for this to work.
http://bugs.quassel-irc.org/projects/quassel-irc/wiki/FAQ#How-do-I-ignore-CTCP-requests

Scott Kitterman (kitterman) wrote :

Fixed upstream. They are about to cut a 0.5.2 release for this issue.

Changed in quassel (Ubuntu Lucid):
assignee: nobody → Scott Kitterman (kitterman)
importance: Undecided → High
milestone: none → lucid-alpha-3
status: New → In Progress
Scott Kitterman (kitterman) wrote :

Because of the user impact, this should be fixed in Karmic too. This (less packaging) is what the SRU proposal will be:

http://git.quassel-irc.org/?p=quassel.git;a=commitdiff;h=ac374ec32612798c230d54665f6bce7faf416602

Changed in quassel (Ubuntu Karmic):
assignee: nobody → Scott Kitterman (kitterman)
importance: Undecided → High
milestone: none → karmic-updates
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quassel - 0.5.2-0ubuntu1

---------------
quassel (0.5.2-0ubuntu1) lucid; urgency=low

  * New upstream bug fix release
    - Multiple bug fixes
    - CTCP ignore capability to combat Freenode spam attacks (LP: #509287)
 -- Scott Kitterman <email address hidden> Mon, 18 Jan 2010 19:23:19 -0500

Changed in quassel (Ubuntu Lucid):
status: In Progress → Fix Released
John Dong (jdong) wrote :

After speaking with Scott K in IRC, consider this an ACK from ubuntu-sru to backport this patch to Karmic

Scott Kitterman (kitterman) wrote :

Waiting for the package to be accepted for karmic-proposed (it's uploaded).

Changed in quassel (Ubuntu Karmic):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
description: updated
Daniel Albers (al) wrote :

Quoted from http://bugs.quassel-irc.org/projects/quassel-irc/wiki/FAQ#How-do-I-ignore-CTCP-requests:

Versions 0.5.2 and newer offer a "CTCP" type in the ignorelist settingspage.
If selected, the rule is parsed as follows:
hostmask [CTCPCMD CTCPCMD]
For example "* VERSION PING" would ignore VERSION and PING requests for any hostmask.
If no CTCPCMD is given, all requests are ignored.
Only global- and per network scope are supported.
Since CTCP is ignored on the coreside, "Strictness" is always permanent.

description: updated

Accepted quassel into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in quassel (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed
Christian Mangold (neversfelde) wrote :

Testing with an external core and several clients for a few hours now and no regressions so far.

Martin Pitt (pitti) on 2010-01-19
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quassel - 0.5.0-0ubuntu1.1

---------------
quassel (0.5.0-0ubuntu1.1) karmic-proposed; urgency=low

  * Add kubuntu_02_ctcp_ignore.patch from upstream to add the ability to
    ignore ctcp requests (LP: #509287)
    - Urgent for SRU due to the recent wave of various DoS attacks on freenode
 -- Scott Kitterman <email address hidden> Mon, 18 Jan 2010 22:31:00 -0500

Changed in quassel (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers