can't add users to quassel

Bug #1863664 reported by Gianfranco Costamagna on 2020-02-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
quassel (Ubuntu)
High
Gianfranco Costamagna
Precise
Undecided
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Gianfranco Costamagna
Bionic
Undecided
Gianfranco Costamagna
Disco
Undecided
Unassigned
Eoan
Undecided
Gianfranco Costamagna
Focal
High
Gianfranco Costamagna

Bug Description

[ Description ]
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=940482

[ Impact ]

Dear Maintainer,

I'm trying to add a user using

# quasselcore -c /var/lib/quassel --add-user

quasselcore is replying with:

2019-09-16 12:26:27 [Warn ] SslServer: Failed to open certificate file /var/lib/quassel/quasselCert.pem error: 5
2019-09-16 12:26:27 [Warn ] SslServer: Unable to set certificate file
           Quassel Core will still work, but cannot provide SSL for client connections.
           Please see https://quassel-irc.org/faq/cert to learn how to enable SSL support.
2019-09-16 12:26:27 [Warn ] SslServer: Failed to open certificate file /var/lib/quassel/quasselCert.pem error: 5
2019-09-16 12:26:27 [Warn ] PostgreSQL driver plugin not available for Qt. Installed drivers: QSQLITE
2019-09-16 12:26:27 [Warn ] No storage backend selected!
2019-09-16 12:26:27 [Error] Cannot write quasselcore configuration; probably a permission problem.

The certificate file is there. There is no PostgreSQL but SQLite
database. There is no permission problem (and the command is executed as
root). When I'm adding the switch --select-backend SQLite like in:

quasselcore -c /var/lib/quassel --add-user --select-backend SQLite

I'm stuck with:

2019-09-16 12:27:56 [Warn ] SslServer: Failed to open certificate file /var/lib/quassel/quasselCert.pem error: 5
2019-09-16 12:27:56 [Warn ] SslServer: Unable to set certificate file
           Quassel Core will still work, but cannot provide SSL for client connections.
           Please see https://quassel-irc.org/faq/cert to learn how to enable SSL support.
2019-09-16 12:27:56 [Warn ] SslServer: Failed to open certificate file /var/lib/quassel/quasselCert.pem error: 5
2019-09-16 12:27:56 [Warn ] PostgreSQL driver plugin not available for Qt. Installed drivers: QSQLITE
2019-09-16 12:27:56 [Warn ] No storage backend selected!
2019-09-16 12:27:56 [Warn ] Unable to open database SQLite for thread 0x55d696f19cb0
2019-09-16 12:27:56 [Warn ] - unable to open database file Error opening database
2019-09-16 12:27:56 [Warn ] Database connection "SQLite" for thread QThread(0x55d696f19cb0) was lost, attempting to reconnect...
2019-09-16 12:27:56 [Warn ] Unable to open database SQLite for thread 0x55d696f19cb0
2019-09-16 12:27:56 [Warn ] - unable to open database file Error opening database
2019-09-16 12:27:56 [Error] Storage backend is not available: SQLite

Testing an upgrade is leading to a dependency on systemd, which I do not
have (we're using sysvinit on servers only). But this could be the issue.

[ Regression Potential ]
* None, its an apparmor minimal fix

[ Other info ]
quassel (1:0.13.1-2) unstable contains the fix

description: updated
Changed in quassel (Ubuntu):
status: New → Fix Released
importance: Undecided → High
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in quassel (Ubuntu Xenial):
status: New → In Progress
Changed in quassel (Ubuntu Trusty):
status: New → Invalid
Changed in quassel (Ubuntu Precise):
status: New → Invalid
Changed in quassel (Ubuntu Bionic):
status: New → In Progress
Changed in quassel (Ubuntu Disco):
status: New → Opinion
status: Opinion → Invalid
Changed in quassel (Ubuntu Eoan):
status: New → In Progress
description: updated
Changed in quassel (Ubuntu Eoan):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in quassel (Ubuntu Bionic):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)
Changed in quassel (Ubuntu Xenial):
assignee: nobody → Gianfranco Costamagna (costamagnagianfranco)

Hello Gianfranco, or anyone else affected,

Accepted quassel into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/quassel/1:0.13.1-1ubuntu1.19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in quassel (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
Steve Langasek (vorlon) wrote :

Hello Gianfranco, or anyone else affected,

Accepted quassel into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/quassel/1:0.12.4-3ubuntu1.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in quassel (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic

On bionic, I can't trigger the error anymore

# quasselcore -c /var/lib/quassel --add-user --select-backend SQLite
2020-03-02 15:43:41 Warning: SslServer: Failed to open certificate file /var/lib/quassel/quasselCert.pem error: 5
2020-03-02 15:43:41 Warning: SslServer: Unable to set certificate file
           Quassel Core will still work, but cannot provide SSL for client connections.
           Please see http://quassel-irc.org/faq/cert to learn how to enable SSL support.
2020-03-02 15:43:41 Warning: SslServer: Failed to open certificate file /var/lib/quassel/quasselCert.pem error: 5
("QSQLITE")
("QSQLITE")
2020-03-02 15:43:41 Warning: Unable to open database SQLite for thread 0x55e942ca59c0
2020-03-02 15:43:41 Warning: - out of memory Error opening database

tags: added: verification-done verification-done-bionic verification-done-eoan
removed: verification-needed verification-needed-bionic verification-needed-eoan

same for eoan!
(yes, I went OOM because I had ram full, but this is not a regression in the new release, the error was happening before that step)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quassel - 1:0.13.1-1ubuntu1.19.10.1

---------------
quassel (1:0.13.1-1ubuntu1.19.10.1) eoan; urgency=medium

  * Cherry-pick fix introduced in Debian in revision 1:0.13.1-2 to fix
    apparmor profile (LP: #1863664)

 -- Gianfranco Costamagna <email address hidden> Mon, 17 Feb 2020 19:02:52 +0100

Changed in quassel (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for quassel has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quassel - 1:0.12.4-3ubuntu1.18.04.1

---------------
quassel (1:0.12.4-3ubuntu1.18.04.1) bionic; urgency=medium

  * Cherry-pick fix introduced in Debian in revision 1:0.13.1-2 to fix
    apparmor profile (LP: #1863664)

 -- Gianfranco Costamagna <email address hidden> Mon, 17 Feb 2020 19:06:19 +0100

Changed in quassel (Ubuntu Bionic):
status: Fix Committed → Fix Released

Hello Gianfranco, or anyone else affected,

Accepted quassel into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/quassel/0.12.2-0ubuntu1.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in quassel (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done
Robie Basak (racb) wrote :

Hello Gianfranco, or anyone else affected,

Accepted quassel into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/quassel/0.12.2-0ubuntu1.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

thanks, it seems to be ok on my xenial chroot!

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hey Gianfranco! Could you confirm what packages did you use for testing? Thank you!

Mathew Hodson (mhodson) on 2020-03-21
Changed in quassel (Ubuntu Disco):
status: Invalid → Won't Fix
Mathew Hodson (mhodson) on 2020-03-21
Changed in quassel (Ubuntu Precise):
status: Invalid → Won't Fix
Changed in quassel (Ubuntu Trusty):
status: Invalid → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quassel - 0.12.2-0ubuntu1.16.04.2

---------------
quassel (0.12.2-0ubuntu1.16.04.2) xenial; urgency=medium

  * Cherry-pick fix introduced in Debian in revision 1:0.13.1-2 to fix
    apparmor profile (LP: #1863664)
  * Fix build failure with qt 5.5 with upstream patches.
    - debian/patches/be23c0c48e37617eebe0be0eb2ea5c6246dc8170.patch:
    - debian/patches/078477395aaec1edee90922037ebc8a36b072d90.patch:

 -- Gianfranco Costamagna <email address hidden> Mon, 17 Feb 2020 19:07:40 +0100

Changed in quassel (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers