Please update Quassel to 0.12.4

Bug #1589128 reported by Michael Marley on 2016-06-04
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
quassel (Ubuntu)
Low
Timo Jyrinki

Bug Description

Quassel should be updated to 0.12.4 to fix several bugs, including a core-crashing bug (fixed in https://github.com/quassel/quassel/commit/adbd7f6efa14b107ed722daa0b7963dd1238a681). I have prepared a package for Yakkety in https://launchpad.net/~mamarley/+archive/ubuntu/quassel-exp/+packages.

Changed in quassel (Ubuntu):
status: New → Confirmed
tags: added: upgrade-software-version
tags: added: yakkety
Changed in quassel (Ubuntu):
importance: Undecided → Low
Michael Hudson-Doyle (mwhudson) wrote :

Hello, thank you for your contribution to Ubuntu (I'm a quassel user myself, so this is extra appreciated :-p)!

However, I see that 0.12.4 is in Debian now. Is there any reason to prefer your package over syncing 0.12.4-2 from Debian? It seems that the Ubuntu delta is no longer applicable.

Changed in quassel (Ubuntu):
status: Confirmed → Incomplete
Michael Marley (mamarley) wrote :

I don't see any reason not to do that, but I am not really the decider of such things. It looks like the only difference is that the Ubuntu package puts the user in the Kubuntu IRC channel by default. I will ask the people from #kubuntu-devel to comment.

Changed in quassel (Ubuntu):
status: Incomplete → In Progress
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Timo Jyrinki (timo-jyrinki) wrote :

Ok I went through it and I think it was really worth merging to get it more maintainable and syncable from Debian.

Attached is a rough "diff" of what changed. I first generated it by trying to standardize the notations (wrap-and-sort) and then diffing between Debian and Ubuntu (Michael's updated 0.12.4 PPA version). After applying changes and keeping some Ubuntu changes, I modified the diff by hand to remove parts that no longer apply. So it's not a real diff, but what tries to explain what did now change in Ubuntu. The big changelog diff is not in there, they'd be welcome to be hand merged to preserve the Ubuntu history.

If you see anything in this diff that's being removed that should not be removed from Ubuntu, or added that should not be added, then feel free to readd the modifications.

Timo Jyrinki (timo-jyrinki) wrote :

And here attached is the new debdiff between Debian and Ubuntu's new 0.12.4-2ubuntu1

Down from 133524 bytes to 9203 bytes.

Changed in quassel (Ubuntu):
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

(stuck in proposed with the Qt and KDE)

Timo Jyrinki (timo-jyrinki) wrote :

I will make another, sponsored upload to fix bug #1608498 but meanwhile here's the changelog entry regarding this bug:

quassel (1:0.12.4-2ubuntu1) yakkety; urgency=medium

  * Merge with Debian. (LP: #1589128) (LP: #1582802)
  * Dropped changes include:
    - Specify 2048-bit RSA key (default anyway now).
    - Many indentation differences.
    - Sysvinit file differences, different name for systemd file,
      upstart file (no longer needed).
    - More complicated debian/rules.
    - Less hardening in Ubuntu, +all in Debian.
    - Some maintainer script transition for very old versions.
    - Changelog entries (manual combining welcome).
    - Qt 4 build dependencies.
  * Remaining changes:
    - Kubuntu channel tweak.
    - Dropping of (different) transitional packages since 16.04 LTS released.
    - Apparmor profile.
    - Ufw profile.

 -- Timo Jyrinki <email address hidden> Mon, 01 Aug 2016 09:12:45 +0300

Jeremy Bicha (jbicha) wrote :

Unsubscribing ~ubuntu-sponsors since this looks taken care of.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quassel - 1:0.12.4-2ubuntu2

---------------
quassel (1:0.12.4-2ubuntu2) yakkety; urgency=medium

  * Fix SSL issues with Qt5.6 and GCC5.
    - Add fix_ssl_qt5.6_gcc5.patch (from upstream git master)

quassel (1:0.12.4-2ubuntu1) yakkety; urgency=medium

  * Merge with Debian. (LP: #1589128) (LP: #1582802)
  * Dropped changes include:
    - Specify 2048-bit RSA key (default anyway now).
    - Many indentation differences.
    - Sysvinit file differences, different name for systemd file,
      upstart file (no longer needed).
    - More complicated debian/rules.
    - Less hardening in Ubuntu, +all in Debian.
    - Some maintainer script transition for very old versions.
    - Changelog entries (manual combining welcome).
    - Qt 4 build dependencies.
  * Remaining changes:
    - Kubuntu channel tweak.
    - Dropping of (different) transitional packages since 16.04 LTS released.
    - Apparmor profile.
    - Ufw profile.

 -- Michael Marley <email address hidden> Mon, 01 Aug 2016 07:49:05 -0400

Changed in quassel (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers