Several installation error issues

Bug #979159 reported by Ghe Rivero on 2012-04-11
32
This bug affects 4 people
Affects Status Importance Assigned to Milestone
quantum (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

As reported in https://lists.launchpad.net/netstack/msg01030.html by Dan Wendlandt:

apt-get install quantum-server
- chown: cannot access `/etc/quantum/' : No such file or directory
- chown: cannot access `/var/run/quantum/' : No such file or directory
- plugins.ini and quantum.conf should be copied from "etc" directory in source to /etc/quantum . /etc/quantum is empty right now.
- "service quantum-server start" doesn't work. No init scripts.
- quantum-ryu-agent was installed in /usr/bin even though I didn't install the ryu plugin.

apt-get install quantum-openvswitch-plugin
- quantum-openvswitch-agent was installed into /usr/bin/quantum-openvswitch-agent/quantum-openvswitch-agent, so it did not show up in the path.
- no logging to /var/log/quantum (at least server logging should go here, ideally agents would have log as well)
- mysql, python-mysqldb should be a dependency for the quantum-openvswitch-plugin
- I suspect agents should be separate packages from the main plugin packages. Plugins correspond to code that is running on the main quantum controller (i.e., the node running the API) . Agents run on each compute node, managing the vswitch.
- ovs quantum agent package should depend on python-mysqldb and openvswitch-switch

Ideally, agent would have init scripts as well.

Attached patch fix most of them. Separated agents and the init (starup) scripts bugs are remaining. I'll open a separate bug for them.

Ghe Rivero (ghe.rivero) wrote :
James Page (james-page) wrote :

Confirmed:

Adding system user `quantum' (UID 134) ...
Adding new user `quantum' (UID 134) with group `quantum' ...
Not creating home directory `/var/lib/quantum'.
chown: cannot access `/etc/quantum/': No such file or directory
dpkg: error processing quantum-common (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of quantum-server:
 quantum-server depends on quantum-common; however:
  Package quantum-common is not configured yet.
dpkg: error processing quantum-server (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          ldconfig deferred processing now taking place
Errors were encountered while processing:
 quantum-common
 quantum-server

Changed in quantum (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → ubuntu-12.04
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quantum - 2012.1-0ubuntu3

---------------
quantum (2012.1-0ubuntu3) precise; urgency=low

  * Split out agents into its own packages. (LP: #979192)
    Thanks to Ghe Rivero.
  * Add upstart job. (LP: #979190)
  * Fix installation issues. (LP: #979159)
 -- Chuck Short <email address hidden> Thu, 12 Apr 2012 13:39:06 -0400

Changed in quantum (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments