quantum-server (and others) cannot be removed.

Bug #1047560 reported by Adam Gandelman on 2012-09-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
quantum (Ubuntu)
High
Adam Gandelman
Nominated for Precise by Adam Gandelman

Bug Description

root@server-570:/etc/quantum# apt-get remove --purge quantum-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  quantum-server*
0 upgraded, 0 newly installed, 1 to remove and 154 not upgraded.
After this operation, 75.8 kB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 73141 files and directories currently installed.)
Removing quantum-server ...
Purging configuration files for quantum-server ...
usage: update-rc.d [-n] [-f] <basename> remove
       update-rc.d [-n] <basename> defaults [NN | SS KK]
       update-rc.d [-n] <basename> start|stop NN runlvl [runlvl] [...] .
       update-rc.d [-n] <basename> disable|enable [S|2|3|4|5]
  -n: not really
  -f: force

The disable|enable API is not stable and might change in the future.
dpkg: error processing quantum-server (--purge):
 subprocess installed post-removal script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Processing triggers for ureadahead ...
Processing triggers for man-db ...
Errors were encountered while processing:
 quantum-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@server-570:/etc/quantum#

Clint Byrum (clint-fewbar) wrote :

I tried this several times in a clean quantal amd64 chroot...

The following packages were automatically installed and are no longer required:
  ca-certificates libgcrypt11 libgpg-error0 libjs-jquery libjs-sphinxdoc libjs-underscore libxml2 libxslt1.1 libyaml-0-2
  openssl python-amqplib python-anyjson python-cliff python-cmd2 python-eventlet python-formencode python-gflags
  python-greenlet python-httplib2 python-iso8601 python-kombu python-lxml python-netaddr python-openid python-openssl
  python-paste python-pastedeploy python-pastescript python-pkg-resources python-prettytable python-pyparsing python-pyudev
  python-quantum python-quantumclient python-repoze.lru python-routes python-scgi python-setuptools python-simplejson
  python-sqlalchemy python-sqlalchemy-ext python-webob python-yaml quantum-common sgml-base xml-core
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  quantum-server*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 110 kB disk space will be freed.
Do you want to continue [Y/n]?
(Reading database ... 20282 files and directories currently installed.)
Removing quantum-server ...
Purging configuration files for quantum-server ..
#

Same basic result on precise as well.

Whats puzzling about your result is that update-rc.d is only run in the postinst, which isn't called during remove or purge.

Can you apport-collect on a box you see this on so I can look at the dependencies?

Changed in quantum (Ubuntu):
status: New → Incomplete
assignee: nobody → Adam Gandelman (gandelman-a)
Adam Gandelman (gandelman-a) wrote :

Sorry clint, the bug actually affects the Openstack Ubuntu Testing PPA. I wish there was a better way to target packages in that PPA and not the Ubuntu package, tho those packages are where the Ubuntu packages are derived.

Anyway, the issue is the use of update-rc.d in the postrm's is bad, and doesn't specify 'remove'. This is fixed in a local branch and will be pushed and upload soon.

summary: - quantum-server (and others) cannot be removed.
+ [SRU] quantum-server (and others) cannot be removed.
summary: - [SRU] quantum-server (and others) cannot be removed.
+ quantum-server (and others) cannot be removed.
Changed in quantum (Ubuntu):
status: Incomplete → Fix Committed
Ursula Junque (ursinha) on 2012-09-10
Changed in quantum (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quantum - 2012.2~rc1-0ubuntu1

---------------
quantum (2012.2~rc1-0ubuntu1) quantal; urgency=low

  [ Adam Gandelman ]
  * debain/*.postrm: Fix argument-less calls to update-rc.d, redirect
    to /dev/null. (LP: #1047560)
  * debian/quantum-server.upstart: Invoke start-stop-daemon properly.
    (LP: #1047404)
  * debain/*.postrm, *.upstart: Ensure files are named for corresponding
    agent package, not plugin package.
  * debian/control:
    - Group agents with plugins.
    - Fix some copy/paste mistakes.
    - Set dependencies between agents and corresponding plugins.
    - Recommend quantum-plugin-openvswitch for quantum-server.
    - Require the same version of quantum-common and python-quantum.
    - Add quantum-netns-cleanup utility to quantum-common.
  * debian/patches/fix-quantum-configuration.patch: Use correct database
    for linuxbridge plugin, use OVS plugin by default, call quantum-rootwrap
    correctly. (LP: #1048668)
  * Fix all use of /usr/sbin, things should go in /usr/bin.
  * Remove dhcp and l3 plugins, they are not actually plugins.
  * Rename packages quantum-plugin-{l3, dhcp}-agent to
    quantum-{l3, dhcp}-agent.
  * debain/quantum-*-agent.upstart: Specify config files as a
    parameter to --config-file, specify log files for all.
  * debian/*.logrotate: Add logrotate configs for server and agents.
  * Install quantum_sudoers with quantum-common, not quantum-server.
  * Install rootwrap filters only with the packages that require them.
  * debian/*-agent.upstart: Specify --config-file=/etc/quantum/quantum.conf
    in addition to plugin-specific config. Specify log files for all agents.
  * Allow group 'adm' read access to /var/log/quantum.
  * debian/quantum-server.postinst: Drop, all has been moved to quantum-common.
  * Add packaging for quantum-plugin-nec.

  [ Chuck Short ]
  * New usptream release.
 -- Chuck Short <email address hidden> Wed, 12 Sep 2012 13:41:20 -0500

Changed in quantum (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers