Impossible to run quantum-server from testing/archives packages

Bug #1045064 reported by Emilien Macchi on 2012-09-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
quantum (Ubuntu)
High
Chuck Short
Quantal
High
Chuck Short

Bug Description

Using Folsom Testing Packages [1], I can't run Quantum-Server.

apt-get install quantum-server

When I try to run the bin "quantum-server" :

Traceback (most recent call last):
  File "/usr/sbin/quantum-server", line 23, in <module>
    from quantum.server import main as server
  File "/usr/lib/python2.7/dist-packages/quantum/server/__init__.py", line 26, in <module>
    from quantum import service
  File "/usr/lib/python2.7/dist-packages/quantum/service.py", line 20, in <module>
    from quantum.common import config
  File "/usr/lib/python2.7/dist-packages/quantum/common/config.py", line 29, in <module>
    from quantum.api.v2 import attributes
  File "/usr/lib/python2.7/dist-packages/quantum/api/v2/attributes.py", line 24, in <module>
    from quantum.common import exceptions as q_exc
  File "/usr/lib/python2.7/dist-packages/quantum/common/exceptions.py", line 26, in <module>
    class QuantumException(OpenstackException):
  File "/usr/lib/python2.7/dist-packages/quantum/common/exceptions.py", line 34, in QuantumException
    message = _("An unknown exception occurred.")
NameError: name '_' is not defined

[1] https://launchpad.net/~openstack-ubuntu-testing/+archive/folsom-trunk-testing

summary: - Impossible to run Quantum Server with testing packages
+ Impossible to run Quantum Server from testing packages

This error is usually the result of gettext.install() was not called, but it should be called any time something in the quantum package is loaded, based on this grep:

./__init__.py:import gettext
./__init__.py:gettext.install('quantum', unicode=1)

My guess is that this is packaging related, since we don't see it in devstack, but it needs more investigation.

Emilien Macchi (emilienm) wrote :

Thank's Dan.

How can I fix that temporarily ?

Endre Karlson (endre-karlson) wrote :

Ok, so the symptons after investigating with Emilien are:
/usr/lib/python2.7/dist-packages/quantum/__init__.py < Was a empty file with no content but existant (Should have been a symlink pointing to pyshared?
/usr/shared/pyshared/quantum/__init__.py < is the file that should be symlinked and is missing in overall.

I guess this is a Ubuntu packaging issue?

Endre Karlson (endre-karlson) wrote :

Updated for comment #3, this basically causes a "gettext / _" failure since the root package file is missing.

Chuck Short (zulcss) on 2012-09-04
affects: ubuntu → quantum (Ubuntu)
dan wendlandt (danwent) on 2012-09-04
no longer affects: quantum
James Page (james-page) wrote :

Also impacts the version currently in Ubuntu quantal development.

Changed in quantum (Ubuntu):
status: New → Confirmed
importance: Undecided → High
status: Confirmed → Triaged
assignee: nobody → Chuck Short (zulcss)
summary: - Impossible to run Quantum Server from testing packages
+ Impossible to run quantum-server from testing/archives packages
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quantum - 2012.2~rc1~20120907.1154-0ubuntu1

---------------
quantum (2012.2~rc1~20120907.1154-0ubuntu1) quantal; urgency=low

  [ Adam Gandelman ]
  * debian/control: Add missing python-keystone dependency.
  * wrap-and-sort.

  [ Chuck Short ]
  * debian/rules:
    - Run testsuite on build.
    - Use get-orig-source.
    - Add python-amqplib, python-anyjson, python-httplib2, python-iso8601,
      python-kombu, python-lxml, python-netadr, python-pyudev to build depends
      and run time deps.
    - Add python-mock, python-mox, and python-unitest2 to build deps.
    - Add adduser as a dep to quantum-common.
  * debian/control: Bump standards version to 3.9.3
  * debian/quantum-common.install: Add missing configuration files.
    (LP: #988999)
  * debian/quantum-plugin-linuxbridge.install: Make isntallable.
  * Add manpages: gratitously ripped from debian.
  * Fix up lintian warnings. (LP: #1025203), (LP: #1021921)
  * Add metaplugin plugin.
  * debian/patches/fix-namespace.patch: Dropped it was causing
    python namespace issues.
    (LP: #1045064)
  * debian/*.upstart:
    - Specify configuration file and log directory.
    - Start on the right transition.
  * debian/rules:
    - Allow to disable testsuite.
    - Dont fail if the testsuite fails.
  * debian/patches/fix-quantum-configuration.patch: Fix configuration files.
  * Add packaging for quantum-plugin-l3 and quantum-plugin-l3-agent
  * Add packaging for quantum-plugin-dhcp-agent and quantum-plugin-dchp-agent
  * debian/patches/fix-ubuntu-tests.patch: Fix testsuite failures.

  [ Soren Hansen ]
  * Update debian/watch to account for symbolically named tarballs and
    use newer URL.
  * Add python-configobj as a build and run time dependency. Recently added
    tests need it, and the Cisco plugin has needed it for a while.
  * Fix Launchpad URLs in debian/watch.
 -- Chuck Short <email address hidden> Fri, 07 Sep 2012 18:50:09 -0500

Changed in quantum (Ubuntu Quantal):
status: Triaged → Fix Released
Adam Gandelman (gandelman-a) wrote :

Reopening as last upload does not fix these issues.

Changed in quantum (Ubuntu Quantal):
status: Fix Released → Confirmed
Changed in quantum (Ubuntu Quantal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers