Trying to overwrite '/etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini', which is also in package quantum-server

Bug #1025203 reported by Emilien Macchi on 2012-07-16
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
neutron
Undecided
Unassigned
quantum (Ubuntu)
High
Chuck Short

Bug Description

Ubuntu 12.10 / OpenStack Folsom Testing Packages

I'm trying to install quantum-plugin-openvswitch but I've got this error :

root@folsom:~# apt-get install quantum-plugin-openvswitch
(...)
Unpacking quantum-plugin-openvswitch (from .../quantum-plugin-openvswitch_2012.2~f2-0ubuntu1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/quantum-plugin-openvswitch_2012.2~f2-0ubuntu1_all.deb (--unpack):
 trying to overwrite '/etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini', which is also in package quantum-server 2012.2~f2-0ubuntu1
Errors were encountered while processing:
 /var/cache/apt/archives/quantum-plugin-openvswitch_2012.2~f2-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

If I delete /etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini and run :

dpkg -i --force-all /var/cache/apt/archives/quantum-plugin-openvswitch_2012.2~f2-0ubuntu1_all.deb

Packaged installed.

description: updated
description: updated
Gary Kotton (garyk) wrote :

This is a problem with the ubuntu packaging of the quantum modules.

James Page (james-page) wrote :

Unpacking quantum-server (from .../quantum-server_2012.2+git201207190101~quantal-0ubuntu1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/quantum-server_2012.2+git201207190101~quantal-0ubuntu1_all.deb (--unpack):
 trying to overwrite '/etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini', which is also in package quantum-plugin-openvswitch 2012.2+git201207190101~quantal-0ubuntu1

Changed in quantum:
status: New → Invalid
Changed in quantum (Ubuntu):
status: New → Confirmed
importance: Undecided → High
milestone: none → quantal-alpha-3
status: Confirmed → Triaged
James Page (james-page) wrote :

Note - only impacts testing packages; not those in the archive. But as they will end up in the archive marking Triaged.

James Page (james-page) on 2012-08-07
Changed in quantum (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
milestone: quantal-alpha-3 → ubuntu-12.10-beta-1
Chuck Short (zulcss) on 2012-09-04
Changed in quantum (Ubuntu):
status: Triaged → Fix Committed
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quantum - 2012.2~rc1~20120907.1154-0ubuntu1

---------------
quantum (2012.2~rc1~20120907.1154-0ubuntu1) quantal; urgency=low

  [ Adam Gandelman ]
  * debian/control: Add missing python-keystone dependency.
  * wrap-and-sort.

  [ Chuck Short ]
  * debian/rules:
    - Run testsuite on build.
    - Use get-orig-source.
    - Add python-amqplib, python-anyjson, python-httplib2, python-iso8601,
      python-kombu, python-lxml, python-netadr, python-pyudev to build depends
      and run time deps.
    - Add python-mock, python-mox, and python-unitest2 to build deps.
    - Add adduser as a dep to quantum-common.
  * debian/control: Bump standards version to 3.9.3
  * debian/quantum-common.install: Add missing configuration files.
    (LP: #988999)
  * debian/quantum-plugin-linuxbridge.install: Make isntallable.
  * Add manpages: gratitously ripped from debian.
  * Fix up lintian warnings. (LP: #1025203), (LP: #1021921)
  * Add metaplugin plugin.
  * debian/patches/fix-namespace.patch: Dropped it was causing
    python namespace issues.
    (LP: #1045064)
  * debian/*.upstart:
    - Specify configuration file and log directory.
    - Start on the right transition.
  * debian/rules:
    - Allow to disable testsuite.
    - Dont fail if the testsuite fails.
  * debian/patches/fix-quantum-configuration.patch: Fix configuration files.
  * Add packaging for quantum-plugin-l3 and quantum-plugin-l3-agent
  * Add packaging for quantum-plugin-dhcp-agent and quantum-plugin-dchp-agent
  * debian/patches/fix-ubuntu-tests.patch: Fix testsuite failures.

  [ Soren Hansen ]
  * Update debian/watch to account for symbolically named tarballs and
    use newer URL.
  * Add python-configobj as a build and run time dependency. Recently added
    tests need it, and the Cisco plugin has needed it for a while.
  * Fix Launchpad URLs in debian/watch.
 -- Chuck Short <email address hidden> Fri, 07 Sep 2012 18:50:09 -0500

Changed in quantum (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers