it's not possible to install quantum-plugin-openvswitch-agent

Bug #1021921 reported by Moula BADJI on 2012-07-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
quantum (Ubuntu)
Undecided
Unassigned

Bug Description

hi,
I try to install : quantum-plugin-openvswitch-agent
it's not possible
every time i have this message :

"dpkg: erreur de traitement de /var/cache/apt/archives/python-quantum_2012.2~f2~20120621.868-0ubuntu1_all.deb (--unpack) :
 tentative de remplacement de « /usr/share/pyshared/quantum/common/test_lib.py », qui appartient aussi au paquet python-quantumclient 2012.1-0ubuntu1
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/python-quantum_2012.2~f2~20120621.868-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)"

thank's

dan wendlandt (danwent) wrote :

unless the error messages are translated to english, I can't really help you. It looks like it may be that the python-quantum package, a dependency, is not properly installed, but I'm not sure.

if this is an issue with packaging, probably best to ask the question with the people maintaining the packaging: https://launchpad.net/ubuntu/precise/amd64/quantum-plugin-openvswitch-agent

Gary Kotton (garyk) wrote :

Google translate's version:

dpkg: error processing / var/cache/apt/archives/python-quantum_2012.2 ~ ~ f2 20120621.868-0ubuntu1_all.deb (- unpack):
    trying to overwrite '/ usr / share / pyshared / quantum / common / test_lib.py ", which is also in package python-quantumclient 2012.1-0ubuntu1
   dpkg-deb: error: subprocess paste killed by signal (Broken (pipe))
   Errors were encountered while processing:
    / ~ ~ f2 var/cache/apt/archives/python-quantum_2012.2 20120621.868-0ubuntu1_all.deb
   E: Sub-process / usr / bin / dpkg Returned an error code (1)

dan wendlandt (danwent) on 2012-07-09
affects: quantum → quantum (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in quantum (Ubuntu):
status: New → Confirmed
summary: - it's not possible to quantum-plugin-openvswitch-agent
+ it's not possible to install quantum-plugin-openvswitch-agent
Chuck Short (zulcss) on 2012-09-04
Changed in quantum (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quantum - 2012.2~rc1~20120907.1154-0ubuntu1

---------------
quantum (2012.2~rc1~20120907.1154-0ubuntu1) quantal; urgency=low

  [ Adam Gandelman ]
  * debian/control: Add missing python-keystone dependency.
  * wrap-and-sort.

  [ Chuck Short ]
  * debian/rules:
    - Run testsuite on build.
    - Use get-orig-source.
    - Add python-amqplib, python-anyjson, python-httplib2, python-iso8601,
      python-kombu, python-lxml, python-netadr, python-pyudev to build depends
      and run time deps.
    - Add python-mock, python-mox, and python-unitest2 to build deps.
    - Add adduser as a dep to quantum-common.
  * debian/control: Bump standards version to 3.9.3
  * debian/quantum-common.install: Add missing configuration files.
    (LP: #988999)
  * debian/quantum-plugin-linuxbridge.install: Make isntallable.
  * Add manpages: gratitously ripped from debian.
  * Fix up lintian warnings. (LP: #1025203), (LP: #1021921)
  * Add metaplugin plugin.
  * debian/patches/fix-namespace.patch: Dropped it was causing
    python namespace issues.
    (LP: #1045064)
  * debian/*.upstart:
    - Specify configuration file and log directory.
    - Start on the right transition.
  * debian/rules:
    - Allow to disable testsuite.
    - Dont fail if the testsuite fails.
  * debian/patches/fix-quantum-configuration.patch: Fix configuration files.
  * Add packaging for quantum-plugin-l3 and quantum-plugin-l3-agent
  * Add packaging for quantum-plugin-dhcp-agent and quantum-plugin-dchp-agent
  * debian/patches/fix-ubuntu-tests.patch: Fix testsuite failures.

  [ Soren Hansen ]
  * Update debian/watch to account for symbolically named tarballs and
    use newer URL.
  * Add python-configobj as a build and run time dependency. Recently added
    tests need it, and the Cisco plugin has needed it for a while.
  * Fix Launchpad URLs in debian/watch.
 -- Chuck Short <email address hidden> Fri, 07 Sep 2012 18:50:09 -0500

Changed in quantum (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers