QWebView widget missing in designer.

Bug #674367 reported by Nathan Osman on 2010-11-12
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
qtwebkit-source (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qtcreator

I went to add a QWebView widget to a window, only to discover that the widget was not listed in the controls.

Here is the group that it is supposed to show up in: http://i.imgur.com/WiNzO.jpg

Revision history for this message
fabienwang (fabienwang) wrote :

It happened to me after some Ubuntu updates i think.

I had found the problem and the solution:

/usr/share/qt4/plugins/designer/libqwebview.so is missing.

Just find it and put it there and it will work.

Changed in qtcreator (Ubuntu):
status: New → Confirmed
Felix Geyer (debfx) on 2010-11-20
affects: qtcreator (Ubuntu) → qtwebkit-source (Ubuntu)
Revision history for this message
Felix Geyer (debfx) wrote :

Seems like the qwebview designer plugin is part of Qt but not QtWebKit.
We could fix this like QtAssistant by using the QtWebKit library built from the qt4-x11 source.
If we don't want to add a new package for the plugin it should go into libqt4-designer.

Revision history for this message
Donovan Hoare (donovan-atstech) wrote :

This bug also effects me. Im running QT creator 2.0.1
The qwebview widget also doesnt show on my list.

Revision history for this message
PasNox (pasnox) wrote :

@Fabien: and how we found this file if we have not it on the machine ?

Very boring bug :(

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtwebkit-source - 2.1~really2.0.2-0ubuntu1

---------------
qtwebkit-source (2.1~really2.0.2-0ubuntu1) natty; urgency=low

  * New upstream release.
  * Adapt 04_enable_debug_information.diff to new upstream version.
  * Add the QtDesigner qwebview plugin. (LP: #674367)
 -- Felix Geyer <email address hidden> Tue, 08 Mar 2011 12:03:10 +0100

Changed in qtwebkit-source (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Nathan Osman (george-edison55) wrote :

This seems to have resurface with the latest builds from the Oneiric repos. Once again the QWebView control is missing from Qt Designer.

Changed in qtwebkit-source (Ubuntu):
status: Fix Released → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtwebkit-source (Ubuntu):
status: New → Confirmed
Revision history for this message
Borivoje Petrovic (borivoje) wrote :

It seems that the problem is fixed, at least for me, since compilation of Simon Speech Recognition Suite is properly bulit.
On this link
https://launchpad.net/ubuntu/+source/qtwebkit-source/2.3.0-0ubuntu2.1/+build/4629870
there exist two versions of this library of which one does the job.

A novice-never-to-become-a-developer here, so don't mind the misinformation.

Revision history for this message
Tonal (tonal-promsoft) wrote :

In Saucy also missing

Revision history for this message
Tonal (tonal-promsoft) wrote :

In Trusty also missing

Revision history for this message
Tonal (tonal-promsoft) wrote :
Revision history for this message
Dino Conte (dermitdemdino) wrote :

How to fix this in Trusty?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.