Webkit broken on PowerPC - JSC::LLInt::CLoop

Bug #1274167 reported by Christian Zigotzky on 2014-01-29
102
This bug affects 39 people
Affects Status Importance Assigned to Milestone
WebKit
Unknown
Unknown
ubiquity
New
Undecided
Unassigned
qtwebkit (Debian)
Fix Released
Unknown
qtwebkit-opensource-src (Ubuntu)
Undecided
Unassigned
qtwebkit-source (Ubuntu)
High
Unassigned
webkitgtk (Debian)
Fix Released
Unknown
webkitgtk (Ubuntu)
High
Unassigned

Bug Description

Midori crashed.

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: midori 0.4.3+dfsg-0.1
Uname: Linux 3.13.0_A-EON_AmigaOne_X1000_Nemo ppc64
ApportVersion: 2.13.2-0ubuntu2
Architecture: powerpc
CrashCounter: 1
CurrentDesktop: LXDE
Date: Wed Jan 29 16:58:54 2014
ExecutablePath: /usr/bin/midori
ProcCmdline: midori
ProcEnviron:
 LANGUAGE=de_DE
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: midori
StacktraceTop:
 JSC::LLInt::CLoop::execute(JSC::ExecState*, void*, bool) () from /usr/lib/powerpc-linux-gnu/libjavascriptcoregtk-1.0.so.0
 callToJavaScript () from /usr/lib/powerpc-linux-gnu/libjavascriptcoregtk-1.0.so.0
 JSC::JITCode::execute(JSC::VM*, JSC::ProtoCallFrame*, JSC::Register*) () from /usr/lib/powerpc-linux-gnu/libjavascriptcoregtk-1.0.so.0
 JSC::Interpreter::execute(JSC::ProgramExecutable*, JSC::ExecState*, JSC::JSObject*) () from /usr/lib/powerpc-linux-gnu/libjavascriptcoregtk-1.0.so.0
 JSC::evaluate(JSC::ExecState*, JSC::SourceCode const&, JSC::JSValue, JSC::JSValue*) () from /usr/lib/powerpc-linux-gnu/libjavascriptcoregtk-1.0.so.0
Title: midori crashed with SIGSEGV in JSC::LLInt::CLoop::execute()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm audio cdrom dip lpadmin plugdev sambashare sudo video

information type: Private → Public
Adam Smith (adamsmith) wrote :

Have you seen this bug report https://bugs.webkit.org/show_bug.cgi?id=103128 ?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in midori (Ubuntu):
status: New → Confirmed

Am 05.04.14 16:45, schrieb Adam Smith:
> Have you seen this bug report
> https://bugs.webkit.org/show_bug.cgi?id=103128 ?
>
> ** Bug watch added: bugs.webkit.org/ #103128
> https://bugs.webkit.org/show_bug.cgi?id=103128
>
No, I haven't. Thanks a lot for your hint. :-)

Rgds,

Christian

It renders essential functionality of the package (or a dependent one) broken.

Changed in midori (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Adam Smith (adamsmith) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in webkitgtk (Ubuntu):
status: New → Confirmed
Adam Smith (adamsmith) wrote :

lqtwebkit recently got patched in debian https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=761040

Adam Smith (adamsmith) wrote :

sorry that should be qtwebkit

Adam Smith (adamsmith) on 2014-12-16
summary: - midori crashed with SIGSEGV in JSC::LLInt::CLoop::execute()
+ Webkit broken on PowerPC - JSC::LLInt::CLoop
affects: midori (Ubuntu) → qtwebkit-source (Ubuntu)
Changed in qtwebkit-source (Ubuntu):
status: Triaged → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Adam Smith (adamsmith) on 2014-12-16
affects: midori → ubuntu
Changed in ubuntu:
status: New → Confirmed
Changed in qtwebkit-source (Debian):
status: Unknown → Fix Released
Changed in webkitgtk (Debian):
status: Unknown → New
Changed in ubuntu:
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1274167

tags: added: iso-testing
affects: qtwebkit-source (Debian) → qtwebkit (Debian)
affects: ubuntu → webkit-open-source
Changed in webkit-open-source:
importance: Undecided → Unknown
status: Confirmed → Unknown
Adam Smith (adamsmith) on 2015-03-24
Changed in qtwebkit-opensource-src (Ubuntu):
status: New → Fix Released
Adam Smith (adamsmith) wrote :

From comments in the ubuntu apple forum, qupzilla is now working in 15.04 (vivid).

Changed in webkitgtk (Debian):
status: New → Fix Released

This is related to this bug 1432965 any update?

A patch the fixes the Cloop issue on PowerPC is available from Debian.

  * http://anonscm.debian.org/cgit/pkg-webkit/webkit.git/commit/?id=20542bcb847030cc0592899d729cccf93ee7f38c

Please include this patch in Ubuntu so that Ubiquity can be reinstated for flavours that support PowerPC, such as Lubuntu and Ubuntu MATE.

Sebastien Bacher (seb128) wrote :

thank, I merged webkitgtk with Debian and uploaded to wily

Changed in webkitgtk (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Committed
Adam Smith (adamsmith) wrote :

Thanks, Sebastian. Can we have this in Trusty etc too please?

Sebastien Bacher (seb128) wrote :

You can read https://wiki.ubuntu.com/StableReleaseUpdates about requesting a stable update

Changed in webkitgtk (Ubuntu):
status: Fix Committed → Fix Released
Adam Smith (adamsmith) wrote :

I can confirm Midori and the Ubuntu-mate-welcome screen are working in vivid.

Adam Smith (adamsmith) wrote :

Sorry that should of been wily. It's still broken in vivid!

Adam Smith (adamsmith) wrote :

I can confirm that everything is working now. This can be closed

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

Changed in qtwebkit-opensource-src (Ubuntu):
status: Fix Released → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

no debug symbol package found for libasyncns0
no debug symbol package found for libsecret-1-0
no debug symbol package found for libgpg-error0
no debug symbol package found for ibus-gtk
no debug symbol package found for libudev1
no debug symbol package found for libproxy1
no debug symbol package found for libselinux1
no debug symbol package found for gecko-mediaplayer
no debug symbol package found for libenchant1c2a
no debug symbol package found for librtmp0
outdated debug symbol package for libidn11: package version 1.28-1ubuntu2.1 dbgsym version 1.28-1ubuntu2
no debug symbol package found for libp11-kit-gnome-keyring
no debug symbol package found for libcroco3
no debug symbol package found for libfreetype6
no debug symbol package found for libaspell15
no debug symbol package found for libwebp5
no debug symbol package found for libexpat1
no debug symbol package found for libuuid1

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-powerpc-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.