PySide FTBFS with new QtWebKit

Bug #1191286 reported by Dmitry Shachnev on 2013-06-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtwebkit-source (Ubuntu)
High
Dmitry Shachnev

Bug Description

PySide fails to build because in QtWebKit 2.3.1-0ubuntu1 /usr/lib/$(DEB_HOST_MULTIARCH)/libQtWebKit.so points to the wrong place. The attached debdiff attempts to fix that.

Dmitry Shachnev (mitya57) wrote :
Philip Muškovac (yofel) wrote :

I just fixed this the quick way as it was blocking work on KDE 4.10.80, but your fix looks like the proper way to do this.
I'll upload it after a quick check.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtwebkit-source - 2.3.1-0ubuntu3

---------------
qtwebkit-source (2.3.1-0ubuntu3) saucy; urgency=low

  * Do not hardcode wrong .so version name when creating a symlink,
    instead use a symlink provided by upstream build (LP: #1191286).
 -- Dmitry Shachnev <email address hidden> Sat, 15 Jun 2013 16:41:49 +0400

Changed in qtwebkit-source (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers