QtWebKit JS crash on 32-bit systems

Bug #1180731 reported by Robert Knight on 2013-05-16
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
qtwebkit-source (Ubuntu)
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned

Bug Description

QtWebKit 2.3.0 as shipped in Ubuntu 13.04 is affected by the bug described at https://bugs.webkit.org/show_bug.cgi?id=108991 which can causes JS crashes on certain pages on 32bit systems. I was not able to reproduce the problem using gap.com as described on that bug report but I can reproduce using Mendeley Desktop.

Applying the patch at https://bug-108991-attachments.webkit.org/attachment.cgi?id=186726 to the source package for libqtwebkit4 fixes the problem.

Steps to reproduce:

 1. Install Mendeley Desktop 1.8.4 from http://download.mendeley.com/apt/pool/main/m/mendeleydesktop/mendeleydesktop_1.8.4-stable_i386.deb on Ubuntu 13.04 (32bit)
 2. Start the app with 'mendeleydesktop --setting General_FirstRun:false' to skip the login screen (if you have a Mendeley account, you can use that instead)
 3. Go to View -> Library As Citations (this invokes a JS program to render citations)

Stacktrace (using a build of QWK with debug symbols included for JavaScriptCode): https://gist.github.com/anonymous/5585274

Regression Potential:

QtWebKit is used as the engine by the arora browser and other apps. If there is an error in the patch it would probably manifest in a similar way to the original issue (browser crash executing JS). Suggested testing approach is visit gap.com, datejs.com and a few JS-heavy web apps with the fixed package.

Jonathan Riddell (jr) wrote :

uploaded to saucy and raring-proposed
it fails to build in saucy presumably due to toolchain issues, unrelated to this patch. raring builds fine for me locally.
in unapproved awaiting approved from ~ubuntu-sru

Jonathan Riddell (jr) on 2013-05-16
tags: added: kubuntu
Brian Murray (brian-murray) wrote :

Hi, this is missing Regression Potential. Please see https://wiki.ubuntu.com/StableReleaseUpdates#Procedure for more information.

Robert Knight (robertknight) wrote :

Hello Brian - I've added this section. Please let me know if you'd like anything more.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtwebkit-source (Ubuntu Raring):
status: New → Confirmed
Changed in qtwebkit-source (Ubuntu):
status: New → Confirmed

For me, I;m not sure the exact bug as it is. But when I opened Mendeley Desktop, and try to send citation to OpenOffice, Mendeley crashed down. Mendeley works well in 12.04.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtwebkit-source - 2.3.1-0ubuntu3

---------------
qtwebkit-source (2.3.1-0ubuntu3) saucy; urgency=low

  * Do not hardcode wrong .so version name when creating a symlink,
    instead use a symlink provided by upstream build (LP: #1191286).
 -- Dmitry Shachnev <email address hidden> Sat, 15 Jun 2013 16:41:49 +0400

Changed in qtwebkit-source (Ubuntu Saucy):
status: Confirmed → Fix Released
jgratero (jgratero) wrote :

The bug is still present, at least when it comes to the case of Mendeley. I've just installed the 1.9.2 version in Xubuntu 13.04, and is just there (same error message displayed)

Joan Maspons (jmaspons) wrote :

I have the same problem in kubuntu 13.10 32 bits and Mendeley 1.10.1

I also still see the problem, with Mendeley 1.10.1 nd Ubuntu 13.10 (at least I see Mendeley's error message)

Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in qtwebkit-source (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers