Video playback broken with Qt 5.5

Bug #1474695 reported by Timo Jyrinki on 2015-07-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Zoltan Balogh
qtvideo-node (Ubuntu)
Critical
Timo Jyrinki

Bug Description

Video playback is broken with Qt 5.5 (tested on mako). Eg sintel trailer just shows a black screen, and no audio. Pure music playback does work elsewhere.

More information at https://wiki.ubuntu.com/Touch/QtTesting

Related branches

Timo Jyrinki (timo-jyrinki) wrote :

Thumbnailing works however fine, but the video does not play in Media Player.

Changed in qtvideo-node (Ubuntu):
assignee: nobody → Jim Hodapp (jhodapp)
Jim Hodapp (jhodapp) on 2015-10-05
no longer affects: mediaplayer-app (Ubuntu)
Timo Jyrinki (timo-jyrinki) wrote :
Timo Jyrinki (timo-jyrinki) wrote :

Videos in YouTube work, and the id used in qtvideo-node is still at the /5.2 it was adapted to during http://bazaar.launchpad.net/~phablet-team/qtvideo-node/trunk/revision/49

Jim Hodapp (jhodapp) wrote :

Can you get the log for mediaplayer-app as well? This will have the qtmultimedia/qtubuntu-media debug output.

Timo Jyrinki (timo-jyrinki) wrote :

Not much to be seen here. It now eventually crashes, attaching the crash file too.

Timo Jyrinki (timo-jyrinki) wrote :
Timo Jyrinki (timo-jyrinki) wrote :

The .crash file is not of much help without debug symbols though.

Timo Jyrinki (timo-jyrinki) wrote :

Ok it's possible to gdb -p [pidofmediaplayer-app] to get:

#0 0xb636a580 in QObject::staticMetaObject () from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#1 0xb0711c34 in QDeclarativeVideoRendererBackend::updatePaintNode (this=0x8bd328, oldNode=0xad30a070, data=<optimized out>)
    at qdeclarativevideooutput_render.cpp:319
#2 0xb69f15ce in QQuickWindowPrivate::updateDirtyNode (this=this@entry=0x7bd658, item=item@entry=0x868eb0)
    at items/qquickwindow.cpp:2985
#3 0xb69f1af4 in QQuickWindowPrivate::updateDirtyNodes (this=this@entry=0x7bd658) at items/qquickwindow.cpp:2723
#4 0xb69f1c2c in QQuickWindowPrivate::syncSceneGraph (this=this@entry=0x7bd658) at items/qquickwindow.cpp:341
#5 0xb69d2274 in QSGRenderThread::sync (this=this@entry=0x90bf38, inExpose=inExpose@entry=false)
    at scenegraph/qsgthreadedrenderloop.cpp:512
#6 0xb69d2a64 in QSGRenderThread::syncAndRender (this=this@entry=0x90bf38) at scenegraph/qsgthreadedrenderloop.cpp:558
#7 0xb69d6776 in QSGRenderThread::run (this=0x90bf38) at scenegraph/qsgthreadedrenderloop.cpp:674
#8 0xb60a8106 in QThreadPrivate::start (arg=0x90bf38) at thread/qthread_unix.cpp:331
#9 0xb5df6490 in start_thread () from /lib/arm-linux-gnueabihf/libpthread.so.0

That's probably as far as I can get there, and the trace doesn't show any hints why video playback works for eg thumbnailer + in Youtube but not in media-player - nothing related to qtvideo-node shown for example, and the backtrace does not go further back because of corrupt stack.

Any help welcome.

Jim Hodapp (jhodapp) wrote :

Thanks Timo. It looks like this is a regression or change of behavior in how the Qt threaded renderer works. Perhaps it has a new requirement for how a QSGVideoNode needs to be setup. Another thought: we brought QSGVideoNode into qtubuntu-media, maybe the definition used by the threaded renderer loop has changed for Qt 5.5 and we need to update our local copy of it.

Timo Jyrinki (timo-jyrinki) wrote :

Right, you mean qtvideo-node. Thanks for reminding about the inclusion of those private headers, they had indeed changed.

With the attached MP video playback works again.

Changed in qtvideo-node (Ubuntu):
assignee: Jim Hodapp (jhodapp) → Timo Jyrinki (timo-jyrinki)
status: New → In Progress
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → Critical
milestone: none → backlog
status: New → In Progress
Pat McGowan (pat-mcgowan) wrote :

downgrade since we will not move to 5.5 near term

Changed in canonical-devices-system-image:
importance: Critical → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtvideo-node - 0.2.1+16.04.20151104-0ubuntu1

---------------
qtvideo-node (0.2.1+16.04.20151104-0ubuntu1) xenial; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Timo Jyrinki ]
  * Port to Qt 5.5 to fix video playback (LP: #1474695) (LP: #1474695)

 -- CI Train Bot <email address hidden> Wed, 04 Nov 2015 08:20:56 +0000

Changed in qtvideo-node (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers