RM: obsolete product

Bug #1708326 reported by Dimitri John Ledkov on 2017-08-03
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
qtubuntu (Ubuntu)
Medium
Andy Whitcroft

Bug Description

qtubuntu was a component of Ubuntu Phone which is no longer developed.

Please remove this package from the Ubuntu Archive.

$ reverse-depends src:qtubuntu
No reverse dependencies found

$ reverse-depends -b src:qtubuntu
No reverse dependencies found

Changed in qtubuntu (Ubuntu):
status: New → Triaged
Alan Griffiths (alan-griffiths) wrote :

qtubuntu supports Qt applications running on Mir, it is selected at runtime, so it has no "depends".

It is still needed for the artful cycle, we're removing it's dependency on platform-api (lp:~albaguirre/qtubuntu/papi-cleanup/+merge/324886)

Michał Sawicz (saviq) wrote :

qtubuntu is not obsolete yet - it's the Qt platform support for Mir.

We've started cleaning up its dependencies in:

https://code.launchpad.net/~albaguirre/qtubuntu/papi-cleanup/+merge/324886

We'll need a follow-up to drop the content-hub dependency.

Dimitri John Ledkov (xnox) wrote :

Ack.

I have now seeded qtubuntu-desktop into supported-kiosk seed, with a comment pointing at this bug.

This should prevent removal of qtubuntu. Sorry for the misshap here.

Regards,

Dimitri.

Changed in qtubuntu (Ubuntu):
status: Triaged → Invalid
tags: removed: u8rm
Dimitri John Ledkov (xnox) wrote :
tags: added: u8rm
Gerry Boland (gerboland) wrote :

Reopening as Mir has sufficiently good Wayland support to support Qt5. qtubuntu can be removed from the archive

Changed in qtubuntu (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtubuntu (Ubuntu):
status: New → Confirmed
Andy Whitcroft (apw) wrote :

No longer seeded, and according to the project people is not needed in cosmic as mir now can talk directly.

Changed in qtubuntu (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Andy Whitcroft (apw)
Andy Whitcroft (apw) wrote :

Not in use by anything either:

  $ seeded-in-ubuntu -b qtubuntu-android qtubuntu-desktop
  qtubuntu-android is not seeded (and may not exist).
  qtubuntu-desktop is not seeded (and may not exist).
  $ reverse-depends src:qtubuntu
  No reverse dependencies found

Removing:

$ remove-package -m 'Obselete product -- LP: #1708326' -s cosmic-proposed qtubuntu
Removing packages from cosmic-proposed:
        qtubuntu 0.64+17.10.20170707-0ubuntu8 in cosmic
Comment: Obselete product -- LP: #1708326
1 package successfully removed.

$ remove-package -m 'Obselete product -- LP: #1708326' -s cosmic qtubuntu
Removing packages from cosmic:
        qtubuntu 0.64+17.10.20170707-0ubuntu7 in cosmic
                qtubuntu-android 0.64+17.10.20170707-0ubuntu7 in cosmic arm64
                qtubuntu-android 0.64+17.10.20170707-0ubuntu7 in cosmic armhf
                qtubuntu-desktop 0.64+17.10.20170707-0ubuntu7 in cosmic amd64
                qtubuntu-desktop 0.64+17.10.20170707-0ubuntu7 in cosmic arm64
                qtubuntu-desktop 0.64+17.10.20170707-0ubuntu7 in cosmic armhf
                qtubuntu-desktop 0.64+17.10.20170707-0ubuntu7 in cosmic i386
                qtubuntu-desktop 0.64+17.10.20170707-0ubuntu7 in cosmic ppc64el
                qtubuntu-desktop 0.64+17.10.20170707-0ubuntu7 in cosmic s390x
Comment: Obselete product -- LP: #1708326
1 package successfully removed.

Changed in qtubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers