camera-app goes black, won’t work until the phone is rebooted

Bug #1493857 reported by Olivier Tilloy on 2015-09-09
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
qtubuntu-camera (Ubuntu)
High
Florian Boucault

Bug Description

The following scenario has happened to me a few times since I use the BQ aquaris e4.5 as my main phone:

 - opened the camera app, took a few pictures, viewed them in the photoroll, shared one via telegram (as a result the camera app goes into the background)
 - carried out other unrelated tasks (web browsing, …)
 - focused back the camera app, swiped to the right to close the photoroll
 - got a completely black screen and (IIRC) a deactivated shutter button

I was on the go when that happened, so no way to debug the issue, and as I really wanted to use the camera, what I did is I rebooted the phone. This "fixed" the issue.

Unfortunately whenever I have tried to reproduce the issue, I have not managed to do so. It seems to happen randomly.

Olivier Tilloy (osomon) wrote :

Note that when that happens, closing all open applications and then launching the camera-app again didn’t result in an improvement.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtubuntu-camera (Ubuntu):
status: New → Confirmed

This problem just happened to me after updating to
rc-proposed 129 on krillinn

And still happens on my wifes krillin with OTA6

What logs should i attach ?

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → backlog
status: New → Confirmed
Bill Filler (bfiller) on 2015-11-10
Changed in qtubuntu-camera (Ubuntu):
assignee: nobody → Florian Boucault (fboucault)
importance: Undecided → High
Changed in canonical-devices-system-image:
milestone: backlog → ww02-2016
Changed in canonical-devices-system-image:
milestone: ww02-2016 → ww08-2016
Olivier Tilloy (osomon) wrote :

Haven’t seen this issue in a long time, I wonder if it’s somehow been fixed?

Florian Boucault (fboucault) wrote :

Closing tentatively :) Reopen if needed

Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in qtubuntu-camera (Ubuntu):
status: Confirmed → Fix Released
Changed in qtubuntu-camera (Ubuntu):
status: Fix Released → Invalid
Changed in canonical-devices-system-image:
milestone: ww08-2016 → ww02-2016
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers