Crashes when compiled with oFono support

Bug #1199813 reported by Timo Jyrinki
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtsystems-opensource-src (Ubuntu)
Undecided
Timo Jyrinki

Bug Description

A segfault in imei reading when using the test program from bug #1197542 when qtsystems has been compiled with CONFIG+=ofono. No crash happens if compiled without.

Backtrace at https://launchpadlibrarian.net/144620369/qtsystems-ofono-backtrace.txt

Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :
description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue is in
QString QDeviceInfoPrivate::imei(int interface)
{
...
              imeiBuffer[interface] = ofonoWrapper->imei(modem);
...
}

the assignment there doesn't work, replace it by "imeiBuffer += ofonoWrapper->imei(modem);" resolves the segfault (but it's probably not correct since it loose the index)

Changed in qtsystems-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtsystems-opensource-src - 5.0~git20130712-0ubuntu1

---------------
qtsystems-opensource-src (5.0~git20130712-0ubuntu1) saucy; urgency=low

  * Configure with CONFIG+=ofono (LP: #1199185)
  * New upstream snapshot fa61ba41b962aa66bf6dc62ce62ce0734063abf9.
    - Fixes oFono segfault (LP: #1199813)
    - Remove some of the examples that aren't installed anymore
  * Add Vcs-Bzr
 -- Timo Jyrinki <email address hidden> Fri, 12 Jul 2013 13:41:02 +0300

Changed in qtsystems-opensource-src (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers