LXQt Appearance Configuration: row height expands abnormally

Bug #1785401 reported by Histesh Shah on 2018-08-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lxqt-config (Ubuntu)
Undecided
Unassigned
qtstyleplugins-src (Ubuntu)
Undecided
Unassigned

Bug Description

$ lsb_release -rd
Description: Ubuntu Cosmic Cuttlefish (development branch)
Release: 18.10
dkb@LubuCC:~$

System information via inxi:

dkb@LubuCC:~$ inxi -Fxxxz
System: Host: LubuCC Kernel: 4.17.0-6-generic x86_64 bits: 64 compiler: gcc v: 8.1.0 Desktop: LXQt 0.13.0
           tk: Qt 4.8.7 info: lxqt-panel wm: Openbox 3.6.1 dm: sddm Distro: Ubuntu 18.10 (Cosmic Cuttlefish)
Machine: Type: Kvm System: QEMU product: Standard PC (i440FX + PIIX, 1996) v: pc-i440fx-bionic
           serial: <filter> Chassis: type: 1 v: pc-i440fx-bionic serial: <filter>
           Mobo: N/A model: N/A serial: N/A BIOS: SeaBIOS v: 1.10.2-1ubuntu1 date: 04/01/2014
CPU: Topology: Single Core model: Intel Core (Broadwell no TSX IBRS) bits: 64 type: MCP arch: Broadwell
           rev: 2 L2 cache: 16.0 MiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 3984
           Speed: 1992 MHz min/max: N/A Core speed (MHz): 1: 1992
Graphics: Card-1: Red Hat QXL paravirtual graphic card driver: qxl v: kernel bus ID: 00:02.0
           chip ID: 1b36:0100
           Display: x11 server: X.Org 1.19.6 driver: none unloaded: fbdev,modesetting,vesa
           resolution: 1280x720~60Hz
           OpenGL: renderer: llvmpipe (LLVM 6.0 256 bits) v: 3.3 Mesa 18.1.3 compat-v: 3.1 direct render: Yes
Audio: Card-1: Intel 82801FB/FBM/FR/FW/FRW High Definition Audio vendor: Red Hat QEMU Virtual Machine
           driver: snd_hda_intel v: kernel bus ID: 00:04.0 chip ID: 8086:2668
           Sound Server: ALSA v: k4.17.0-6-generic
Network: Card-1: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge driver: piix4_smbus v: N/A port: N/A
           bus ID: 00:01.3 chip ID: 8086:7113
           Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter driver: 8139cp v: 1.3 port: c000
           bus ID: 00:03 chip ID: 10ec:8139
           IF: ens3 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: Local Storage: total: 10.00 GiB used: 4.72 GiB (47.2%)
           ID-1: /dev/sda model: QEMU HARDDISK size: 10.00 GiB speed: <unknown> serial: <filter> rev: 2.5+
           scheme: MBR
Partition: ID-1: / size: 9.78 GiB used: 4.72 GiB (48.3%) fs: ext4 dev: /dev/sda1
Sensors: Message: No sensors data was found. Is sensors configured?
Info: Processes: 119 Uptime: 4m Memory: 3.85 GiB used: 394.1 MiB (10.0%) Init: systemd v: 237 runlevel: 5
           Compilers: gcc: 8.2.0 alt: 8 Shell: bash v: 4.4.19 running in: qterminal inxi: 3.0.20
dkb@LubuCC:~$

=====================================================================================

When I open LXQt Appearance Configuration (/usr/bin/lxqt-config-appearance) and click on any of the choices for "Widget Style"

What I expect: row height should not change
What happened instead: clicking on bb10dark or on bb10bright causes the row height to increase so that the bottom reset and close buttons are off the screen. Clicking again on any style other than those two styles restores row height and window dimensions.

Revision history for this message
Histesh Shah (chimak111) wrote :
Revision history for this message
Histesh Shah (chimak111) wrote :

Changed affected package to lxqt-config

affects: qterminal (Ubuntu) → lxqt-config (Ubuntu)
Revision history for this message
Simon Quigley (tsimonq2) wrote :

This is not a problem with the LXQt configuration, but it's a problem with qtstyleplugins-src.

affects: lxqt-config (Ubuntu) → qtstyleplugins-src (Ubuntu)
Revision history for this message
Simon Quigley (tsimonq2) wrote :

I would also highly recommend that you file a bug upstream alerting them of this.

Revision history for this message
Histesh Shah (chimak111) wrote :

How do I file a bug upstream? Could you please provide details or a link?

Revision history for this message
Histesh Shah (chimak111) wrote :
Revision history for this message
Histesh Shah (chimak111) wrote :

tsimonq, thanks for forwarding upstream. I filed as well and it was closed as a dupe of your forward: https://github.com/lxqt/lxqt/issues/1532

Revision history for this message
Simon Quigley (tsimonq2) wrote :

When I said upstream, I meant Qt.

Revision history for this message
Simon Quigley (tsimonq2) wrote :

lxqt-config shouldn't recommend it.

Revision history for this message
Simon Quigley (tsimonq2) wrote :
Changed in lxqt-config (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lxqt-config - 0.13.0-0ubuntu3

---------------
lxqt-config (0.13.0-0ubuntu3) cosmic; urgency=medium

  * Run wrap-and-sort.
  * Demote qt5-style-plugins to a Suggests, because some of the themes are not
    working (LP: #1785401).

 -- Simon Quigley <email address hidden> Thu, 09 Aug 2018 14:24:44 -0500

Changed in lxqt-config (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtstyleplugins-src (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.