Lubuntu Daily ISO (May 19) QtPass error "GnuPG not found"

Bug #1829693 reported by Eric Adams on 2019-05-20
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
qtpass (Ubuntu)
Undecided
Philip Rinn

Bug Description

SUMMARY
Due to varying expectations about the state of gpg and gpg2, QtPass produces an error on launch.

STEPS TO REPRODUCE
Launch QtPass on Lubuntu 19.10 (daily, as of 19 May)

EXPECTED RESULTS
Launching QtPass succeeds without error.

ACTUAL RESULTS
Launching QtPass results in an error "GnuPG not found."

WORKAROUND
 1. Install gnupg2
 2. In ~/.config/IJHack/QtPass.conf, set gptExecutable=/usr/bin/gpg2

===

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: qtpass 1.2.3-2
ProcVersionSignature: Ubuntu 5.0.0-13.14-generic 5.0.6
Uname: Linux 5.0.0-13-generic x86_64
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CasperVersion: 1.407
CurrentDesktop: LXQt
Date: Mon May 20 03:37:06 2019
ExecutablePath: /usr/bin/qtpass
LiveMediaBuild: Lubuntu 19.10 "Eoan Ermine" - Alpha amd64 (20190519)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
 TERM=qterminal
SourcePackage: qtpass
UpgradeStatus: No upgrade log present (probably fresh install)

Eric Adams (esa1975) wrote :
Eric Adams (esa1975) wrote :
Eric Adams (esa1975) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1829693

tags: added: iso-testing
Dan Simmons (kc2bez) wrote :

Thank you for submitting your report. I can confirm this behavior on a 19.10 install of Lubuntu. I can also confirm that it works properly on a 19.04 install of Lubuntu and it works properly on a 19.10 install of Kubuntu.

Changed in qtpass (Ubuntu):
status: New → Confirmed
Philip Rinn (rinni) wrote :

Uh, that's pretty strange as the posted Dependencies.txt clearly shows gpg as dependency.

Could you post the content of ~/.config/IJHack/QtPAss.conf

and the results from

which gpg2
which gpg
which pass

[You need to open a terminal and paste the three lines there]

Thanks!

Changed in qtpass (Ubuntu):
assignee: nobody → Philip Rinn (rinni)
Philip Rinn (rinni) wrote :

And can you confirm, that installing the package "gnupg2" fixes the problem?

Philip Rinn (rinni) wrote :

Alternatively you could change

gpgExecutable=/usr/bin/gpg2

to

gpgExecutable=/usr/bin/gpg

in ~/.config/IJHack/QtPAss.conf

Philip Rinn (rinni) wrote :

See also a corresponding upstream bug: https://github.com/IJHack/QtPass/issues/433

apt-ghetto (apt-ghetto) wrote :

Hi @rinni,

On Lubuntu 19.10, the value for gpgExecutable in ~/.config/IJHack/QtPass.conf is not set.
After installing gnupg2 and moving/deleting ~/.config/IJHack/QtPass.conf and starting QtPass, it recreates the config file with gptExecutable=/usr/bin/gpg2 and it works.

After git grepping:
I guess, the problem starts in https://github.com/IJHack/QtPass/blob/master/src/qtpasssettings.cpp#L289
Interesting: https://github.com/IJHack/QtPass/blob/master/src/configdialog.cpp#L241

guenter (guenterk) wrote :

I had the same problem with qtpass on Lubuntu 19.10 and solved it by adding the value '/usr/bin/gpg' to the empty 'gpgExecutable' entry in the config file '~/.config/IJHack/QtPass.conf'.

Maybe this remark is useful: I tried to install gpg2 but there is no such package, only gpg. And this is of version 2.

gpg --version
gpg (GnuPG) 2.2.12
libgcrypt 1.8.4
...

Walter Lapchynski (wxl) wrote :

I'm also really confused as to why gpg itself isn't at least a recommend or a suggest or something. Seems pretty darn essential.

And from what I can tell calling gpg on all supported releases at time of writing sans Xenial had the effect of invoking gpg version 2. Cosmic uniquely had a /usr/bin/gpg2 → gpg symlink from the gnupg2 package while gpg came from the gpg package. Xenial had both gpg and gpg2. It's all a ridiculous mess.

Walter Lapchynski (wxl) on 2019-09-27
description: updated
summary: - Lubuntu Daily ISO (May 19) QtPass error GnuPG not found
+ Lubuntu Daily ISO (May 19) QtPass error "GnuPG not found"
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtpass - 1.3.0-2

---------------
qtpass (1.3.0-2) unstable; urgency=medium

  * Add patch to fix editing of entries

 -- Philip Rinn <email address hidden> Mon, 16 Sep 2019 10:21:26 +0200

Changed in qtpass (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.