EDS reverts alarm status immediately

Bug #1272337 reported by Nekhelesh Ramananthan on 2014-01-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Clock App
Status tracked in Trunk
Trunk
High
Zsombor Egri
Ubuntu UI Toolkit
Invalid
Undecided
Unassigned
qtorganizer5-eds (Ubuntu)
Undecided
Unassigned

Bug Description

The clock app provides switches to enable/disable individual alarms. However sometimes, I have noticed that on disabling an alarm, it immediately enables it again. Multiple tries to disable the alarm does not help. Again the key thing to remember here is that this does not happen everytime but only sometime. I have not found a reliable way to reproduce the issue. So you may have to do a bit of trial and error to confirm this bug.

Steps to reproduce:
1. Open clock app and navigate to alarm tab
2. Open toolbar and select "Add alarm"
3. Set any alarm (single or recurring)
4. Save the alarm
5. Attempt to set the alarm to disable by clicking the switch next to the new alarm

What happens sometimes:
The alarm is enabled again immediately by the system

What should happen
Since the user can toggle the alarm in the app, it is expected that the alarm can be turned off (so it is seen as disabled in the Upcoming settings menu tab)

Video showing the issue http://www.youtube.com/watch?v=Z5pkTq6V2vs&feature=youtu.be

Related branches

Changed in ubuntu-clock-app:
milestone: none → 1.6

could you isolate the bug in a small app?

Nekhelesh Ramananthan (nik90) wrote :
Changed in ubuntu-clock-app:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
description: updated
Changed in ubuntu-clock-app:
milestone: 1.6 → 1.8
tags: added: alarms dogfooding-blocker
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtorganizer5-eds (Ubuntu):
status: New → Confirmed
Changed in ubuntu-clock-app:
milestone: 1.8 → backlog

Markina s invalid for qtorganizer5-eds (Ubuntu) since the bug is related with SDK component.

Changed in qtorganizer5-eds (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-clock-app:
assignee: Renato Araujo Oliveira Filho (renatofilho) → nobody
Changed in ubuntu-clock-app:
milestone: backlog → alarm-blockers
Changed in ubuntu-clock-app:
milestone: alarm-blockers → rtm
Changed in ubuntu-clock-app:
milestone: rtm → backlog
status: Triaged → Won't Fix

Fix committed into lp:ubuntu-clock-app/reboot at revision 62, scheduled for release in ubuntu-clock-app, milestone rtm

Changed in ubuntu-clock-app:
status: Won't Fix → Fix Committed
Changed in ubuntu-clock-app:
status: Fix Committed → Won't Fix
Zsombor Egri (zsombi) on 2014-08-20
Changed in ubuntu-ui-toolkit:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints