Please sync qtoctave from debian unstable

Bug #227099 reported by Andreas Wenning
4
Affects Status Importance Assigned to Milestone
qtoctave (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qtoctave

Please sync qtoctave 0.7.4+dfsg-1 (universe) from Debian unstable (main).

Changes in ubuntu since common version listed here. All changes has been applied in debian version (0.7.1+dfsg-1), and can therefore be dropped as ubuntu-specific changes.

qtoctave (0.5.1+dfsg-1ubuntu2) hardy; urgency=low

  * Added debian/qtoctave.desktop file. (LP: #193208)
    - Added dh_install to debian/rules to install .desktop file.
  * Added icons in debian/icons.tar.uu
    - Now Build-Depends on sharutils to uudecode the icons.
    - Changes in debian/rules to decode the icons.
    - Build-Depends for debhelper changed to >= 5.0.51
  * Updated to Standards-Version 3.7.3
    - Added Homepage-field to debian/control
  * Minor changes to debian/rules to make lintian clean
  * Fixed typo in debian/control field name

 -- Andreas Wenning <email address hidden> Tue, 19 Feb 2008 19:28:10 +0100

qtoctave (0.5.1+dfsg-1ubuntu1) hardy; urgency=low

  * octave2.9 -> octave3.0 transition (LP: #185959)
    - debian/control: adjusted binary deps accordingly
  * Adjusted Maintainer field

 -- Stephan Hermann <email address hidden> Fri, 25 Jan 2008 13:23:57 +0100

Changelog since current intrepid version 0.5.1+dfsg-1ubuntu2:

qtoctave (0.7.4+dfsg-1) unstable; urgency=low

  [ Rafael Laboissiere ]
  * debian/control: Drop the build-dependencies on several lib*-dev
    packages introduced in the previous versions. Force the
    build-dependency on libqt4-dev to be equal or greater than 4.4.0~rc1-4
    in order to have the above working.

  [ Thomas Weber ]
  * New upstream version (starts up cleanly, closes: #476768)
  * debian/rules, debian/control: switch to CMake based system, as upstream
    switched to CMake. Likewise, use CDBS.
  * New patches:
    - build-out-of-source:
      enables out-of-source builds for CMake, by addinge some include paths to
      the cmake include directories
    - use_octave3.0-htmldoc:
      Use octave3.0's htmldoc, instead of the stripped HTML files from
      upstream.
    - move_doc_under_doc:
      Move the qtoctave_doc/ directory from /usr/share/qtoctave to
      /usr/share/doc/qtoctave
    Dropped patch: compile-with-gcc-4.4.diff, now superfluous.
  * debian/docs: some doc files changed their names to lowercase.
  * Use debian/qtoctave.manpages for manpage installation.
  * debian/lintian-overrides: Override empty directory warnings. The
    directories are either empty from upstream or after the repackaging.

 -- Thomas Weber <email address hidden> Tue, 22 Apr 2008 09:03:38 +0200

qtoctave (0.7.1+dfsg-4) unstable; urgency=low

  * debian/control: Build-depend on several lib*-dev packages that used to
    be dependencies of libqt4-dev

 -- Rafael Laboissiere <email address hidden> Mon, 14 Apr 2008 11:35:47 +0200

qtoctave (0.7.1+dfsg-3) unstable; urgency=low

  * debian/patches/compile-with-gcc-4.4.diff: Renamed patch
  * debian/rules: Apply patches before running configure. This really
    insures that the package compiles against GCC 4.4 (closes: #475921).

 -- Rafael Laboissiere <email address hidden> Mon, 14 Apr 2008 09:00:10 +0200

qtoctave (0.7.1+dfsg-2) unstable; urgency=low

  [ Thomas Weber ]
  * debian/control: Vcs-fields point to the trunk/ directory

  [ Rafael Laboissiere ]
  * debian/rules: Adapt for using quilt
  * debian/control:
    + Build-depend on quilt
    + Add build-dependency on libaudio-dev, which used to be a dependency
      of libqt4-dev
  * debian/patches/compile-with-gcc-4.1.diff: Patch for including cstdlib
    in install-tool2/install.cpp and allowing the package to build against
    GCC 4.4 (closes: #474837)

 -- Rafael Laboissiere <email address hidden> Sun, 13 Apr 2008 15:28:07 +0200

qtoctave (0.7.1+dfsg-1) unstable; urgency=low

  * New upstream release (closes: #462804)
  * debian/control:
    + Depends on octave3.0
    + Bumped Standards-Version to 3.7.3 (no changes needed)
    + Maintainer is now the Debian Octave Group
    + Add myself and Jordi Gutiérrez to the list of Uploaders
    + Add Homepage, Vcs-Svn, and Vcs-Browser fields
  * debian/rules:
    + Do not ignore errors in make clean
    + Do not alter upstream files config.guess and config.sub
      (closes: #466737)
    + Make the configure executable (strangely enough, the upstream
      tarball contains a non-executable script)
    + Use "INSTALL_ROOT" instead of "prefix" when invoking make install
  * debian/copyright: Added proper copyright notice
  * Add debian/qtoctave.desktop file and icons in debian/icons.tar.uu
    (Build-Depends on sharutils to uudecode the icons). Thanks Andreas
    Wenning and the Ubuntu folks for the patch (closes: #466763).

 -- Rafael Laboissiere <email address hidden> Wed, 05 Mar 2008 17:32:23 +0100

Changed in qtoctave:
status: New → Confirmed
Revision history for this message
Andreas Wenning (andreas-wenning) wrote :

libqt4-dev need updating to 4.4.0~rc1 before the sync can be done. Missed it while looking through the dependencies; i'll write here again when it is updated.

Revision history for this message
Daniel Holbach (dholbach) wrote : ACK of sync request

ACKed.

Revision history for this message
Martin Pitt (pitti) wrote :

Getting binaries for intrepid...
[Updating] qtoctave (0.5.1+dfsg-1ubuntu2 [Ubuntu] < 0.7.4+dfsg-1 [Debian])
 * Trying to add qtoctave...
  - <qtoctave_0.7.4+dfsg-1.dsc: downloading from http://ftp.debian.org/debian/>
  - <qtoctave_0.7.4+dfsg.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
  - <qtoctave_0.7.4+dfsg-1.diff.gz: downloading from http://ftp.debian.org/debian/>
I: qtoctave [universe] -> qtoctave_0.5.1+dfsg-1ubuntu2 [universe].

Changed in qtoctave:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers