QtNX hangs during connect

Bug #244961 reported by Sebastian Urban on 2008-07-02
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
qtnx (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qtnx

When trying to connect to our FreeNX server, QtNX hangs. The text in the status bar and Logging Output reads "Process started". No further messages are displayed.

TODO:
run from terminal and report the messages displayed there. QtNX fails to display some important messages in the gui but writes them to STDOUT.

ZdadrDeM (zdadr-dem) wrote :

Same problem here. I tried to connect to FreeNx (NXSERVER - Version 2.1.0-72 OS (GPL, using backend: 3.1.0)).

stdout> NX> 1000 NXNODE - Version 2.1.0-72 OS (GPL, using backend: 3.1.0)
stdout> NX> 700 Session id: myhostname-1001-9A2172C34FA1AE10FAEDFE0A5C463D94
NX> 705 Session display: 1001
NX> 703 Session type: unix-kde
NX> 701 Proxy cookie: ae5b0e2bffc8236508f2da298c9a9690
NX> 702 Proxy IP: 127.0.0.1
NX> 706 Agent cookie: ae5b0e2bffc8236508f2da298c9a9690
NX> 704 Session cache: unix-kde
NX> 707 SSL tunneling: 1
stdout> NX> 1009 Session status: starting
NX> 710 Session status: running
NX> 1002 Commit
NX> 105
stdin> bye
stderr> NX> 1006 Session status: running
/usr/lib/nx/nxserver: line 1368: 16218 Beendet sleep $AGENT_STARTUP_TIMEOUT
stdout> bye
stderr> Bye
NX> 999 Bye
Starting NX proxy
NX_COMMFD=17Process started

Michael Nagel (nailor) wrote :

confirming, too

Changed in qtnx:
status: New → Confirmed
AZ (m-dev) wrote :

same happends for me to. it usually helps to kill qtnx and retry.

willdeans (william-deans) wrote :

Same happens for me with 3.3.0 backend.

Kevin (kjslag) wrote :

I'm also having the same problem on Ubuntu 9.04

Endolith (endolith) wrote :

Same thing for me, but when I ran it from the Terminal I realized it was prompting to add the host. After typing "yes" at the command line Qtnx went blank, but then when I restarted it and tried again, it worked.

Endolith (endolith) wrote :

Now it's doing it again. I run it from a terminal and it says

stderr> tr: write error: No space left on device

Aha!

You really need to display error messages to the user instead of just hanging at "Authenticating client".

Michael Nagel (nailor) on 2010-02-14
description: updated
Matt Janus (hello-mattjan) wrote :

Client just hangs when trying to connect. It says "Process started" and displays no other message. This bug is 2 years old and still no fixes?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers