load() of a QDeclarativePlaylist does not fully work

Bug #1510225 reported by Jim Hodapp on 2015-10-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Unassigned
qtmultimedia-opensource-src (Ubuntu)
Medium
Andrew Hayzen
qtmultimedia-opensource-src (Ubuntu RTM)
Medium
Andrew Hayzen
qtubuntu-media (Ubuntu)
Medium
Andrew Hayzen
qtubuntu-media (Ubuntu RTM)
Medium
Andrew Hayzen

Bug Description

* load(location) only works when a QDeclarativePlaylist is not read-only.
* QMediaPlayer loads playlist items one by one instead of using the new addTracks for much greater efficiency and lower latency.

Jim Hodapp (jhodapp) on 2015-10-26
tags: added: bgplaylist
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
importance: Undecided → Medium
milestone: none → backlog
status: New → Confirmed
Andrew Hayzen (ahayzen) wrote :

This does not block music-app landing as we have a custom solution (albeit a slow one) as long as we still have the lifecycle exception.

Jim Hodapp (jhodapp) on 2015-11-02
Changed in qtmultimedia-opensource-src (Ubuntu):
status: New → Triaged
Changed in qtmultimedia-opensource-src (Ubuntu RTM):
status: New → Triaged
Changed in qtubuntu-media (Ubuntu):
status: New → Triaged
Changed in qtubuntu-media (Ubuntu RTM):
status: New → Triaged
Jim Hodapp (jhodapp) on 2015-11-02
Changed in qtmultimedia-opensource-src (Ubuntu):
importance: Undecided → Medium
Changed in qtmultimedia-opensource-src (Ubuntu RTM):
importance: Undecided → Medium
Changed in qtubuntu-media (Ubuntu):
importance: Undecided → Medium
Changed in qtubuntu-media (Ubuntu RTM):
importance: Undecided → Medium
Jim Hodapp (jhodapp) wrote :

ahayzen has shown that it does in fact work. Therefore this bug is no longer valid.

Changed in canonical-devices-system-image:
status: Confirmed → Invalid
Changed in qtmultimedia-opensource-src (Ubuntu):
status: Triaged → Invalid
Changed in qtmultimedia-opensource-src (Ubuntu RTM):
status: Triaged → Invalid
Changed in qtubuntu-media (Ubuntu):
status: Triaged → Invalid
Changed in qtubuntu-media (Ubuntu RTM):
status: Triaged → Invalid
Andrew Hayzen (ahayzen) wrote :

@Jim, the save works, but the load doesn't due to a) qtubuntu-media having the playlist in 'read-only' mode and b) qtmultimedia passing each item to addMedia instead of a list causing a large performance hit.

I've got patches for qtubuntu-media and just figuring out the qtmultimedia one, shall I use this bug for tracking these issues? And link the branches to this bug?

Jim Hodapp (jhodapp) wrote :

Sure that'd be fine to track with this. I'll change the title a bit to reflect that save() is working. We should really make the change for the read only fix in media-hub as qtubuntu-media merely passes on the can_edit_tracks() value for the current tracklist.

Changed in canonical-devices-system-image:
status: Invalid → Triaged
summary: - Load and save of a QDeclarativePlaylist do not work
+ load() of a QDeclarativePlaylist does not fully work
description: updated
Changed in qtmultimedia-opensource-src (Ubuntu):
status: Invalid → Triaged
Changed in qtmultimedia-opensource-src (Ubuntu RTM):
status: Invalid → Triaged
no longer affects: qtubuntu-media (Ubuntu)
no longer affects: qtubuntu-media (Ubuntu RTM)
Changed in media-hub (Ubuntu):
status: New → Triaged
Changed in media-hub (Ubuntu RTM):
status: New → Triaged
Changed in media-hub (Ubuntu):
importance: Undecided → Medium
Changed in media-hub (Ubuntu RTM):
importance: Undecided → Medium
Changed in media-hub (Ubuntu):
assignee: nobody → Andrew Hayzen (ahayzen)
Changed in media-hub (Ubuntu RTM):
assignee: nobody → Andrew Hayzen (ahayzen)
Changed in qtmultimedia-opensource-src (Ubuntu):
assignee: nobody → Andrew Hayzen (ahayzen)
Changed in qtmultimedia-opensource-src (Ubuntu RTM):
assignee: nobody → Andrew Hayzen (ahayzen)
Andrew Hayzen (ahayzen) wrote :

@Jim, I think the issue is in qtubuntu-media, can_edit_tracks() returns True, but what was happening is qtubuntu-media was returning that straight away to isReadOnly() therefore making that True as well, rather than flipping it. So I've just changed it so return !can_edit_tracks(); ... so in that case can_edit_tracks() is True, making isReadOnly() False. I will link the branch later and it'll probably make more sense then :-)

Jim Hodapp (jhodapp) wrote :

Yeah makes sense, didn't realize that was the issue. That's a simple fix and will adjust the bug again. :)

no longer affects: media-hub (Ubuntu)
no longer affects: media-hub (Ubuntu RTM)
Changed in qtubuntu-media (Ubuntu):
importance: Undecided → Medium
Changed in qtubuntu-media (Ubuntu RTM):
importance: Undecided → Medium
Changed in qtubuntu-media (Ubuntu):
status: New → In Progress
Changed in qtubuntu-media (Ubuntu RTM):
status: New → In Progress
Changed in qtubuntu-media (Ubuntu):
assignee: nobody → Andrew Hayzen (ahayzen)
Changed in qtubuntu-media (Ubuntu RTM):
assignee: nobody → Andrew Hayzen (ahayzen)
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Changed in qtmultimedia-opensource-src (Ubuntu):
status: Triaged → In Progress
Changed in qtmultimedia-opensource-src (Ubuntu RTM):
status: Triaged → In Progress
Andrew Hayzen (ahayzen) wrote :

The qtmultimedia patch [0] as part of QTBUG-54849 [1] has been approved upstream. Now we just need to get this patch into our image and then we should be able to land the qtubuntu-media fix :-)

0 - https://codereview.qt-project.org/#/c/168472/
1 - https://bugreports.qt.io/browse/QTBUG-54849

Timo Jyrinki (timo-jyrinki) wrote :

Built and soon testable (as soon as LP publishes the binaries to be available) from https://requests.ci-train.ubuntu.com/#/ticket/1972. Use phablet-tools-bileto's bileto tool for example to upgrade a device, or just apt-add-repository on desktop where no apt pinning is required.

Timo Jyrinki (timo-jyrinki) wrote :

Reminder the ticket is still waiting for testing before it goes forward.

Timo Jyrinki (timo-jyrinki) wrote :

(qtubuntu-media was added 3 days ago)

Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package qtubuntu-media 0.8.1+15.04.20160927-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

qtubuntu-media (0.8.1+15.04.20160927-0ubuntu1) vivid; urgency=medium

  [ Andrew Hayzen ]
  * Fix isReadOnly to respect can_edit_tracks correct, so when
    can_edit_tracks is True isReadOnly is False (LP: #1510225)

 -- Timo Jyrinki <email address hidden> Tue, 27 Sep 2016 10:01:26 +0000

Changed in qtubuntu-media (Ubuntu RTM):
status: In Progress → Fix Released
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package qtmultimedia-opensource-src 5.4.1-1ubuntu19~overlay5~1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

qtmultimedia-opensource-src (5.4.1-1ubuntu19~overlay5~1) vivid; urgency=medium

  * debian/patches/Optimize-QMediaPlaylistPrivate-readItems.patch
    - Fix load() (LP: #1510225)

 -- Timo Jyrinki <email address hidden> Wed, 21 Sep 2016 11:39:33 +0000

Changed in qtmultimedia-opensource-src (Ubuntu RTM):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu-media - 0.8.1+16.10.20160927-0ubuntu1

---------------
qtubuntu-media (0.8.1+16.10.20160927-0ubuntu1) yakkety; urgency=medium

  [ Andrew Hayzen ]
  * Fix isReadOnly to respect can_edit_tracks correct, so when
    can_edit_tracks is True isReadOnly is False (LP: #1510225)

 -- Timo Jyrinki <email address hidden> Tue, 27 Sep 2016 10:01:26 +0000

Changed in qtubuntu-media (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmultimedia-opensource-src - 5.6.1-2ubuntu2~1

---------------
qtmultimedia-opensource-src (5.6.1-2ubuntu2~1) yakkety; urgency=medium

  * debian/patches/Optimize-QMediaPlaylistPrivate-readItems.patch
    - Fix load() (LP: #1510225)

 -- Timo Jyrinki <email address hidden> Wed, 21 Sep 2016 11:36:56 +0000

Changed in qtmultimedia-opensource-src (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers