Unity8 is crashing under UITK tests

Bug #1517571 reported by Zoltan Balogh on 2015-11-18
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
kevin gunn
qtmir (Ubuntu)
Critical
Gerry Boland

Bug Description

unity8 - 8.11+15.04.2
UITK - 1.3.1717+201511171416-staging-0+1.3.1688+15.10.20151018.1~ubuntu15.04.1 (but the stock Overlay version does the same)

Install ubuntu-ui-toolkit-autopilot on the device and run

$ phablet-test-run ubuntuuitoolkit.tests.gallery.test_gallery.OpenPagesTestCase.test_open_page

or on the device

$ autopilot3 run ubuntuuitoolkit.tests.gallery.test_gallery.OpenPagesTestCase.test_open_page

The shell will crash and restart with this output from the test tools ->

[1447868985.090179] <ERROR> MirConnectionAPI: Caught exception at client library boundary (in release): /build/mir-AHj2eT/mir-0.17.1+15.04.20151105.1/src/client/rpc/stream_socket_transport.cpp(168): Throw in function virtual void mir::client::rpc::StreamSocketTransport::send_message(const std::vector<unsigned char>&, const std::vector<mir::Fd>&)
Dynamic exception type: N5boost16exception_detail10clone_implINS0_19error_info_injectorIN3mir25socket_disconnected_errorEEEEE
std::exception::what: Failed to send message to server: Broken pipe
32, "Broken pipe"
Failed to create screencast
Failed to connect to server. Error was :Failed to connect to server socket: Connection refused
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
/bin/bash: line 1: 3796 Terminated SUPPRESS_DEPRECATED_NOTE=yes autopilot3 run ubuntuuitoolkit.tests.gallery.test_gallery.OpenPagesTestCase.test_open_page

The `apport-bug unity8` gave this ->

The problem cannot be reported:
This is not an official Ubuntu package. Please remove any third party package and try again.

Related branches

Gerry Boland (gerboland) wrote :

https://tinyurl.com/ocsa8of looks like the culprit

affects: unity8 (Ubuntu) → qtmir (Ubuntu)
Gerry Boland (gerboland) wrote :

Suspect a race between the frameSwapped signal firing, and the MirSurface being deleted. We should ensure MirSurface disconnects from the frameSwapped signal asap on destruction

Gerry Boland (gerboland) on 2015-11-19
Changed in qtmir (Ubuntu):
status: New → In Progress
assignee: nobody → Gerry Boland (gerboland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.6+16.04.20151125-0ubuntu1

---------------
qtmir (0.4.6+16.04.20151125-0ubuntu1) xenial; urgency=medium

  [ Daniel d'Andrada ]
  * Forward Mir mouse wheel events to the shell cursor (LP: #1497091)
  * Implemented support for cursors set by client surfaces
  * Revert revision 415

  [ Gerry Boland ]
  * Manage frameSwapped signal/slot connection with MirSurface more
    strictly to avoid crash. (LP: #1517571)

 -- Michał Sawicz <email address hidden> Wed, 25 Nov 2015 15:38:57 +0000

Changed in qtmir (Ubuntu):
status: In Progress → Fix Released
Zoltan Balogh (bzoltan) wrote :

With the Staging branch of the UITK I have seen at least one AP test crashing unity8: http://pastebin.ubuntu.com/13546492/

Changed in qtmir (Ubuntu):
status: Fix Released → Confirmed
Zoltan Balogh (bzoltan) wrote :
Gerry Boland (gerboland) wrote :

Reopening - but appears to be different issue this time. Unity8 has this failure logged:

[qtmir.mir: SessionListener::stopping - this= SessionListener(0xb1be1ffc) session= 0x157099c
1448884391.745199] <ERROR> mircommon: Caught exception at Mir/EGL driver boundary (in queueBuffer): /build/mir-AHj2eT/mir-0.17.1+15.04.20151105.1/src/client/buffer_stream.cpp(169): Throw in function virtual MirWaitHandle* {anonymous}::ExchangeSemantics::submit(const std::function<void()>&, mir::geometry::Size, MirPixelFormat, int)
Dynamic exception type: N5boost16exception_detail10clone_implINS0_19error_info_injectorISt13runtime_errorEEEE
std::exception::what: disconnected: no new buffers

Changed in canonical-devices-system-image:
milestone: none → ww02-2016
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → kevin gunn (kgunn72)
Zoltan Balogh (bzoltan) on 2016-01-08
Changed in qtmir (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → Invalid
Changed in qtmir (Ubuntu):
status: Invalid → Fix Released
Changed in canonical-devices-system-image:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments