/usr/bin/dialer-app:6:qt_message_fatal:QMessageLogger::fatal:UbuntuClientIntegration::UbuntuClientIntegration:UbuntuMirClientIntegrationPlugin::create:loadIntegration

Bug #1468496 reported by errors.ubuntu.com bug bridge on 2015-06-24
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
kevin gunn
Mir
Incomplete
Undecided
Unassigned
dialer-app (Ubuntu)
High
Gustavo Pichorim Boiko
mir (Ubuntu)
High
Gerry Boland
qtmir (Ubuntu)
High
Gerry Boland

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding dialer-app. This problem was most recently seen with version 0.1+15.10.20150615-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/d4b5f8e8e69986f28fd161d677a4cea7c76e4c7f contains more details.

Rank 4 on errors.u.c with an increased number of reports with 0.1+15.04.20151112.1-0ubuntu1

Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww02-2016
description: updated
Bill Filler (bfiller) wrote :

from stacktrace it appears that connection to MIR server is being rejected for some reason. Looking at the "Examples" in the errors.ubuntu.com page, seems like the condition is when dialer is being invoked with url like "tel:///<phoneNumber>"

Changed in dialer-app (Ubuntu):
importance: Undecided → High
Changed in mir (Ubuntu):
importance: Undecided → High
Changed in qtmir (Ubuntu):
importance: Undecided → High
Changed in dialer-app (Ubuntu):
assignee: nobody → Gustavo Pichorim Boiko (boiko)
Changed in mir (Ubuntu):
assignee: nobody → Kevin Gunn (kgunn)
Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → Kevin Gunn (kgunn)
assignee: Kevin Gunn (kgunn) → kevin gunn (kgunn72)
Changed in dialer-app (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller) wrote :

Get the exact same stacktrace on this bug launching mediaplayer:
https://bugs.launchpad.net/ubuntu/+source/mediaplayer-app/+bug/1474106

pretty clear it's not an app specific bug, but a mir/shell issue.

Changed in dialer-app (Ubuntu):
status: Confirmed → Invalid
Changed in qtmir (Ubuntu):
assignee: nobody → Gerry Boland (gerboland)
Changed in mir (Ubuntu):
assignee: Kevin Gunn (kgunn) → Gerry Boland (gerboland)
Jean-Baptiste Lallement (jibel) wrote :

Moving to backlog and setting severity to medium, only 2 instances of this crash reported on recent builds.

Changed in canonical-devices-system-image:
importance: High → Medium
milestone: ww02-2016 → backlog
Daniel van Vugt (vanvugt) wrote :

The stack trace does not contain any frames from Mir. Only Ubuntu platform code and Q-things.

Changed in mir (Ubuntu):
status: New → Invalid
Changed in mir:
status: New → Invalid
Daniel van Vugt (vanvugt) wrote :

Actually, this looks like the kind of error you might get from any app/client if Unity8 freezes or deadlocks somewhere. And that kind of bug is just as likely to be in the Mir server itself.

Changed in mir:
status: Invalid → Incomplete
Changed in mir (Ubuntu):
status: Invalid → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers