3 seconds delay before sending SIGSTOP (changing apps, suspending phone) seems too much

Bug #1402650 reported by Ricardo Salveti on 2014-12-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
qtmir (Ubuntu)
Critical
Ricardo Mendoza
qtmir (Ubuntu RTM)
Critical
Michał Sawicz

Bug Description

current build number: 51
device name: mako
channel: ubuntu-touch/vivid-proposed
last update: 2014-12-11 15:02:13
version version: 51
version ubuntu: 20141211
version device: 20141209
version custom: 20141211

Currently it takes around 3 seconds for the app to get the SIGSTOP signal when the app moves to background (when changing apps, moving to the home scopes, suspending the phone, etc), which is specially annoying if the app has an active audio stream (you can still hear the sound for a few seconds before it stops completely).

I know we export signals for the apps to react when they are moved out of focus, but I also believe the platform could react a bit sooner than the current 3 seconds timeouts (in order to improve the user experience for webapps, for example).

Related branches

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → ww03-2015
status: New → Confirmed
no longer affects: platform-api (Ubuntu)
affects: qtmir → qtmir (Ubuntu RTM)
Changed in canonical-devices-system-image:
milestone: ww03-2015 → ww05-2015
status: Confirmed → In Progress
Changed in qtmir (Ubuntu RTM):
status: New → In Progress
assignee: nobody → Ricardo Mendoza (ricmm)
Michał Sawicz (saviq) on 2015-01-15
Changed in qtmir (Ubuntu):
status: New → In Progress
assignee: nobody → Ricardo Mendoza (ricmm)
Changed in qtmir (Ubuntu RTM):
assignee: Ricardo Mendoza (ricmm) → nobody
status: In Progress → Triaged
importance: Undecided → Critical
Changed in qtmir (Ubuntu):
importance: Undecided → Critical
Changed in qtmir (Ubuntu RTM):
milestone: none → 14.09-release
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.4+15.04.20150115-0ubuntu1

---------------
qtmir (0.4.4+15.04.20150115-0ubuntu1) vivid; urgency=low

  [ Gerry Boland ]
  * Add Wakelock support - ensures device drops to deep-sleep mode only
    when all AppMan suspend tasks have completed

  [ Ricardo Mendoza ]
  * Reduce suspend timeout to half of the previous value because the
    long value was too apparent on fast paced apps, like web games of
    music players; it broke the user experience according to design.
    (LP: #1402650)
 -- Ubuntu daily release <email address hidden> Thu, 15 Jan 2015 15:19:46 +0000

Changed in qtmir (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2015-01-16
Changed in qtmir (Ubuntu RTM):
status: Triaged → In Progress
assignee: nobody → Michał Sawicz (saviq)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.4+15.04.20150121~rtm-0ubuntu1

---------------
qtmir (0.4.4+15.04.20150121~rtm-0ubuntu1) 14.09; urgency=medium

  [ Gerry Boland ]
  * Add Wakelock support - ensures device drops to deep-sleep mode only
    when all AppMan suspend tasks have completed (LP: #1309915)

  [ Ricardo Mendoza ]
  * Reduce suspend timeout to half of the previous value because the
    long value was too apparent on fast paced apps, like web games of
    music players; it broke the user experience according to design.
    (LP: #1402650)
 -- Ubuntu daily release <email address hidden> Wed, 21 Jan 2015 11:36:24 +0000

Changed in qtmir (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Javier Ibáñez (javier-ibanez) wrote :

Hi, I have already flashed my device to r15 version. The behavior has improved, but it is still working for about 1 second, when you leave an app. If you press power button when sound still working it takes 1 second to stop, the behaviour is perfect when you press home button in launcher.

Noemí (noemi-gallego) wrote :

I have tried in the r19 version and the sound remains after leaving the app.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers