qtiplot version 0.9.8.2-1ubuntu4 failed to build on armel

Bug #745892 reported by Steve Langasek on 2011-03-30
This bug report is a duplicate of:  Bug #736944: armel FTBFS, uses OpenGL and Qt. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtiplot (Ubuntu)
Medium
Unassigned

Bug Description

qtiplot version 0.9.8.2-1ubuntu4 failed to build on armel
Link to failed build: https://launchpad.net/ubuntu/+source/qtiplot/0.9.8.2-1ubuntu4/+buildjob/2325184

Direct link to the build log: https://launchpad.net/ubuntu/+source/qtiplot/0.9.8.2-1ubuntu4/+buildjob/2325184/+files/buildlog_ubuntu-natty-armel.qtiplot_0.9.8.2-1ubuntu4_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 2273 lines into the build log:

src/qwt3d_extglwidget.cpp:118:37: error: 'glRotatef' was not declared in this scope
src/qwt3d_extglwidget.cpp:121:62: error: 'glScalef' was not declared in this scope
src/qwt3d_extglwidget.cpp:122:67: error: 'glTranslatef' was not declared in this scope
src/qwt3d_extglwidget.cpp:124:16: error: 'GL_PROJECTION' was not declared in this scope
src/qwt3d_extglwidget.cpp:124:30: error: 'glMatrixMode' was not declared in this scope
src/qwt3d_extglwidget.cpp:128:75: error: 'glOrtho' was not declared in this scope
src/qwt3d_extglwidget.cpp:129:82: error: 'glFrustum' was not declared in this scope
src/qwt3d_extglwidget.cpp:131:59: error: 'glOrtho' was not declared in this scope
src/qwt3d_extglwidget.cpp:132:55: error: 'glFrustum' was not declared in this scope
make[2]: *** [lib/tmp/qwt3d_extglwidget.o] Error 1
make[2]: Leaving directory `/build/buildd/qtiplot-0.9.8.2/3rdparty/qwtplot3d'
make[1]: *** [sub-3rdparty-qwtplot3d-make_default] Error 2
make[1]: Leaving directory `/build/buildd/qtiplot-0.9.8.2'
make: *** [build-arch-stamp] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110323-1143
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/qtiplot-0.9.8.2

Steve Langasek (vorlon) wrote :

This is caused by the qt4 switch from GL to GLES2 (bug #707794).

Changed in qtiplot (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers