Ubuntu

[Natty] Qtiplot cannot initialize python scripting language: needs rebuilding with Python 2.7

Reported by Dmitry "Divius" Tantsur on 2011-03-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtiplot (Ubuntu)
Undecided
Andres Rodriguez

Bug Description

Binary package hint: qtiplot

Reproduce:
1. Select "Python" scripting language

QtiPlot itself doesn't crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: qtiplot 0.9.8.2-1ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-6.34-generic 2.6.38-rc7
Uname: Linux 2.6.38-6-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Mar 15 18:42:34 2011
ExecutablePath: /usr/bin/qtiplot
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
ProcCmdline: qtiplot
ProcEnviron:
 LANGUAGE=ru_RU:en
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: qtiplot
Title: qtiplot crashed with RuntimeError: Bad magic number in .pyc file
Traceback: RuntimeError: Bad magic number in .pyc file
UpgradeStatus: Upgraded to natty on 2011-03-07 (7 days ago)
UserGroups: adm admin audio cdrom dialout dip fax floppy fuse lpadmin netdev nopasswdlogin plugdev sambashare tape vboxusers video

Related branches

lp:~showard314/ubuntu/natty/qtiplot/Python2.7_fix
Merged into lp:ubuntu/natty/qtiplot at revision 20
Andres Rodriguez: Approve on 2011-03-16
Bhavani Shankar (community): Approve on 2011-03-16
Ubuntu branches: Pending requested 2011-03-16
visibility: private → public

Recreating *.pyc files solves this problem only partly, still some error occurs, see the screenshot.

Oh, no problem is not solved.

Dependencies:
libpython2.6 2.6.6-6ubuntu6
libpython2.7 2.7.1-5
What does it mean?

Download full text (3.3 KiB)

# ldd /usr/bin/qtiplot
 linux-vdso.so.1 => (0x00007fffeb76b000)
 libmuparser.so.0 => /usr/lib/libmuparser.so.0 (0x00007ff2e2265000)
 libgsl.so.0 => /usr/lib/libgsl.so.0 (0x00007ff2e1e50000)
 libgslcblas.so.0 => /usr/lib/libgslcblas.so.0 (0x00007ff2e1c14000)
 liborigin2.so.1 => /usr/lib/liborigin2.so.1 (0x00007ff2e1918000)
 libz.so.1 => /lib/libz.so.1 (0x00007ff2e1700000)
 libpython2.6.so.1.0 => /usr/lib/libpython2.6.so.1.0 (0x00007ff2e123c000)
 libQtAssistantClient.so.4 => /usr/lib/libQtAssistantClient.so.4 (0x00007ff2e1034000)
 libpthread.so.0 => /lib/libpthread.so.0 (0x00007ff2e0e16000)
 libGLU.so.1 => /usr/lib/libGLU.so.1 (0x00007ff2e0ba6000)
 libGL.so.1 => /usr/lib/nvidia-current/libGL.so.1 (0x00007ff2e089b000)
 libQtSvg.so.4 => /usr/lib/libQtSvg.so.4 (0x00007ff2e0643000)
 libQt3Support.so.4 => /usr/lib/libQt3Support.so.4 (0x00007ff2e0164000)
 libQtXml.so.4 => /usr/lib/libQtXml.so.4 (0x00007ff2dff20000)
 libQtOpenGL.so.4 => /usr/lib/libQtOpenGL.so.4 (0x00007ff2dfc32000)
 libQtGui.so.4 => /usr/lib/libQtGui.so.4 (0x00007ff2def94000)
 libQtNetwork.so.4 => /usr/lib/libQtNetwork.so.4 (0x00007ff2dec64000)
 libQtCore.so.4 => /usr/lib/libQtCore.so.4 (0x00007ff2de7d4000)
 libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007ff2de4cd000)
 libm.so.6 => /lib/libm.so.6 (0x00007ff2de248000)
 libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x00007ff2de032000)
 libc.so.6 => /lib/libc.so.6 (0x00007ff2ddc8c000)
 libboost_date_time.so.1.42.0 => /usr/lib/libboost_date_time.so.1.42.0 (0x00007ff2dda78000)
 libssl.so.0.9.8 => /lib/libssl.so.0.9.8 (0x00007ff2dd825000)
 libcrypto.so.0.9.8 => /lib/libcrypto.so.0.9.8 (0x00007ff2dd495000)
 libdl.so.2 => /lib/libdl.so.2 (0x00007ff2dd291000)
 libutil.so.1 => /lib/libutil.so.1 (0x00007ff2dd08e000)
 /lib64/ld-linux-x86-64.so.2 (0x00007ff2e24e9000)
 libnvidia-tls.so.270.29 => /usr/lib/nvidia-current/tls/libnvidia-tls.so.270.29 (0x00007ff2dce8b000)
 libnvidia-glcore.so.270.29 => /usr/lib/nvidia-current/libnvidia-glcore.so.270.29 (0x00007ff2db241000)
 libX11.so.6 => /usr/lib/libX11.so.6 (0x00007ff2daf07000)
 libXext.so.6 => /usr/lib/libXext.so.6 (0x00007ff2dacf4000)
 libQtSql.so.4 => /usr/lib/libQtSql.so.4 (0x00007ff2daab6000)
 libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007ff2da81c000)
 libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00007ff2da612000)
 libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007ff2da3dc000)
 libaudio.so.2 => /usr/lib/libaudio.so.2 (0x00007ff2da1c2000)
 libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x00007ff2d9ed3000)
 libpng12.so.0 => /lib/libpng12.so.0 (0x00007ff2d9cac000)
 libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007ff2d9a5a000)
 libSM.so.6 => /usr/lib/libSM.so.6 (0x00007ff2d9852000)
 libICE.so.6 => /usr/lib/libICE.so.6 (0x00007ff2d9637000)
 libXi.so.6 => /usr/lib/libXi.so.6 (0x00007ff2d9426000)
 libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0x00007ff2d9221000)
 librt.so.1 => /lib/librt.so.1 (0x00007ff2d9018000)
 libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007ff2d8dfc000)
 libexpat.so.1 => /lib/libexpat.so.1 (0x00007ff2d8bd3000)
 libXt.so.6 => /usr/lib/libXt.so.6 (0x00007ff2d896c000)
 libXau.so.6 => /usr/lib/libXau.so.6 (0x00007ff2d8769000)
 libpcre.so.3 => /lib/libpcre.so.3 (0x...

Read more...

summary: - [Natty] Qtiplot cannot initialize python scripting language: qtiplot
- crashed with RuntimeError: Bad magic number in .pyc file
+ [Natty] Qtiplot cannot initialize python scripting language: needs
+ rebuilding with Python 2.7
Scott Howard (showard314) wrote :

needs a patch refreshed too, i'll put up a PPA in a sec

Changed in qtiplot (Ubuntu):
status: New → Triaged

Qtiplot from your ppa seems to be ok.

Scott Howard (showard314) wrote :

See attached branch for the fix. I don't think an FFE is needed - this is a FTBFS bug fix that is a very small and easy diff.

Cheers,
Scott

Changed in qtiplot (Ubuntu):
assignee: nobody → Andres Rodriguez (andreserl)
status: Triaged → In Progress
Andres Rodriguez (andreserl) wrote :

Looks good.

Uploading!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtiplot - 0.9.8.2-1ubuntu4

---------------
qtiplot (0.9.8.2-1ubuntu4) natty; urgency=low

  * Refreshed 01_build_system.diff, s/python2.6/python2.7/ (LP: #735546)
 -- Scott Howard <email address hidden> Tue, 15 Mar 2011 23:34:37 -0400

Changed in qtiplot (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers