qtiplot FTBFS using qt > 4.6 (Maverick has 4.7)

Bug #598826 reported by Scott Howard on 2010-06-26
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QtiPlot
New
Undecided
Unassigned
qtiplot (Debian)
Fix Released
Unknown
qtiplot (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qtiplot

qtiplot fails to build when using Qt > 4.6 (4.7 is in debian experimental and Ubuntu Maverick right now)

src/core/ApplicationWindow.cpp:166:28: error: QAssistantClient: No
such file or directory

qassistantclient has been removed from qt in 4.7.
See:
http://doc.qt.nokia.com/4.6/qassistantclient.html

http://doc.qt.nokia.com/4.7-snapshot/functions.html

"This class is obsolete and only required when using the old Qt
Assistant, now called assistant_adp. If you want to use the new Qt
Assistant as a remote help viewer, simple create a QProcess instance
and specify assistant as its executable."

I posted this at:
https://developer.berlios.de/forum/message.php?msg_id=51418

Related branches

Changed in qtiplot (Debian):
status: Unknown → New
Alex Valavanis (valavanisalex) wrote :

Just add Build-Depends: libqtassistantclient-dev and Depends: qt-assistant-compat to debian/control. That should fix it

Changed in qtiplot (Ubuntu):
status: New → Confirmed
Bhavani Shankar (bhavi) wrote :

If nobody has any objections m willing to work on this bug :)

regards

I've actually done the merge with qtiplot in unstable already
including qt-assistant-compat, but I won't be able to upload it for a
few days. Feel free to work on it and upload, but please do a merge at
the same time.

Bhavani Shankar (bhavi) wrote :

yes I ll take care of the merge

Regards

Bhavani Shankar (bhavi) wrote :

Scott:

Instead of merging it through here is the patch attached

when you upload a new version containing all the ubuntu changes it can be synced again :)

regards

tags: added: patch
Bhavani Shankar (bhavi) wrote :

fabrice,

please upload this patch now as it fixes FTBFS

regards

Bhavani Shankar (bhavi) wrote :
Changed in qtiplot (Ubuntu):
status: Confirmed → Incomplete
Bhavani Shankar (bhavi) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtiplot - 0.9.8-1ubuntu1

---------------
qtiplot (0.9.8-1ubuntu1) maverick; urgency=low

  * Merge from debian unstable(LP: #605027). Remaining changes:
    - Build-Depends on libqtassistantclient-dev
      Recommends qt-assistant-compat to fix a FTBFS since qtassistant
      is removed in qt > 4.6 (LP: #598826)

qtiplot (0.9.8-1) unstable; urgency=low

  * New upstream release
  * Bump standards version to 3.9.0
  * Change python version to 2.6

qtiplot (0.9.7.14-1) unstable; urgency=low

  * New upstream release
  * Build QTeXEngine into program
  * Bump liborigin2 dependency to >=1:06042009+svn1724
  * Bump muparser dependency to 1.32

qtiplot (0.9.7.13-1) UNRELEASED; urgency=low

  * New upstream release
  * Switch to dpkg-source 3.0 (quilt) format
  * Minor fix to patch 01_build_system.diff
  * Add qwtplot3d to build.conf
  * Bump standards version to 3.8.4
  * Fix spelling errors in description
  * Add misc depends in qtiplot-doc
  * Remove patch 02_docbook_stylesheet and
    04_add_includes.diff
  * Rename 03_fix_qti_wordlist.txt_path to
    02_fix_paths.diff
 -- Scott Howard <email address hidden> Tue, 24 Aug 2010 18:09:11 -0400

Changed in qtiplot (Ubuntu):
status: Incomplete → Fix Released
Changed in qtiplot (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.