Qt 5.6.1 causes some powerpc tests to fail

Bug #1606927 reported by Michał Sawicz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
biometryd (Ubuntu)
Undecided
Unassigned
maliit-framework (Ubuntu)
Undecided
Unassigned
qtdeclarative-opensource-src (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu)
Undecided
Alberto Mardegan
unity-api (Ubuntu)
Undecided
Unassigned

Bug Description

An example: ubuntu-system-settings:

https://launchpadlibrarian.net/275303704/buildlog_ubuntu-yakkety-powerpc.ubuntu-system-settings_0.4+16.10.20160727.2-0ubuntu1_BUILDING.txt.gz

Stacktraces:
http://pastebin.ubuntu.com/21137254/
http://pastebin.ubuntu.com/21137968/
http://pastebin.ubuntu.com/21138111/

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: libqt5qml5 5.6.1-4ubuntu1~4
ProcVersionSignature: Ubuntu 3.13.0-79.123-powerpc64-smp 3.13.11-ckt33
Uname: Linux 3.13.0-79-powerpc64-smp ppc
ApportVersion: 2.20.2-0ubuntu1
Architecture: powerpc
Date: Wed Jul 27 13:27:50 2016
ProcEnviron:
 TERM=screen
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
SourcePackage: qtdeclarative-opensource-src
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Michał Sawicz (saviq) wrote :
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :
tags: added: qt5.6
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

This looks very similar to the upstream bug I filed: https://bugreports.qt.io/browse/QTBUG-54719

Revision history for this message
James Henstridge (jamesh) wrote :

I encountered similar failures on a new unity-api build, with test programs segfaulting on powerpc:

https://launchpadlibrarian.net/276663009/buildlog_ubuntu-yakkety-powerpc.unity-api_7.116+16.10.20160804.1-0ubuntu1_BUILDING.txt.gz

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-api - 7.116+16.10.20160730-0ubuntu1

---------------
unity-api (7.116+16.10.20160730-0ubuntu1) yakkety; urgency=medium

  [ Michał Sawicz ]
  * Don't run tests on powerpc (LP: #1606927)

  [ Stephen Kelly ]
  * Silence some gcc warnings.

 -- Lukáš Tinkl <email address hidden> Sat, 30 Jul 2016 21:18:50 +0000

Changed in unity-api (Ubuntu):
status: New → Fix Released
Alberto Mardegan (mardy)
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
assignee: nobody → Alberto Mardegan (mardy)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package biometryd - 0.0.1+16.10.20160628-0ubuntu4

---------------
biometryd (0.0.1+16.10.20160628-0ubuntu4) yakkety; urgency=medium

  * Skip qml test on powerpc, segfaults. LP: #1606927

 -- Dimitri John Ledkov <email address hidden> Thu, 18 Aug 2016 15:44:55 +0100

Changed in biometryd (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.4+16.10.20160810-0ubuntu1

---------------
ubuntu-system-settings (0.4+16.10.20160810-0ubuntu1) yakkety; urgency=medium

  * Skip tests on powerpc due to Qt 5.6 bug (LP: #1606927)
  * Depend on upstart to prevent s390x problems until upstart has been
    fixed.
  * bluetooth: Add Apperance characteristic to type conversion

 -- Konrad Zapałowicz <email address hidden> Wed, 10 Aug 2016 13:17:54 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.7+16.10.20160830.2-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.7+16.10.20160830.2-0ubuntu1) yakkety; urgency=medium

  [ Alberto Mardegan ]
  * debian/rules:
    - Don't run tests on powerpc (LP: #1606927)

  [ Gary.Wzl ]
  * add a new property "userAgent" for OAuth item. (LP: #1587282)

  [ Timo Jyrinki ]
  * Add qttools5-dev-tools build dependency (LP: #1608814)

 -- Alberto Mardegan <email address hidden> Tue, 30 Aug 2016 08:37:06 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.6.1-7ubuntu1~2

---------------
qtdeclarative-opensource-src (5.6.1-7ubuntu1~2) yakkety; urgency=medium

  * debian/patches/Fix-visibility-of-properties-in-value-types.patch:
    - Fix compare() in QML (LP: #1610349)
  * Update symbols.
  * debian/patches/Fix-V4-on-big-endian.patch:
    - Fixes value/tag reads on 32-bit big-endian and offsets on 64-bit.
      (LP: #1606927)

 -- Timo Jyrinki <email address hidden> Mon, 22 Aug 2016 13:31:32 +0000

Changed in qtdeclarative-opensource-src (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Take that with a grain of salt (it's just one related patch), but please test if the powerpc QML tests would be passing for your component now.

Revision history for this message
Dimitri John Ledkov (xnox) wrote :

powerpc has been dropped. thus no longer relevant right?

Changed in maliit-framework (Ubuntu):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers