Protect the RegExp against early garbage collection

Bug #1443981 reported by Albert Astals Cid
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtdeclarative-opensource-src (Ubuntu)
Undecided
Timo Jyrinki
Vivid
Undecided
Timo Jyrinki

Bug Description

RegExp is not properly protected against garbage collection and can cause a crash depending on when the garbage collection kicks in.

To reproduce the problem save http://paste.ubuntu.com/10821832/ to file.qml and run
QV4_MM_AGGRESSIVE_GC=1 qmlscene file.qml

The fix is accepted upstream at https://codereview.qt-project.org/#/c/110411/

Changed in qtdeclarative-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Michał Sawicz (saviq)
Changed in qtdeclarative-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtdeclarative-opensource-src (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Albert Astals Cid (aacid) wrote :

I can confirm that i can't reproduce the problem anymore with the packages in landing 004

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.4.1-1ubuntu5

---------------
qtdeclarative-opensource-src (5.4.1-1ubuntu5) vivid; urgency=medium

  * debian/patches/Protect-the-RegExp-against-early-garbage-collection.patch
    - Fix a potential random crasher with a fix from upstream (LP: #1443981)
 -- Timo Jyrinki <email address hidden> Wed, 15 Apr 2015 07:19:34 +0000

Changed in qtdeclarative-opensource-src (Ubuntu Vivid):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers