QML's ListView currentItem changes on resize

Bug #1433442 reported by handsome_feng on 2015-03-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
kevin gunn
qtdeclarative-opensource-src (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

When i drag the edge of the window of the unity8-dash, and adjust the width of it quickly, the scope will changes to another one.

Description: Ubuntu Vivid Vervet (development branch)
Release: 15.04
unity8: 8.02+15.04.20150302-0ubuntu1

Related branches

handsome_feng (feng-kylin) wrote :

and i fond if i delete 121 or 123 in DashContent.qml, the scope will not auto-switch in that situation,of course , it will bring other negative effects.

121 snapMode: ListView.SnapToItem
122 highlightMoveDuration: 250
123 highlightRangeMode: ListView.StrictlyEnforceRange

handsome_feng (feng-kylin) wrote :

i made a mistake , sorry, the 121 of the DashContent.qml is :
      snapMode: ListView.SnapOneItem

Michał Sawicz (saviq) wrote :

Yeah, this is an upstream Qt issue unfortunately.

summary: - scope auto-swithes when i drag to change the width of the window of
- the unity8-dash quickly
+ QML's ListView currentItem changes on resize
affects: unity8 (Ubuntu) → qtdeclarative-opensource-src (Ubuntu)
Changed in qtdeclarative-opensource-src (Ubuntu):
status: New → Confirmed
Alberto Mardegan (mardy) wrote :

Since this issue was affecting a project of mine too, I took some time to fix this upstream:
https://codereview.qt-project.org/#/c/121242/

The fix has been accepted into Qt 5.6. I wonder if we can have it backported to Qt 5.5 in Ubuntu?

Timo Jyrinki (timo-jyrinki) wrote :

Ok, as per discussions on IRC targeting both wily (on top of Qt 5.4.2) and vivid overlay (on top of Qt 5.4.1).

Changed in qtdeclarative-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: Confirmed → Triaged
Timo Jyrinki (timo-jyrinki) wrote :

Could I get you to test silo 029 (https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-029/+packages) and report back if it fixes all the issues you had without you noticing regressions?

Use the citrain tool (you need either the wily version or vivid-overlay version of phablet-tools) like: citrain device-upgrade 29 0000 ubuntu

Double check dpkg -s libqt5quick5 gives you 5.4.1-1ubuntu9 on the device.

Changed in qtdeclarative-opensource-src (Ubuntu):
status: Triaged → In Progress
Alberto Mardegan (mardy) wrote :

I confirm that libqt5quick5 from silo 29 fixes the issue, thanks!

Timo Jyrinki (timo-jyrinki) wrote :

Unfortunately the silo failed QA testing:

< davmor2> Tapping on the second third or fourth video always opens the first

(video scope, youtube scope)

If the fix in the silo is completely valid, it's possible the scopes would need fixing to remove any workarounds they've previously used.

Changed in qtdeclarative-opensource-src (Ubuntu):
assignee: Timo Jyrinki (timo-jyrinki) → nobody
status: In Progress → Triaged
Timo Jyrinki (timo-jyrinki) wrote :

< davmor2> so the issue is this, I click on top right video bottom left or bottom right and it always opens the top left

Alberto Mardegan (mardy) wrote :

That's interesting, because the behaviour described by davmor2 is exactly what I'd expect would happen in an application when this bug is not fixed. It may indeed be that there is a workaround which makes things work actually worse when the bug is fixed.

However, I cannot reproduce it with the ubuntu-touch/rc-proposed/ubuntu channel on N4: the correct video is always being opened. Dave, can you please give me the details of the image you are using?

Timo Jyrinki (timo-jyrinki) wrote :

Unity 8 part fixed in vivid-overlay:

---
unity8 (8.11+15.04.20150817-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * Drop gcc 4.9 requirement in debian/rules
  * Make the test more stable
  * Optimize scope.preview() calls (LP: #1478022)

  [ Alberto Mardegan ]
  * Set currentIndex after the model change is completed (LP: #1433442)

 -- CI Train Bot <email address hidden> Mon, 17 Aug 2015 11:57:31 +0000
---

Changed in unity8 (Ubuntu):
status: New → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

qtdeclarative now also fixed in vivid-overlay (for OTA-7):

qtdeclarative-opensource-src (5.4.1-1ubuntu9) vivid; urgency=medium

  * debian/patches/Don-t-change-the-currentItem-after-a-viewport-resize.patch:
    - Fix ListView's currentIndex changing when view is resized (LP: #1433442)

 -- Timo Jyrinki <email address hidden> Tue, 11 Aug 2015 07:31:29 +0000

Changed in canonical-devices-system-image:
status: New → Fix Committed
Changed in canonical-devices-system-image:
milestone: none → ww40-2015
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.11+15.10.20150826-0ubuntu1

---------------
unity8 (8.11+15.10.20150826-0ubuntu1) wily; urgency=medium

  [ Michael Zanetti ]
  * release for wily

  [ CI Train Bot ]
  * New rebuild forced.

unity8 (8.11+15.04.20150821-0ubuntu1) vivid; urgency=medium

  [ Michael Terry ]
  * Skip the tutorial entirely when in desktop mode. This fixes the
    emulator not being able to pass the tutorial.
  * Skip the tutorial entirely when in desktop mode. This fixes the
    emulator not being able to pass the tutorial.

unity8 (8.11+15.04.20150817-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * Drop gcc 4.9 requirement in debian/rules
  * Make the test more stable
  * Optimize scope.preview() calls (LP: #1478022)

  [ Alberto Mardegan ]
  * Set currentIndex after the model change is completed (LP: #1433442)

unity8 (8.11+15.04.20150814-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * Make the test pass again after rework of appmanager
  * fix testPhoneStage

  [ CI Train Bot ]
  * New rebuild forced.

  [ Daniel d'Andrada ]
  * Fix and clean up InputInfo plugin

  [ Rodney Dawes ]
  * Do not call verify in the payments button code. (LP: #1468038)

unity8 (8.11+15.04.20150812-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * Add a test that checks that items in an expandable are the correct
    size after expanding the expandable
  * Fix the expandable test
  * Replace some waitForRendering with wait(0)
  * Workaround for bug 1473471 (LP: #1473471)

  [ Gary.Wzl ]
  * Fix layout issue when adding audio track widget in expandable widget

  [ handsome_feng ]
  * Added indication for running apps. (LP: #1471577)
  * Adjust the color to highlighting indicator. (LP: #1457098)
  * Convert the MouseArea to MultiPointTouchArea to track multiple touch
    points. (LP: #1445472)

  [ handsome_feng<email address hidden> ]
  * Convert the MouseArea to MultiPointTouchArea to track multiple touch
    points. (LP: #1445472)

 -- CI Train Bot <email address hidden> Wed, 26 Aug 2015 09:01:03 +0000

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
assignee: nobody → kevin gunn (kgunn72)
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.4.2-1ubuntu5

---------------
qtdeclarative-opensource-src (5.4.2-1ubuntu5) wily; urgency=medium

  * debian/patches/Don-t-change-the-currentItem-after-a-viewport-resize.patch:
    - Fix ListView's currentIndex changing when view is resized (LP: #1433442)

 -- Timo Jyrinki <email address hidden> Thu, 13 Aug 2015 12:30:49 +0300

Changed in qtdeclarative-opensource-src (Ubuntu):
status: Triaged → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers