Segfault with QSG_VISUALIZE=overdraw

Bug #1430337 reported by Albert Astals Cid
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qtdeclarative-opensource-src (Ubuntu)
Undecided
Timo Jyrinki

Bug Description

QSG_VISUALIZE=overdraw causes segfaults on the phone

Upstream bug at https://bugreports.qt.io/browse/QTBUG-43129

Patch that has already landed in Qt 5.4.2 at http://code.qt.io/cgit/qt/qtdeclarative.git/commit/?id=d43a963e49956ba772644e9f3448dc3672147f77

Since it's a think we use regularly may be a good idea to have it backported to the vivid packages.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtdeclarative-opensource-src (Ubuntu):
status: New → Confirmed
Changed in qtdeclarative-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.4.1-1ubuntu3

---------------
qtdeclarative-opensource-src (5.4.1-1ubuntu3) vivid; urgency=medium

  * New upstream release.
  * Drop patches, fixed upstream:
    - Support-RFC2822Date-date-format-similar-to-V8.patch
  * Merge with Debian 5.4.1-1, bringing better private symbols marking
    (LP: #1426314)
  * debian/patches/Fix-crash-in-overdraw-and-change-visualizers.patch:
    - Fix a potential crasher (LP: #1430337)
  * debian/patches/High-dpi-SVG-and-QQuickImageProvider-Images.patch:
    - Fix scaling of source size if devicepixelratio is set
 -- Timo Jyrinki <email address hidden> Wed, 11 Mar 2015 10:56:54 +0000

Changed in qtdeclarative-opensource-src (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers