[FFe] QML compilation cache patch needs adaptation for Qt 5.4

Bug #1418060 reported by Timo Jyrinki
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtdeclarative-opensource-src (Ubuntu)
Critical
Ricardo Mendoza

Bug Description

-- FFe --

Since we're past the feature freeze, bringing this patch back needs an exception, even though it's a regression fix at the same time. Summary:
- The patch allows opt-in, environment variable controlled use of storing some cache data when loading QML files. Without the environment variable there are no changes.
- Not having the patch is a performance regression on application startup time on the phones from Qt 5.3.2.
- The patch already shipped in Qt 5.3.2, but needed adjustments for 5.4 that were not done on time when Qt 5.4 was otherwise ready to land before feature freeze, so the patch was commented out.
- The patch is also shipping on the sold Bq phones.
- The proposed changes are in the MP below, that is uncommenting the patch in debian/patches/series and the rebasing (the full patch is 25 files changed, 703 insertions(+), 14 deletions(-)).

As usual, we have a wide testing being done also on this rebased-to-Qt-5.4.0 patch.

Upstreaming is being considered now that the patch seems to work for our purposes. It might need more than code discussions since upstream developer is also selling a proprietary product that offers somewhat similar benefits.

-- Original bug report --

The environment variable controlled new functionality provided by QML compilation cache patch (landed for Qt 5.3.2) needs adaptation for Qt 5.4, as it does not currently apply.

Attachment shows a summary of the patch applying problems.

More information about Qt 5.4 at https://wiki.ubuntu.com/Touch/QtTesting

Related branches

Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :
summary: - QML compliation cache patch needs adaptation for Qt 5.4
+ QML compilation cache patch needs adaptation for Qt 5.4
Changed in qtdeclarative-opensource-src (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote : Re: QML compilation cache patch needs adaptation for Qt 5.4
description: updated
summary: - QML compilation cache patch needs adaptation for Qt 5.4
+ [FFe] QML compilation cache patch needs adaptation for Qt 5.4
Changed in qtdeclarative-opensource-src (Ubuntu):
status: Triaged → In Progress
Revision history for this message
Iain Lane (laney) wrote :

It's probably okay since we had it before, but could you first add some patch headers to explain why it's there and the status on getting it upstream?

Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Patch headers added. Upstream discussion is currently being planned, there should be enough time to discuss and get it to Qt 5.6 which will have feature freeze somewhere around July.

Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Testing nearing finalization, package moved to https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/landing-020/+packages for final build.

Revision history for this message
Iain Lane (laney) wrote :

OK. Please make sure you propose upstream in good enough time so nobody has to rebase again next time on our side.

Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Added bug #1426288 about the upstreaming before the next Qt feature freeze.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.4.0-4ubuntu2

---------------
qtdeclarative-opensource-src (5.4.0-4ubuntu2) vivid; urgency=medium

  * debian/patches/QML-Compilation-unit-caching-and-JIT-changes.patch:
    - [regression] Re-enable the opt-in QML cache patch (LP: #1418060)
  * Update symbols from build logs.
  * Don't run unit tests on 32-bit powerpc, those fail more often
    than not. Other archs not affected.
 -- Timo Jyrinki <email address hidden> Tue, 24 Feb 2015 14:01:39 +0000

Changed in qtdeclarative-opensource-src (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers