Better fix for crash due to wrong objects being garbage collected

Bug #1349297 reported by Albert Astals Cid on 2014-07-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtdeclarative-opensource-src (Ubuntu)
Undecided
Timo Jyrinki

Bug Description

We need to stop using debian/patches/parenttosubcreator_qqmlobjectcreator.patch that has been rejected as a valid upstream patch and use https://codereview.qt-project.org/#/c/88064/ which also fixes the issue and is upstream (will be in the 5.3.2 release)

Related branches

Albert Astals Cid (aacid) wrote :

Timo can you help me with this?

Timo Jyrinki (timo-jyrinki) wrote :

Back from vac now.

Changed in qtdeclarative-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Timo Jyrinki (timo-jyrinki) wrote :

Simply removing parenttosubcreator_qqmlobjectcreator.patch and adding the new upstream patch instead does not seem to work:
https://launchpadlibrarian.net/181479134/buildlog_ubuntu-utopic-amd64.qtdeclarative-opensource-src_5.3.0-3ubuntu8~utopic1~test1_FAILEDTOBUILD.txt.gz

"error: 'topLevelCreator' was not declared in this scope"

Would 5.3.0 need some additional patching?

Changed in qtdeclarative-opensource-src (Ubuntu):
status: New → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

The same error happens also with 5.3.1 + the patch.

Adding https://codereview.qt-project.org/#/c/88011/ to the mix seems to resolve the issue. Could it be confirmed that the set of those two patches would be wanted to go in? Is there regression potential when those patches alone are added on top of 5.3.0?

Albert Astals Cid (aacid) wrote :

Ah https://codereview.qt-project.org/#/c/88011/ is a wanted one too, i may have forgotten to open a bug for it.

On the regression potential, well i've looked at the rest of changes in qdeclarative and there are many to be able to confirm if these two standalone would or would not cause a regression. There is of course regression potential as with any patch.

Having asked upstream they say that debian/patches/parenttosubcreator_qqmlobjectcreator is not "totally horrible" and would mostly work even if make things a bit slower and having the ocassional memory leak.

If we want to live with it until we upgrade to 5.3.2, we just have to remember to remove it by then, i guess i'm ok.

Michał Sawicz (saviq) wrote :

Since we're not moving to 5.3.1+ in time for release, I'd be wary leaving a known-to-not-be-great patch around...

Albert Astals Cid (aacid) wrote :

Then i guess the best is getting https://codereview.qt-project.org/#/c/88011/ + https://codereview.qt-project.org/#/c/88064/ somewhere in a PPA and give it a spin?

Timo Jyrinki (timo-jyrinki) wrote :

Uploaded 1h ago, armhf binaries should be published soon (<30min): https://launchpad.net/~canonical-qt5-edgers/+archive/ubuntu/qt5-beta1 / ppa:canonical-qt5-edgers/qt5-beta1

It includes also Saviq's other changes that are going in as the 'ubuntu8' via a landing silo, so these two new patches would be ubuntu9 then. Note that you can't have that Saviq's landing PPA enabled at the same time as it has higher version number.

I'll myself give it a better spin later when the ubuntu8 is first published and I can get a proper landing silo for ubuntu9 (+ fix changelog).

Changed in qtdeclarative-opensource-src (Ubuntu):
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.3.0-3ubuntu8

---------------
qtdeclarative-opensource-src (5.3.0-3ubuntu8) utopic; urgency=medium

  [ Michał Sawicz ]
  * debian/patches/8454a21b-Flickable-Cancel-interaction-on-interactive-changes.patch
    - Fix flickable interaction (LP: #1349705)
  * debian/control
  * debian/rules
    - Force gcc-4.8 to avoid symbols changes

  [ Timo Jyrinki ]
  * debian/patches/parenttosubcreator_qqmlobjectcreator.patch:
    - Drop, rejected by upstream
  * debian/patches/Fix-crash-when-deleting-component-in-Component.onCom.patch
    debian/patches/Fix-interaction-of-garbage-collector-with-JS-objects.patch:
    - Replace the old patch with accepted upstream approach (LP: #1349297)
 -- Timo Jyrinki <email address hidden> Mon, 04 Aug 2014 10:58:28 +0000

Changed in qtdeclarative-opensource-src (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers