Regression: Performance hit when editing sorted lists

Bug #1334177 reported by David Planella on 2014-06-25
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Notes app
Critical
Unassigned
qtdeclarative-opensource-src (Ubuntu)
Undecided
Unassigned

Bug Description

This is a follow-up from bug 1303746.

After the migration from Qt 5.2.1 to 5.3.0 in utopic, it seems that this patch was lost, and it did not land upstream until 5.3.1, which we do not ship yet. Therefore, we've regressed and we're back to the same bug.

The most visible effect is in the Reminders app, which uses a list sorted by date to show the existing notes, and that list is continually being reordered, rendering the application unusable.

[Impact]
Performance regression from Qt 5.2.1 to 5.3.0 in sorted lists, due to lacking a proper way to support layoutChange.

[Test Case]
We first noticed this after the migration to 5.3.0 in utopic and using the Reminders app: in summary, when editing a note the application becomes unresponsive on the phone and the CPU goes to 100% on the desktop (there it's not too noticeable).

From the upstream bug, my understanding is that the fix landed after Qt 5.2.1 was released and it made it to 5.3.1, but not 5.3.0, which is what we currently ship in Ubuntu.

https://bugreports.qt-project.org/browse/QTBUG-37983

Related branches

David Planella (dpm) on 2014-06-25
Changed in reminders-app:
status: New → Triaged
importance: Undecided → Critical
David Planella (dpm) on 2014-06-25
summary: - Regressioin: Performance hit when editing sorted lists
+ Regression: Performance hit when editing sorted lists
Niklas Wenzel (nikwen) on 2014-06-26
Changed in qtdeclarative-opensource-src (Ubuntu):
status: New → Confirmed
David Planella (dpm) wrote :

I can confirm that this upload fixes the bug. Tested on image 100 and ran the Unity test plan - the manual part, but not the autopilot tests.

David Planella (dpm) wrote :

Also tested it on image 105 now, and it still fixes the bug there.

Niklas Wenzel (nikwen) wrote :

Seems to be fixed in r106. Thanks a lot. :)

http://people.canonical.com/~ogra/touch-image-stats/106.changes

David Planella (dpm) wrote :

Thanks a lot for confirming! Not sure why the upload didn't mark the bug as Fix Released, so I'll do it manually.

Changed in reminders-app:
status: Triaged → Fix Released
Changed in qtdeclarative-opensource-src (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers