Cannot debug console application in qt-creator

Bug #566387 reported by Muktabh on 2010-04-19
58
This bug affects 14 people
Affects Status Importance Assigned to Milestone
qtcreator (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qtcreator

Description: Ubuntu lucid (development branch)
Release: 10.04

qtcreator:
Installed: 1.3.1-1ubuntu1
Candidate: 1.3.1-1ubuntu1

1) Create a empty qt4 project.
2) Add a c++ file which has input/output operations using standard cin and cout
3) Under project properties->run settings, check "run in terminal"
4) Compile
5) When run, a terminal is opened which doesnot take input nor show any output.

To fix, under tools-options-environment-general, change terminal value from "x-terminal-emulator -e" to "/usr/bin/xterm -e"

The program now runs fine from an xterm window.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: qtcreator 1.3.1-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Sun Apr 18 23:00:26 2010
ExecutablePath: /usr/bin/qtcreator.bin
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: qtcreator

Muktabh (markian) wrote :
eraserix (eraserix) wrote :

Just won't work with gnome-terminal, I tried -e and -x as parameters. No luck! :(

xterm works fine though.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtcreator (Ubuntu):
status: New → Confirmed
Clearstar (szummer-l) wrote :

The issue is still present in Ubuntu 12.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers