Qt Creator high CPU usage

Bug #459752 reported by Kayra Akman
236
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Arch Linux
Fix Released
Undecided
Unassigned
qtcreator (Debian)
Fix Released
Unknown
qtcreator (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Kev

Bug Description

Binary package hint: qtcreator

Qt Creator uses almost all of the available CPU time even when idle. "qtcreator.bin" process doesn't quit after closing the application. See the screenshots of System Monitor.

ProblemType: Bug
Architecture: i386
Date: Sat Oct 24 15:56:42 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
Package: qtcreator 1.2.1-3ubuntu1
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: qtcreator
Uname: Linux 2.6.31-14-generic i686

Revision history for this message
Kayra Akman (ckakman) wrote :
Revision history for this message
Kayra Akman (ckakman) wrote :
Revision history for this message
Kev (ukev) wrote :

I can confirm this bug with karmic final release on i386.

Changed in qtcreator (Ubuntu):
status: New → Confirmed
Revision history for this message
lunchboxtheman (bandpunk109) wrote :

Confirmed in Karmic Koala.

Revision history for this message
lunchboxtheman (bandpunk109) wrote :

Just figured out that this is not a bug. The first time you start Qt Creator it parses all of the help documentation. It might take a minute or two, but it should stop eventually.

Try letting it run for a few minutes to see if it stops.

Revision history for this message
Uwe Lippmann (uwe-lippmann) wrote :

I can confirm: After letting it run a few minutes the CPU usage drops back to normal level. (Running under GNOME on Ubuntu 9.10 Karmic Koala, 32 bit). I had the same effect with the Qt Asisstant most probably for the same reason as lunchboxtheman pointed out.

Revision history for this message
Pauli (paniemin) wrote :

This is interface bug that is fixed in creator 1.3

Revision history for this message
ATIpro (atipro) wrote :

I have the same bug with Qt Creator 1.3.1 on Arch Linux with latest updates

Changed in qtcreator (Arch Linux):
status: New → Confirmed
Revision history for this message
koso (koso) wrote :

I have this problem with lucid with qtcreator_1.3.1-1ubuntu1.

Changed in qtcreator (Debian):
status: Unknown → Confirmed
Revision history for this message
Mike Durham (mdurhamesq) wrote :

Sane problem here. Takes 3-4 mins to start on Lucid. What a pain!

Revision history for this message
eraserix (eraserix) wrote :

This bug occurs on lucid beta2 as well (creator version 1.3.1). Takes forever to start (and to quit!). Also on the second and third invocation...

Revision history for this message
Muktabh (markian) wrote :

Happened to me too. but after leaving QT open for 5/10 minutes, or quitting and reopening a few times, it becomes normal. next restarts are quick and shutdown doesnot take long. I think QT tries to do something on initial run which takes a long time and can span multiple restarts.

Revision history for this message
supremo (manuelgs88) wrote :

Same problem on lucid.
I try to start qtcreator and CPU usage becomes at 100%, and after 4-5 minutes qtcreator starts, but CPU still at 100%.
The same when quit program.

Revision history for this message
Mike Durham (mdurhamesq) wrote :

How can a serious and annoying bug like this, reported on 2009-10-24, have an 'Importance' of 'undecided'? Why is it undecided? How can it ever be 'decided'?

Revision history for this message
supremo (manuelgs88) wrote :

The only parcial solution that I Have found is:
sudo apt-get remove qt4-doc

Doc isn't but program run normally...

Revision history for this message
Rodrigo Linfati (rlinfati) wrote :

repro on lucid rc

Revision history for this message
Rodrigo Linfati (rlinfati) wrote :

qtcreator is indexing the help...

Revision history for this message
Andrioid (andri80) wrote :

Running 64-bit Lucid on i5-750 - Qt creator becomes 'defunct' and stalls for a while. "Indexing the help" doesn't really resolve this, as this doesn't just happen the first time I run Qtcreator... also the second time (don't know about the third, yet).

Revision history for this message
tim (timothyguo) wrote :

I have the same problem on Lucid Lynx. I start qtcreator from the Application Menu, but there is just no response. There is a high CPU usage and on the process tab of System Monitor is qtcreator.bin with 100% CPU.

Revision history for this message
Lele Long (schemacs) wrote :

I move /usr/share/qt/doc to /usr/share/qt/doc-backup to avoid this annoying bug in sqlite(see here http://bugreports.qt.nokia.com/browse/QTCREATORBUG-315?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel ).

tags: added: amd64
Revision history for this message
Мартин Спасовски (moondowner) wrote :

Same problem here.

@schemacs
Does QtCreator use the documentation for example Autocomplete and hints abut the methods/api/etc? If so, when It's moved, it wont display them right? Is there an option in QtCreator to set the path to, let's say /usr/share/qt/doc-backup?

Revision history for this message
YaGeek (yageek) wrote :

Yes you can move the path to the documentation but qtcreator will crash again.

Revision history for this message
StefanF (stefan) wrote :

I have also the same problem. Both qt-creator and qt-designer cause very high CPU load and take multiple minutes to start.
How can I develop good software, when the development tools are already so obviously broken?

Revision history for this message
YaGeek (yageek) wrote : Re: [Bug 459752] Re: Qt Creator high CPU usage

You can install the tool development provided on qt.nokia.com ! Also, you can move the documentation from the original directory and browsing it from firefox ! It sucks but it works !

2010/5/6 StefanF &lt;<email address hidden>&gt;
I have also the same problem. Both qt-creator and qt-designer cause very high CPU load and take multiple minutes to start.
How can I develop good software, when the development tools are already so obviously broken?

--
Qt Creator high CPU usage
https://bugs.launchpad.net/bugs/459752
You received this bug notification because you are a direct subscriber
of the bug.

Status in “qtcreator” package in Ubuntu: Confirmed
Status in “qtcreator” package in Arch Linux: Confirmed
Status in “qtcreator” package in Debian: Confirmed

Bug description:
Binary package hint: qtcreator

Qt Creator uses almost all of the available CPU time even when idle. "qtcreator.bin" process doesn't quit after closing the application. See the screenshots of System Monitor.

ProblemType: Bug
Architecture: i386
Date: Sat Oct 24 15:56:42 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
Package: qtcreator 1.2.1-3ubuntu1
ProcEnviron:
&nbsp;LANGUAGE=en_GB.UTF-8
&nbsp;LANG=en_GB.UTF-8
&nbsp;SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: qtcreator
Uname: Linux 2.6.31-14-generic i686

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/qtcreator/+bug/459752/+subscribe

Revision history for this message
prower2000 (prower2000) wrote :

Experiencing the same issue in Ubuntu 10.04 (64-bit edition) in both KDE and GNOME, qtcreator takes about a minute to start and when it finally does, it's constantly using 100% CPU.

Is anyone looking into this?

Revision history for this message
Jaroslav Šmíd (jardasmid-gmail) wrote :

Still there... But ubuntu folks tend not to solve the bugs, because this is obviously not as important as changing color of desktop wallpaper ...

Revision history for this message
Martin Stiborský (martin-stiborsky-gmail) wrote :

After few minutes is all ok.

Revision history for this message
los-nikos (id4me) wrote :
Download full text (6.6 KiB)

All OK? After some minutes have

--- SIGPIPE (Broken pipe) @ 0 (0) ---
write(2, "ICE default IO error handler doi"..., 69ICE default IO error handler doing an exit(), pid = 3182, errno = 32
) = 69
futex(0x3484cac, FUTEX_WAIT_PRIVATE, 1, NULL) = 0
futex(0x3484c80, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x3484c3c, FUTEX_CMP_REQUEUE_PRIVATE, 1, 2147483647, 0x3484c10, 2) = 1
futex(0x342d66c, FUTEX_WAIT_PRIVATE, 1, NULL) = 0
futex(0x342d640, FUTEX_WAKE_PRIVATE, 1) = 0
futex(0x32ca28c, FUTEX_CMP_REQUEUE_PRIVATE, 1, 2147483647, 0x32ca260, 4) = 1
futex(0x32ca260, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x32ca22c, FUTEX_WAKE_OP_PRIVATE, 1, 1, 0x32ca228, {FUTEX_OP_SET, 0, FUTEX_OP_CMP_GT, 1}) = 1
futex(0x32ca200, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x32ca38c, FUTEX_WAIT_PRIVATE, 1, NULL) = 0
futex(0x32ca360, FUTEX_WAKE_PRIVATE, 1) = 0
writev(30, [{"l\1\1\1\241\0\0\0\36\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\234\0\0\0type='signal',sender='org.fr"..., 161}], 2) = 305
writev(30, [{"l\1\1\1\243\0\0\0\37\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\236\0\0\0type='signal',sender='org.fr"..., 163}], 2) = 307
writev(30, [{"l\1\1\1\247\0\0\0 \0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\242\0\0\0type='signal',sender='org.fr"..., 167}], 2) = 311
writev(30, [{"l\1\1\1\221\0\0\0!\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\214\0\0\0type='signal',sender='org.fr"..., 145}], 2) = 289
writev(30, [{"l\1\1\1\301\0\0\0\"\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\274\0\0\0type='signal',sender='org.fr"..., 193}], 2) = 337
writev(30, [{"l\1\1\1\237\0\0\0#\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\232\0\0\0type='signal',sender='org.fr"..., 159}], 2) = 303
writev(30, [{"l\1\1\1\277\0\0\0$\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\272\0\0\0type='signal',sender='org.fr"..., 191}], 2) = 335
writev(30, [{"l\1\1\1\235\0\0\0%\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\230\0\0\0type='signal',sender='org.fr"..., 157}], 2) = 301
close(44) = 0
close(28) = 0
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = 0
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAKE_PRIVATE, 1) = 1
futex(0x3231358, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)
futex(0x3231358, FUTEX_WAKE_PRIVATE, 1) = 1
close(40) = 0
futex(...

Read more...

Revision history for this message
tx (372046933-qq) wrote :

#6 is right, just leave it alone and have a cup of coffee, some minutes later the zombie process came to normal

Revision history for this message
Rohan Garg (rohangarg) wrote :

Has anyone tried this out on maverick yet? It has a new version of Qt creator that is supposed to solve this

Revision history for this message
Mathieu Brethes (mathieu-brethes) wrote :

An impressively sluggish piece of software, that. Eclipse looks fast in comparison. Just great...

Revision history for this message
Mathieu Brethes (mathieu-brethes) wrote :

It would be nice to add a "progress bar" on this first load so that people understand that the program is actually doing something. More a usability issue than a "real bug" per se.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

I have tested with qtcreator2.4.1 on Ubuntu12.04 64bit and qtcreator 2.5.0 on Ubuntu12.10 pre alpha 64bit.

qtcreator takes some seconds to come up, but not minutes (on a dual core system -busy state with background processes).

From my side of view it has become fixed and I set it to this.

When there is anybody on the still supported Ubuntu versions(11.04,11.10 and 12.04) please reopen ( or may be thing over a system upgrade).

Thank you.

Changed in qtcreator (Ubuntu):
status: Confirmed → Fix Released
affects: qtcreator (Arch Linux) → archlinux
Changed in archlinux:
status: Confirmed → Fix Released
Revision history for this message
StefanF (stefan) wrote :

Thew problem does not occur anymore with current versions. Both, the affected linux version and the affected QT version are out of date now.
Should be closed.

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

So than,

on Ubuntu this is already set to fixed, also on arch linux(which is a rolling release linux and with this more to the latest packages). On Debian this issue might be still relevant for the stable release.

So, I let the report in the state as it is. It will be automatically close if the Debian reports is closed.

The Debian maintainer is informed by E-mail from me of the resolved status of the issue in Ubuntu.

Changed in qtcreator (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.