qtcreator freezes and crashes all the time

Bug #1577213 reported by yesint on 2016-05-01
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
qtcreator (Ubuntu)
Medium
Unassigned

Bug Description

qtcreator 3.5.1 shipped by default in Xubuntu 16.04 crashes and freezes all the time. It either freezes regularly for 10-30 seconds or just crashes for no reason and with no trace at all if started from console. It is not usable due to this. This a major issue is one is a developer using qtcreator!

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: qtcreator 3.5.1+dfsg-2ubuntu2
ProcVersionSignature: Ubuntu 4.4.0-21.37-generic 4.4.6
Uname: Linux 4.4.0-21-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun May 1 20:15:16 2016
SourcePackage: qtcreator
UpgradeStatus: No upgrade log present (probably fresh install)

yesint (yesint4) wrote :
Fabian (fmaier) wrote :

I have the same problem. When it happens, the CPU usage of one core goes to 100% until it crashes.
It seems to happen only when I'm editing the biggest file in my project so far (~500 lines)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtcreator (Ubuntu):
status: New → Confirmed
Eric G. Stern (egstern1) wrote :

Same problem, but the file I'm working on is not all that large (< 100 lines).

Fabian (fmaier) wrote :

do you include something large?
I use the boost::multiarray header in my project, which has quite a lot dependencies. I think that could be more of a problem than a few hundred lines of code.

Eric G. Stern (egstern1) wrote :

Yes, I am using boost::multiarray, and some other include files which pull in a lot of project dependencies. I have both xfce4 and kde desktops installed on my system. I had been preferring the xfce desktop, but I just switched to kde and the problem has not happened yet.

yesint (yesint4) wrote :

It seems to be more stable under Cinnamon 3.0 as well.

Changed in qtcreator (Ubuntu):
importance: Undecided → Medium
koso (koso) wrote :

Experiencing the same. It freezes during auto-completion once boost header files are included.
Backtrace from gdb (attached) shows there is huge recursion before segmentation fault is detected.

pingglala (pingglala) wrote :

i has the same problem too, and i use centos7. once i include a few boost header, qtcreator coredump .god, please solve the problem

yesint (yesint4) wrote :

A kind of workaround is to add qtcreator-git ppa and install the latest version from there. For me it works perfectly.
However it's a shame to have completely broken version of such popular software in LTS.

Lisitsa Nikita (lisyarus) wrote :

Experiencing the same. Crashes / freezes with full CPU load after "Find usages" in quite a large codebase.

Alexis (zarhock) wrote :

Experiencing the same things on Ubuntu 16.04 LTS or OpenSuse Leap 42.1. I'm only working on CMake projects. I'm not using boost but I do have a lot of project dependencies. QtCreator just freezes for 30 seconds to a minute whenever it looks for autocompletion, I'm copying a variable, or Ctrl+clicking on one. It is making it unusable as a IDE. It doesn't seem to crash though.

elichai2 (elichai2) wrote :
DT (delnia) wrote :

I have the same problem!
I can't even write a code because it starts hanging whenever I bring up Qtcreator on ubuntu 16.04. I have Qt Creator 3.5.1
Based on Qt 5.5.1 (GCC 5.2.1 20151129, 64 bit)

MoD (lluna-nova) wrote :

Any workaround available? Does it still happen on qtcreator 5.8 opensource?

MoD (lluna-nova) wrote :

It doesn't happen with QtCreator 4.2.1 with Qt 5.8.0 installed using Qt's installer. Hopefully there'll be a fix soon on the repository version.

Warren Hong (accumulation) wrote :

I have the same problem when qt creator does code completion, for an example I type ROS_INFO.
I have found a solution which may solve your problem.
I change code model from buit-in to clang following tutorials in the below link:
http://doc.qt.io/qtcreator/creator-clang-codemodel.html.
And qt creator does not crash again.
Good Luck!

brice (sharpshooter) wrote :

Same problem "Segmentation fault (core dumped)". Is there any news to why this happens.

brice (sharpshooter) wrote :

Newer version works well. Qt Creator 4.4.0-Qt 5.9.1 or QtCreator 4.2.1- Qt 5.8.0 .

Pander (pander) wrote :

Is this bug still relevant as version 4.7.0 is up next to be packages? See also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=904672 If not, please close this bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.