qthelp not working in Qt Creator

Bug #1356515 reported by jegjessing on 2014-08-13
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
qtcreator (Ubuntu)
Undecided
Unassigned

Bug Description

While trying to access help on Qt Creator I get:
The page could not be found!

Error loading: qthelp://org.qt-project.qtcreator.301/doc/index.html

ProblemType: Bug
DistroRelease: elementary OS 0.3
Package: elementary-desktop 1.349+393~ubuntu0.3.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.13.0-33.58-generic 3.13.11.4
Uname: Linux 3.13.0-33-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Wed Aug 13 20:15:04 2014
InstallationDate: Installed on 2014-08-13 (0 days ago)
InstallationMedia: elementary OS 0.3 "Freya" - Daily amd64 (20140810)
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

jegjessing (jarlgjessing) wrote :
Daniel Fore (danrabbit) wrote :

Qt creator is neither shipped nor supported by elementary.

Changed in elementaryos:
status: New → Invalid
irancplusplus (irancplusplus) wrote :

This is the case in Ubuntu 14.04 64 bit edition.

affects: elementaryos → ubuntu
Changed in ubuntu:
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Sudhir Khanger (sudhirkhanger) wrote :

Qt Creator 3.1.1 from Ubuntu SDK PPA is also broken.

Error loading: qthelp://org.qt-project.qtcreator.311/doc/index.html

xbuntu (xbuntu-w) wrote :

workaround
Open Qt Creator > Tools > Options > Help > Documentation > Add > /usr/share/qtcreator/doc/ choose qtcreator.qch

Dmitry Ershov (edvice) wrote :

Ubuntu 16.04 LTS with Ubuntu SDK from ppa:ubuntu-sdk-team/ppa affected.

packages:
ubuntu-sdk-ide 3.5.1~133+201604191659~ubuntu16.04.1
qtcreator 3.5.1+dfsg-2ubuntu2
qtcreator-doc 3.5.1+dfsg-2ubuntu2

Help in sidebar show error:
"The page could not be found
Error loading: qthelp://org.qt-project.qtcreator.351/doc/index.html
Check that you have the corresponding documentation set installed."

Home page in options:
qthelp://org.qt-project.qtcreator.351/doc/index.html

After
> Open Qt Creator > Tools > Options > Help > Documentation > Add > /usr/share/qtcreator/doc/ choose qtcreator.qch
page loaded correctly.

Paul White (paulw2u) on 2018-08-12
affects: ubuntu → qtcreator (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers