qtcreator slow start

Bug #1174112 reported by minimoog77
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
qtcreator (Ubuntu)
Undecided
Unassigned

Bug Description

minimoog@minimoog-H67M-D2-B3:~$ qtcreator

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_settings_set_long_property: assertion `GTK_SETTINGS (settings)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_icon_theme_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_icon_theme_prepend_search_path: assertion `GTK_IS_ICON_THEME (icon_theme)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed

(qtcreator:5911): Gtk-CRITICAL **: IA__gtk_settings_set_string_property: assertion `GTK_SETTINGS (settings)' failed
void DBusMenuExporterPrivate::addAction(QAction*, int): Already tracking action "Follow Symbol Under Cursor" under id 135
SOFT ASSERT: "str && *str" in file ../../../../src/plugins/coreplugin/id.cpp, line 120
SOFT ASSERT: "str && *str" in file ../../../../src/plugins/coreplugin/id.cpp, line 120
QByteArray ProjectExplorer::runGcc(const Utils::FileName&, const QStringList&, const QStringList&): Timeout running '/usr/bin/g++'.
QProcess: Destroyed while process ("/usr/bin/g++") is still running.
^[T^[^NQByteArray ProjectExplorer::runGcc(const Utils::FileName&, const QStringList&, const QStringList&): Timeout running '/usr/bin/g++'.
QProcess: Destroyed while process ("/usr/bin/g++") is still running.
QByteArray ProjectExplorer::runGcc(const Utils::FileName&, const QStringList&, const QStringList&): Timeout running '/usr/bin/g++'.
QProcess: Destroyed while process ("/usr/bin/g++") is still running.
QByteArray ProjectExplorer::runGcc(const Utils::FileName&, const QStringList&, const QStringList&): Timeout running '/usr/bin/g++'.
QProcess: Destroyed while process ("/usr/bin/g++") is still running.
Qt version is no longer known, removing from kit "Desktop".
Qt version is no longer known, removing from kit "Desktop".

After the long start, when you go to Options there is crash.

On Kubuntu works ok.

Ubuntu 13.04 and qtcreator 2.7.0 (2.7.0-0ubuntu3).

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: qtcreator 2.7.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic x86_64
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Mon Apr 29 01:30:29 2013
InstallationDate: Installed on 2013-01-14 (104 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: qtcreator
UpgradeStatus: Upgraded to raring on 2013-04-25 (3 days ago)

Revision history for this message
minimoog77 (minimoog77) wrote :
Revision history for this message
Sergey Shambir (sergey-shambir-auto) wrote :

I can confirm this bug. For some reason QProcess hungs and always destroyed by timeout; of course, IDE becomes unusable because QProcess required to configure compilers & qmake.

Problem not appear anymore for me after uninstalling KDE. Probably it can be reproduced by installing as many KDE packages as possible.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtcreator (Ubuntu):
status: New → Confirmed
Revision history for this message
alessandro_paganelli (alessandro-paganelli) wrote :

I can confirm this bug, too. I recently upgraded from kubuntu 12.10, where I've installed "ubuntu-desktop" package; everything worked perfectly before the upgrade, from both kde and unity.
Selecting "options" from the menu hangs the program.

The same happens from the qt-creator package (ver. 2.7.0) downloaded directly from Digia.

Revision history for this message
Mikael (mikael-p-persson+lp) wrote :

I confirm the bug as, qtcreator broke from the 13.04 update.

Reinstalling the package by apt-get purge followed by install did not work.

Manually installing the latest version 2.70 from the qt-homepage worksed for me however, given that this is the version supposedly in raring it seems likely error is configuration related.

Revision history for this message
Kevin Cole (kjcole) wrote :

For me, starting Ubuntu SDK from Unity, it takes several minutes to open a window, it cannot find a valid kit, and claims that qmake isn't an executable (and also that the version is invalid). Running qtcreator from the command line gives the attached console log (also with the same results as listed).

However, running from KDE, it opens right up, finds everything it needs, etc.

Revision history for this message
Zoltan Balogh (bzoltan) wrote :

With the QtCreator 3.0 based on the Qt 5.2 many similar issues disappeared. Please reopen this bug if you still find the startup slow on 14.04 or 14.10 releases

Changed in qtcreator (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers