Qt Creator misconfigures itself on first run if qt4-qmake is installed (does not respect qt5-default)

Bug #1135336 reported by Timo Jyrinki
42
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
High
Timo Jyrinki
qtcreator (Ubuntu)
High
Timo Jyrinki

Bug Description

Qt Creator only auto-detects Qt 4 and not Qt 5, if both are installed. If qt4-qmake is then removed, Qt 5 will be automatically detected, although only if the old Qt Creator configuration is first removed.

If you are having this bug, multiple things in Qt Creator configuration may be broken. You can either try to fix the problems manually, or remove the qt4-qmake package and reset the Qt Creator configuration. See below for instructions on both.

== Similar misconfiguration causes ==

The following cases cause some of the same problems, even though they are not related to having qt4-qmake installed:

- Qt Creator may misconfigure itself if a proper removal of the old Qt 5 Beta 1 PPA has not been done: http://askubuntu.com/questions/254800/how-can-i-update-the-ubuntu-sdk-preview-from-the-qt-5-beta-ppa-to-the-qt-5-relea
- Qt Creator may misconfigure itself if not all of ubuntu-sdk has been installed before the first launch. Either the Qt Creator configuration resetting or manual fixing is needed also in case of functionality problems encountered.

== Symptoms ==

Symptoms of having the problem include:
- Not being able to "Run" QML projects
- Getting QML Import complaints when going to the Design tab after opening a .qml file first in the editor
- Missing Ubuntu UI wizard options (this can also be cause by not having the special package ubuntu-qtcreator-plugins from ubuntu-sdk-ppa installed)

== Methods of fixing ==

=== Automatically fixing Qt Creator settings by resetting configuration ===

If you can or want to reset all the Qt Creator configuration:
1. Quit Qt Creator
2. Remove the configuration files: rm -r .config/Trolltech.conf .config/Qt* .config/Nokia*
3. Remove the qt4-qmake package if you didn't already remove it: sudo apt-get remove --purge qt4-qmake
4. Check that ubuntu-sdk is installed: sudo apt-get install ubuntu-sdk
5. Now start Qt Creator, and it should have everything functional.

=== Manually fixing Qt Creator settings ===

You can go through the manual route if you don't want to remove all your Qt Creator settings, or just want to learn about how to configure Qt Creator in general.

As a first step you need to go Tools -> Options -> Qt Versions -> Add... and add the /usr/bin/qmake which then identifies itself as Qt 5.0.0 or 5.0.1. Remove Qt 4 references if you don't need those.

If still having problems, you need to check the Kits tab as well to double-check that the "Desktop (default)" has Qt version "Qt 5.0.1 (System)" set. Not having it set can for example result in Build -> Run being greyed out when having qmlproject like lp:~dpm/+junk/ubuntu-app-dev-cookbook opened.

If the Build -> Run is still greyed out after this when you've a CurrencyConverter.qmlproject open from above link, but Tools -> Options settings seem fine, open the "Projects" from the left pane in Qt Creator. Check that you have a kit defined (use the "Add Kit" dropdown if not), after which you should have the Desktop -> Run tab filled with "Run configuration: "QML Scene" for example. Now the Run should work.

Also the QML Import Path might be broken if qt4-qmake package was installed during the time of first run of Qt Creator. This is shown in the Design tab from the left pane not functioning for Ubuntu UI projects.

TODO: how to reset the QML Import Path from the UI without resetting all configuration?

Revision history for this message
David Planella (dpm) wrote :

In my particular case, it did not detect either of those.

description: updated
Changed in qtcreator (Ubuntu):
status: New → Won't Fix
status: Won't Fix → Invalid
status: Invalid → Confirmed
Revision history for this message
Florian Boucault (fboucault) wrote :

Is it the same as bug #1132600?

description: updated
description: updated
description: updated
summary: - If both Qt 4 and 5 are installed Qt Creator does not detect system Qt 5
- automatically
+ If qmake for both Qt 4 and Qt 5 are installed, Qt Creator does not
+ detect system Qt 5 correctly and Qt Creator configuration gets broken
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote : Re: If qmake for both Qt 4 and Qt 5 are installed, Qt Creator does not detect system Qt 5 correctly and Qt Creator configuration gets broken

It does not seem to be the same as bug #1132600. This is about raring currently, and with the problematic computer we debugged the Ubuntu UI wizard options were there all the time.

description: updated
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Hmm actually it may be related to qt4-qmake again, let's continue there.

Changed in qtcreator (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
description: updated
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

I believe the bug #1134647 that is now fixed for 12.04 and 12.10 users may also decrease the amount of people who get this bug in the first place. Ie. if they just install ubuntu-sdk more sane things get installed.

Another bug fix will be landing soon (2 hours) for precise users so that they can install ubuntu-sdk in the first place.

After that we can start looking at this bug itself, but at least less people should hit it. There might be upstream fixes in qtcreator that fix having Qt5 and Qt4 qmake:s both installed.

description: updated
description: updated
summary: - If qmake for both Qt 4 and Qt 5 are installed, Qt Creator does not
- detect system Qt 5 correctly and Qt Creator configuration gets broken
+ Qt Creator misconfigures itself if Qt4 qmake is installed or if the
+ whole ubuntu-sdk isn't installed before the first run
description: updated
description: updated
description: updated
summary: - Qt Creator misconfigures itself if Qt4 qmake is installed or if the
+ Qt Creator misconfigures itself if qt4-qmake is installed or if the
whole ubuntu-sdk isn't installed before the first run
description: updated
description: updated
description: updated
Changed in qtcreator (Ubuntu):
status: Confirmed → In Progress
summary: - Qt Creator misconfigures itself if qt4-qmake is installed or if the
- whole ubuntu-sdk isn't installed before the first run
+ Qt Creator misconfigures itself on first run if qt4-qmake is installed
+ (does not respect qt5-default)
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Fix submitted to upstream at https://codereview.qt-project.org/#change,52927 and to the Ubuntu qtcreator packaging branch.

Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

And fixed packages for precise, quantal and raring at https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-staging for the moment. I've tested it on precise and raring - on a first run the default of qtchooser is respected now, ie. if ubuntu-sdk is installed Qt 5 always gets configured correctly.

Changed in qtcreator (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtcreator - 2.7.0-0ubuntu2

---------------
qtcreator (2.7.0-0ubuntu2) raring; urgency=low

  * Add debian/patches/prefer_qmake_to_qmake-qt4.patch:
    - With qtchooser, 'qmake' should be the nr. 1 qmake executable
      to consider, since it's the user preferred qmake version.
      (LP: #1135336)
 -- Timo Jyrinki <email address hidden> Thu, 04 Apr 2013 05:56:35 +0000

Changed in qtcreator (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Fix released for raring users. I added ubuntu-ui-toolkit to track when the fixed version is copied over to the SDK PPA (https://launchpad.net/~ubuntu-sdk-team/+archive/ppa) for 12.04 LTS and 12.10 users from qt5-staging where it currently resides.

I've created two more related bugs that are more wishlist type items for Qt Creator development:
bug #1164504: "No automatic reconfiguration / reconfiguration feature when system environment changes"
bug #1164508: "If Qt 5 and Qt 4 both are installed, only the default one gets configured in Qt Creator"

Changed in ubuntu-ui-toolkit:
importance: Undecided → High
status: New → In Progress
assignee: nobody → Timo Jyrinki (timo-jyrinki)
Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers