Kits creation for a project should match targeted framework

Bug #1461026 reported by Didier Roche on 2015-06-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtcreator-plugin-ubuntu (Ubuntu)
High
Benjamin Zeller

Bug Description

When you connect a device which has a particular ubuntu version (and so frameworks), the "Devices" mode tells you that you don't have a kit for that device. This is nice, however, the selected framework is always the latest available (like 15.04), which is optionally not supported by the device.

The suggestion should match the highest supported version from the device.

Related branches

Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
importance: Critical → High
assignee: nobody → Benjamin Zeller (zeller-benjamin)
Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: Triaged → In Progress
Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtcreator-plugin-ubuntu - 3.1.1+15.10.20150720-0ubuntu1

---------------
qtcreator-plugin-ubuntu (3.1.1+15.10.20150720-0ubuntu1) wily; urgency=medium

  [ Alexandre Abreu ]
  * Fix html5 application launch for 15.04 & policy 1.3 (LP: #1471383)

  [ Benjamin Zeller ]
  * Add settings page for project configuration default values
  * Remove QtScript dependency from the manifest.json parser Fix Bug
    lp:1461026 "Kits creation for a project should match targeted
    framework" Fix Bug lp:1461014 "Match application name to click
    package name" Fix Bug lp:1461019 "Default in project creation dialog
    should be a qmake project" Fix Bug lp:1340061: "Some dialogs have
    unreadable (too small) text" (LP: #1461026, #1461019, #1340061,
    #1461014)

 -- CI Train Bot <email address hidden> Mon, 20 Jul 2015 12:53:17 +0000

Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers