Some dialogs have unreadable (too small) text

Bug #1340061 reported by David Planella on 2014-07-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
qtcreator-plugin-ubuntu (Ubuntu)
Medium
Benjamin Zeller

Bug Description

See the attachment. I've seen it in some other places too, but this is an example of the scope creation wizard where the text above "Qt Creator can use..." is way to small to be read.

Related branches

David Planella (dpm) wrote :
Zoltan Balogh (bzoltan) on 2014-07-14
Changed in qtcreator-plugin-ubuntu:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → zbenjamin (zeller-benjamin)
David Planella (dpm) on 2014-07-25
tags: added: avengers
Zoltan Balogh (bzoltan) on 2014-11-24
Changed in qtcreator-plugin-ubuntu (Ubuntu):
assignee: nobody → Benjamin Zeller (zeller-benjamin)
importance: Undecided → Medium
status: New → Confirmed
Zoltan Balogh (bzoltan) on 2014-11-24
no longer affects: qtcreator-plugin-ubuntu
Kyle Fazzari (kyrofa) wrote :

David, do you have a high-DPI screen? I would suggest that this is due to QtCreator's issues with high DPIs. My reasoning is contained in two screenshots. Since I can only apparently attach one item per comment, I'll attach a screenshot of running the SDK regularly (i.e. "low dpi mode" if you will) on a high-DPI screen, that shows tiny (but proportional) text.

Kyle Fazzari (kyrofa) wrote :

Now I'm attaching a screenshot of running with QT_DEVICE_PIXEL_RATIO=2, which makes things a little more readable on a high-DPI screen. Notice that this only applies to MOST of the text-- "Built Targets" is still tiny. Maybe it's a graphic?

Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtcreator-plugin-ubuntu - 3.1.1+15.10.20150720-0ubuntu1

---------------
qtcreator-plugin-ubuntu (3.1.1+15.10.20150720-0ubuntu1) wily; urgency=medium

  [ Alexandre Abreu ]
  * Fix html5 application launch for 15.04 & policy 1.3 (LP: #1471383)

  [ Benjamin Zeller ]
  * Add settings page for project configuration default values
  * Remove QtScript dependency from the manifest.json parser Fix Bug
    lp:1461026 "Kits creation for a project should match targeted
    framework" Fix Bug lp:1461014 "Match application name to click
    package name" Fix Bug lp:1461019 "Default in project creation dialog
    should be a qmake project" Fix Bug lp:1340061: "Some dialogs have
    unreadable (too small) text" (LP: #1461026, #1461019, #1340061,
    #1461014)

 -- CI Train Bot <email address hidden> Mon, 20 Jul 2015 12:53:17 +0000

Changed in qtcreator-plugin-ubuntu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers