Regression: Qt Creator cannot run the executable

Bug #1299441 reported by Jussi Lind on 2014-03-29
264
This bug affects 55 people
Affects Status Importance Assigned to Milestone
qtcreator-plugin-cmake (Ubuntu)
Medium
Unassigned

Bug Description

I cannot execute my application (CMake project) anymore in Qt Creator after compiling. It just says "No executable specified." even though I have selected the run target. This is regression as it has worked before.

I'm using Qt Creator that came with ubuntu-sdk.

Steps to reproduce:

1) Import a clean CMake project
2) Configure
3) Run (and compile) the project
4) Observe that the chosen target starts
5) Close Qt Creator
6) Open the same project again e.g. via recent projects
7) Run

What should happen:

- The selected binary should be lauched

What happens instead:

- "No executable specified." is outputted to the Application Output console. Specifying an executable has no effect.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: ubuntu-sdk (not installed)
ProcVersionSignature: Ubuntu 3.13.0-17.37-generic 3.13.6
Uname: Linux 3.13.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Sat Mar 29 14:17:54 2014
SourcePackage: ubuntu-touch-meta
UpgradeStatus: No upgrade log present (probably fresh install)

Jussi Lind (jussi-lind) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-touch-meta (Ubuntu):
status: New → Confirmed
Jussi Lind (jussi-lind) on 2014-03-29
tags: added: regression-release
tags: added: regression-update
removed: regression-release
Tibault Damman (tibault-damman) wrote :

Deleting the CMakeLists.txt.user file and reopening the project works, but you'll have to repeat this every single time you open the project :(

Basil Random (random-f) wrote :

I confirm this bag happens exactly as described.

Ubuntu 14.04,

Qt Creator 3.0.1
Based on Qt 5.2.1 (GCC 4.8.2, 64 bit)
Built on Apr 9 2014 at 09:12:59

Steve Langasek (vorlon) on 2014-04-22
tags: added: regression-release
removed: regression-update
Basil Random (random-f) wrote :

Deleting the CMakeLists.txt.user not helps for me. The temporary workaround is:
Run Settings -> Run configuration -> add -> select your target, you'll get "<target>2" configuration. And this works until Qt Creator restart.

yesint (yesint4) wrote :

I'm confirming this bug.
I can add that this happens any time when you swith between release and debug builds.
Only the build, which was configured when CMake.txt was loaded the very first time, works as expected. When you switch to another build, which was configured later, you immediately get "No executable specified."
The bug is very annoing and ruins the whole workflow!

rdebroize (rpdebroize) wrote :

Hllo,

FYI I just install qtrcreator 3.1.0 from this ppa: https://launchpad.net/~alexey-ivanov/+archive/qtcreator (build with Qt4.8.6),
the regression is not here anymore.

Basil Random (random-f) wrote :

Thanks!
Alexey Ivanov + QT4 = solution of the problem :)

Basil Random (random-f) wrote :

Oh, it doesn't work on Ubuntu 14.04: when starting says that can't load any plugin... F.e. for CppTools:

Cannot load plugin because dependency failed to load: CppTools(3.1.0)
Reason: Cannot load plugin because dependency failed to load: ProjectExplorer(3.1.0)
Reason: /usr/lib/x86_64-linux-gnu/qtcreator/plugins/QtProject/libProjectExplorer.so: Cannot load library /usr/lib/x86_64-linux-gnu/qtcreator/plugins/QtProject/libProjectExplorer.so: (libbotan-1.10.so.0: cannot open shared object file: No such file or directory)

-- sleepless night + red eyes? No, thanks...

rdebroize (rpdebroize) wrote :

I had no such problem (with Ubuntu 14.04), do you remove the previous version of qtcreator ?

I removed / purged qtcreator then autoclean and reinstall it with apt, and all goes well.

Jussi Lind (jussi-lind) wrote :

Another way to work around this bug is to install the "official" Qt SDK by Digia and use that instead. Of course it's not a solution if some Ubuntu-specific functionality is required.

Basil Random (random-f) wrote :

2 rpdebroize: no, just remove... I'll try to purge/clean later (if this bug will not be fixed soon).

I can confirm that after apt-get purge/autoclean/install qtcreator,
removing CMakeLists.txt.user every time before opening a project
"solves" the problem.

On 04/23/2014 04:47 AM, Basil Random wrote:
> 2 rpdebroize: no, just remove... I'll try to purge/clean later (if this
> bug will not be fixed soon).
>

Basil Random (random-f) wrote :

2 Simon:
I'm sorry, but the last conversation was about using qt4-based build from Alexey Ivanov's ppa...

Rouzaud Denis (denis-rouzaud) wrote :

The problem with Alex's PPA is that it doesn't contain qtcreator-plugin-cmake version 3.1. Therefore, I can't upgrade Qt Creator.
This bug is quite annoying!

Denis (mahrizh) on 2014-05-08
no longer affects: qtcreator-plugin-ubuntu
Rouzaud Denis (denis-rouzaud) wrote :

I have this problem as soon as I checkout a different branch in a project.
The problem also occured with release 3.1 downloaded from Qt website.

seem cmake- only bug

affects: ubuntu-touch-meta (Ubuntu) → qtcreator-plugin-cmake

I also have this problem with a cmake project.

Versions:
qtcreator 3.0.1-0ubuntu4
qtcreator-plugin-cmake 3.0.1+14.04.20140415-0ubuntu1
both amd64

In the previous version it work perfectly, but it is now really broken.

Also a problem with valgrind, which cannot find the executable as well.

Jussi Lind (jussi-lind) wrote :

Hmm...this works for me now with the same versions as mentioned in #19.

Qt Creator 3.0.1
cmake version 2.8.12.2
Using Qt5.

==> affects me as well.

Jussi Lind (jussi-lind) wrote :

I must take back my comment #20. The bug is still there.

Alex (aduliu) wrote :

I'm also having this issue on both ubuntu 14.04 and 14.10 on three different machines. Problems started after I upgraded from 13.10.

The only action that works is to delete the "CMakeLists.txt.user" before every use. This is very tedious.

I assumed that there is something going wrong with this file when exiting QtCreator so I made copies of the file right after it is generated (when starting qtcrator) and after exiting. Replacing the .user file with the fresh one removed the problem (of course untill the next time). I ran diff on the two versions of the file and got the attached results (please not that "racoon" is the name of the project/executable).

I am not familiar with these config lines but they seem so be partly responsabile for the issue (or at least triggering it).

Can someone please have a look? Thank you

john (khartow-elsac) wrote :

It's been more than half a year now since this really annoying bug has first been reported. Has anyone found a good workaround?

Jussi Lind (jussi-lind) wrote :

My workaround is to compile and run in a terminal. Also the official Qt SDK from Digia doesn't suffer from this bug.

I am also affected by this. One more Ubuntu bug that is never fixed. Frustrating.

affects: qtcreator-plugin-cmake → qtcreator-plugin-cmake (Ubuntu)
Felix Haase (haase6000) wrote :

I also have this problem. My workaround is to delete the CMakeLists.txt.user every time, but this also means i have to recompile the whole project over and over again...
Would be very nice to have this issue removed in 14.04 LTS

Felix Haase (haase6000) wrote :

Ok i have solved this problem now by getting an rpm from a different distro containing a newer version (from 3.1.1 to 3.1.2) of

/usr/lib/x86_64-linux-gnu/qtcreator/plugins/libCMakeProjectManager.so

hardydragon (hardikkarelia) wrote :

I confirm this issue from my side.

I'm also having this problem in 14.04, with qtcreator installed from the ubuntu repo. Felix' solution in #28 does not work for me. Installing qtcreator from Qt's own installer worked: http://www.sysads.co.uk/2014/06/install-qt-creator-ubuntu-14-04-lts/

Jussi Lind (jussi-lind) on 2015-03-30
description: updated
Arthur Schiwon (blizzz) wrote :

I saw this issue now with 15.04

Jussi Lind (jussi-lind) on 2015-04-24
tags: added: vivid
Changed in qtcreator-plugin-cmake (Ubuntu):
importance: Undecided → High
Mariano (mg0701tt) wrote :

An alternate 'workaround' for this, (avoid recompiling and using qtcreator external installer) is to create a new run configuration, qtcreator will create the default one even if deleted. But the one created for your self will stay functional always.

Project Properties -> Run Settings -> Run -> Add -> Executable "%{buildDir}/<executable_name>"

Unfortunately there is no executable name variable built into qtcreator so I just give it the real name.

That solved the issue for me without having to regenerate the CMakeLists.txt.user file or download Qt's version.

Changed in qtcreator-plugin-cmake (Ubuntu):
importance: High → Medium
dinamic (dinamic6661) wrote :

i'm having this problem with Qt Creator 3.1.1 in Ubuntu 15.10 wily

victor (vsotofrances) wrote :

Today after upgrading Ubuntu 14.04
the upgrade affects; GNU gcc package, compiler c++ gnu, gnu standard c++ library v3, base ubuntu

The bug appeared.
Qt Creator 3.0.1

It is solved if with qtcreator opened I remove CMakeLists.txt.user then when I open it, qtcretaor asks for reconfiguring...then OK.. I can debug otherwise appears Unknown Error.

victor (vsotofrances) wrote :

Solution of #32 worked for me as a patch

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers