Bluetooth doesn't work at all

Bug #1412246 reported by Saikrishna Arcot on 2015-01-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qtconnectivity-opensource-src (Debian)
Fix Released
Unknown
qtconnectivity-opensource-src (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned

Bug Description

[Impact]

Attempting to use any of the bluetooth classes to interact with attached bluetooth devices will result in no devices being detected and, therefore, nothing being done.

[Test Case]

1. Have a bluetooth device attached and recognized and usable by BlueZ.
2. Write a short program that just constructs an instance of the QBluetoothLocalDevice class (http://doc.qt.io/qt-5/qbluetoothlocaldevice.html), which gives info about the local device.
3. See that the address returned is of an invalid device, and that there are no connected devices.

[Regression]

Minimal. This package handles only the bluetooth and NFC protocols, and the current state is that nothing is detected. With the build change, local devices will actually be accessible.

[Original Message]

The QtConnectivity package was built without the BlueZ headers. Therefore, bluetooth functionality was effectively not included in the binary packages.

Related branches

tags: added: trusty utopic
description: updated
Thomas Ward (teward) wrote :

Marking "Fix Released" in Vivid based on the Debian bug stating this was fixed in 5.3.1-2, and Vivid has 5.3.2-2build1.

The debian bug was referenced to in #ubuntu-bugs, and linked here by myself. Nomination request for Utopic and Trusty was handled at the same time. Timestamped logs below (timestamps are UTC-5) for this:
[2015/01/21 13:25:00] <saiarcot895> Can someone nominate bug #1412246 for Utopic and Trusty?
[2015/01/21 13:25:01] <ubot5> bug 1412246 in qtconnectivity-opensource-src (Ubuntu) "Bluetooth doesn't work at all" [Undecided,New] https://launchpad.net/bugs/1412246
[2015/01/21 13:26:13] <teward> saiarcot895: nominated - confirm that vivid is unaffected before continuing with the sru procedures.
[2015/01/21 13:26:34] <teward> nominated, but not approved*
[2015/01/21 13:27:29] <saiarcot895> Based on build logs, Vivid appears to be unaffected (or rather, fixed).
[2015/01/21 13:28:10] <teward> saiarcot895: if that's the case then we can 'Fix Released' Vivid - but you should check and confirm this, if possible
[2015/01/21 13:28:31] <teward> (standard triage guideline, I know :P)
[2015/01/21 13:31:07] <saiarcot895> teward: Would this work? https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=757271
[2015/01/21 13:31:08] <ubot5> Debian bug 757271 in libqt5bluetooth5 "Might need linking against qtDBus" [Important,Fixed]
[2015/01/21 13:31:25] <saiarcot895> message 10 in that thread
[2015/01/21 13:32:01] <saiarcot895> Vivid currently has 5.3.2-2build1, whereas that was fixed in 5.3.1.
[2015/01/21 13:32:07] <teward> saiarcot895: is that the upstream equivalent bug?
[2015/01/21 13:32:19] <teward> (upstream being Debian)
[2015/01/21 13:32:33] <saiarcot895> yes

Changed in qtconnectivity-opensource-src (Ubuntu):
status: New → Fix Released
Thomas Ward (teward) wrote :

Note this should still be SRU'd, pending Trusty and Utopic nomination approvals, if necessary.

Changed in qtconnectivity-opensource-src (Debian):
status: Unknown → Fix Released

Hello Saikrishna, or anyone else affected,

Accepted qtconnectivity-opensource-src into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qtconnectivity-opensource-src/5.3.0-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qtconnectivity-opensource-src (Ubuntu Utopic):
status: New → Fix Committed
tags: added: verification-needed
Saikrishna Arcot (saiarcot895) wrote :

Tested the package in -proposed and it works.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for qtconnectivity-opensource-src has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtconnectivity-opensource-src - 5.3.0-2ubuntu0.1

---------------
qtconnectivity-opensource-src (5.3.0-2ubuntu0.1) utopic-proposed; urgency=low

  * Add BlueZ bluetooth dependency, so that bluetooth works. (LP: #1412246)
 -- Saikrishna Arcot <email address hidden> Wed, 21 Jan 2015 12:25:34 -0500

Changed in qtconnectivity-opensource-src (Ubuntu Utopic):
status: Fix Committed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Trusty version sponsored to the unapproved queue. This bug will be updated once it's ready for verification.

Changed in qtconnectivity-opensource-src (Ubuntu Trusty):
status: New → In Progress
Brian Murray (brian-murray) wrote :

Unsubscribing sponsors since it's been uploaded to Trusty.

Saikrishna Arcot (saiarcot895) wrote :

Do the merge proposals still need to be approved and the code merged into the main branches?

Hello Saikrishna, or anyone else affected,

Accepted qtconnectivity-opensource-src into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qtconnectivity-opensource-src/5.2.1-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qtconnectivity-opensource-src (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Timo Jyrinki (timo-jyrinki) wrote :

Saikrishna: No need to do anything for the MP:s in particular anymore, just the verification request above needs to be fulfilled.

There will be auto merge to ubuntu/trusty branch of qtconnectivity once the package is in -updates.

Thanks for the work to enable BT via Qt!

Timo Jyrinki (timo-jyrinki) wrote :

I've successfully tested 5.2.1-1ubuntu0.1 on my 14.04 LTS with a BT dongle. The examples from qtconnectivity5-examples start working with the new version, while they did not before the upgrade.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtconnectivity-opensource-src - 5.2.1-1ubuntu0.1

---------------
qtconnectivity-opensource-src (5.2.1-1ubuntu0.1) trusty; urgency=low

  * Add BlueZ bluetooth dependency, so that bluetooth works. (LP:
    #1412246)
 -- Saikrishna Arcot <email address hidden> Mon, 26 Jan 2015 15:37:25 -0500

Changed in qtconnectivity-opensource-src (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.